monome_test_5.patch not recognising my arduinome

  • I am still struggeling with getting the monome_test_5.patch to recognice my arduinome

    First I used an Arduino UNO, then later tried a Sparkfun RedBoard, and not I just got my Duemilanove in the mail, and tried.
    I have been using OSX 10.10 and 10.9, and could not compile owen's serialosc or libomonome.

    I just digget out a old mac I had in my basement with OSX 10.7.5 ...
    I managed to build and install everything ... but my arduino uno is still not detected by serialosc.... is my serial number wrong??

    I can get the UNO card detected by ArduinoSerial (screenshot number two)

    Another thing that is really weird, is that my Duemilanove gets detected fine on windows,
    I can see it in the monome_test_5.patch, I can light up leds, but the buttons are not working (some times there are random keystrokes done even if no cables are attached to the button-pad ...

    On my MAC the Duemilanove gets a weird name, where the serial is not what I set it to in the windows GUI.
    In my mac it is registered as /dev/tty.usbserial-0000101D and does not get registered in either serialosc or ArduinoSerial

    Again, any help would be great.

    PS: If you need any unsped-shields I have like 20 pcs here .... Any help getting along here will result in rewards :)

    1571 x 545 - 237K
    413 x 584 - 58K
  • I'm not of much help here, but serialosc is the sucessor of monomeserial (which a'serial is based on) they don't work at the same time.. if you installed serialosc, you need to stop the service (or uninstall) to use a'serial.. (and only use apps using the old monomeserial protocol)
    also: monomes (what your device wants to simulate) are expected to have a certain name scheme I think, but I guess you have that part in your arduinome building instructions somewhere where you flash the chip..