mlrv newbie - problem selecting driver

  • Help! Have downloaded mlrv2.5, and Max 7. When I fire up mlrv I can connect my 128, but cannot seem to set the DSP driver to Core Audio (I'm running on a Macbook Air, running 10.9.5), it's stuck as None.

    I can load a sample into group one but when I press the grid nothing plays.

    What am I missing?

  • Bump. No-one?

  • i had trouble using mlrv with max 7 (would crash when i'd try to load a save file) so i'd really recommend using the 'ancient' max 5.1.9...

    if you insist on max 7 try setting up your audio engine from the native max menu: ->Options ->Audio Status

  • Thanks, I'll certainly give 5.1.9 a shot.

    FWIW, I think the issue in Max7 that I was seeing lies in the driver subpatch. The options in the two umenus don't match. Adding a print to the output from the patcher in the settings.maxpat yields:
    print: clear
    print: append None
    print: append Core Audio
    print: append ad_portaudio Core Audio
    print: append ad_rewire
    print: setsymbol CoreAudio Built-in Output
    print: setsymbol CoreAudio Built-in Output
    print: setsymbol CoreAudio Built-in Output
    print: setsymbol CoreAudio Built-in Output
    print: clear
    print: append None
    print: append Core Audio
    print: append ad_portaudio Core Audio
    print: append ad_rewire
    print: setsymbol CoreAudio Built-in Output
    print: setsymbol CoreAudio Built-in Output
    print: setsymbol CoreAudio Built-in Output

    It looks (to a Max newbie) that one of the umenus might be hard coded and that Apple may have changed the driver name??

  • indeed - there's a lot of those kind of hard-coded kludges in mlrv in order to improve the visual appearance. so while on the closed system of os10.6.8 & max5 it works better than the native max implementation, obvious problems arise years down the track with updates...

    did you try changing the audio settings in max 7's default options window? i think this might over-ride the in-patch changes in mlrv...

  • Got it working. I'd missed the fact that the included xsample has to be moved. Digging into the patch has been informative. I think you're right about the max 7 defaults.

    Thanks for your help! Now I'm off to have some fun :)