can someone please confirm? app problem

  • hello! i just reinstalled everything from scratch, as per instructions on the docs page. sum up and running, meadowphysics up and running, but with the currently available download from the documents list, when i open mlr (not mrlv but the regular version) and decisions, there is no place where i can click to connect my 64? they are supposed to be current serialosc versions… can anyone else check and see if its my system that's messed up, or if its the currently available apps that aren't working properly? thanks for any help you can give!

  • same for xor, haven't checked others yet….

  • Is it a Max 6/7 issue?

  • happened to me too a couple of times ... I deleted the serialosc bpatcher (which was empty), created a new one with proper argument and connections (like the deleted one). after that it worked again. No idea what's causing this.

  • ok cool, thanks for letting me know that its the patches and not my whole setup...

  • if your using max7 it comes bundled with serialosc.maxpat with its bpatcher offsets 0. 0.

    serialosc.maxpat originally had massive offsets for unknown reasons (o_o), they fixed it finally for the max7 bundled version to make it easier for new users to add it into a patch without having to figure out the offsets.

    consequently, any app released before the max7 bundled serialosc.maxpat, which will override any serialosc.maxpat in the apps folder, now has massive offsets it doesn't need and renders the app unusable until you edit the bpatcher to have offsets of 0. 0.

  • also if your using an app fixed for max7 in max6 you'll strike the same problem. albeit offset wrongly in the other direction

  • one of our current tasks is progressively fixing all of these apps for max 7 (new serialosc) compliance. if anyone has repaired a broken app, please post it back to the wiki!

  • @tehn ah sweet, thanks for the heads up! i didn't realize there had been updates all around that needed processing. hell, i'm still running OSX 10.7.5, trying to escape the reality of updating as much as i can...

  • if you're on max 6 you can download the new serialosc.maxpat (included in max 7) from here: https://github.com/monome/serialosc.maxpat/archive/master.zip
    make sure to drop the whole folder inside of your Max 6.1 directory.

    this info is now updated on the wiki/customize page

    all the max apps should be updated on the wiki application list, so if you're having issues, it's best to make sure you've got the most recent version from the wiki.

  • @galapagoose - thanks man! i'll check it out tonight, and report back if i find anything that doesn't work. appreciate the help!