MLRV 2.5 & Max 7 rewire issue

  • EDIT -My timing on this post was terrible, just saw Stretta's new video! It wasn't uploaded when I started writing my post! Max7 is going to be incredible, can't wait to see what everyone does with it.

    My apologies if this is covered elsewhere, but I've had a hard time finding anything online that addresses my issue. I recently upgraded my computer to Yosemite and downloaded Max 7, MLRV 2.5, and my DAW, which is Logic Pro 9 1.7. The stand-alone mlrv 2.5 works fine except for the rewire and audio driver functions. When I select rewire, or turn rewire on using the button, my audio driver turns off. Subsequent attempts to change the driver, to soundflower-64 for example, will then display ad_rewire driver but will not show up in Logic or allow the driver to turn on. I've tried uninstalling and reinstalling all of the programs, using older versions of MLRV as well as Max 5.19, and I even briefly tried using Logic X but I'm getting the same results. I have moved the xsample.maxpat into the appropriate folders during my troubleshooting and reinstalled ReWire as well. I can't tell if the issue lies in Max 7, Logic 9, or MLRV (though I get the same results with other monome apps I have downloaded so its probably not specifically MLRV). Does anyone have any ideas? I've ensured everything is in 64-bit mode.

  • I just tried reinstalling ReWire again, this time manually placing the 1.8.2 bundle in library/applicationsupport/propellerhead/rewire folder, with no luck. ReWire options do not appear in Logic's auxiliary channel strip input options and the audio driver won't turn on when ReWire is selected in any of the patches I've opened, including the stand-alone MLRV 2.5, Grainstorm, and tml. I'm going to keep trying to solve this problem on my own, but if any of you have any suggestions they would be greatly appreciated!

  • Just discovered the show Max window feature in the stand-alone MLRV and I'm getting a bunch of messages that may shed light on what's going wrong. I've attached screenshots of these. The most pertinent error message I'm receiving is "ad_rewire: error starting audio. Is ReWire mixer running?", but there are others too.

  • i wouldn't worry about the bulk of those messages - they might result in display issues at worst, but they aren't the issue.

    i've actually received a number of emails in the last few days of others who've upgraded to Yosemite and their rewire has broken - it makes me think there's some incompatibility of Max5/6 with Yosemite on the audio driver level. the problem being that it won't be fixed because it's a non-current version of Max. (the mlrv standalone is built with the Max 5 engine).

    you could try Max 6, but I'm uncertain whether that will fix the issue. if you try it though, please report back on your findings.

    re: Max 7, there's been some audio settings changes over the last 2 versions that break the method I used to display audio driver options. in Max 7, go to Options -> Audio Status, where you can change the audio driver options directly.

  • thanks for your help trent!
    i think i found a solution. it seems that selecting ad_rewire in MLRV 2.5 just doesn't work, but selecting soundflower64 does and automatically displays as ad_rewire anyway. in logic the rewire option is still not available, but the 64 soundflower channels are, which can be routed as though they were rewired. maybe Yosemite has tried to make this process simpler? i don't normally use rewire for midi so I'm not sure this is a solution for everyone, but for audio routing this works. in using patches like grainstorm and tml in Max7, it seems better to go to the audio setup menu first instead of accessing these settings in the patches themselves.
    i'm going to download some midi patches & see if i can get them to work too. i'll let you know how i fare.

  • thanks for the info

    re "it's better to go to the audio setup menu first" - totally! the issue was that in max 5&6 this wasn't available in the runtimes, hence adding the settings into the patch.