re:mix {m4l app}

  • a maxforlive performance sampler. inspired by mlr and all it's variants.


    still an ongoing project. new features/enhancements to come. follow the github page to keep up to date on new developments and bug fixes.

  • i'd like to give special thanks to Hiko. without his outstanding help beta testing, it would't be nearly as reliable as it is now.

  • I won't sleep tonight...

  • @elquinto so pumped! many thanks

  • @elquinto congrats and thanks for making it real !
    I've just test it with my 64 non varibright and the sync looks solid as a rock :P

  • Be sure to click the tips button in the setup tab if u have not already. Useful info in there.

  • Been waiting so HARD for this

  • not very max literate, and can't figure out how to get pages working with Live 9.1.3 after I jumped to that update, I'm now on yosemite, and max6.1, since I'm not sure about max7. I will say this, I had no problem with Re:dux.

  • did u check out the zeroconf folder?

  • was able to configure the midi, but still having issues. I installed the gridlock (have no idea what that even is) and changed the settings on Remix to grid. dragged the audio file in. I trigger it once, can't cut it up, only deactivate it, w/o any led response beside the 15th in the top row, and once I deactivate it, I can't trigger it again. Same thing happens when I replace with Zeroconf max patch and change all the settings on the M4L patch to suit the zeroconf.

  • gridlock-vserialosc folder is for launchpad/push users. u need the one in the pages-zeroconf folder. put that in your max6.1/patches folder, then when you load re:mix enable the zeroconfig toggle in setup. i've been using it this way with pages no problem.

  • At this point I'm just trying to use it without pages like Redux worked because I can't even get pages to work, haven't been able to for months. I'll film a youtube and send it to your inbox tomorrow. thanks!

  • yeah, pm me a video. that would help. did u load the group1-6 .amxd's? u need those loaded for the app to work.

    (or at least load the groups you're using. if u only use 4 groups then just load 1-4)

  • -redacted-

  • Loaded a sample on the first slot but nothing happen when I press a button on the second row of the Monome. I'm missing something?

  • Do u have the group .amxd's loaded?

    I need to add this to the readme because i think it's causing some confusion. The Group1-6 .amxd's are the audio outputs for each group. If u don't load them, you won't get audio or led movement.

    re:mix is multichannel so u load these on separate audio tracks

  • worth mentioning (need to add this to the readme too), if u change the color of your group output tracks, the colors on the interface for the corresponding groups change too.

  • @abozzelli
    is live's transport running?

  • I'm at work right now, however, it sounds like he's have a similar problem as I am. Am I wrong here when I say, I thought one of the updates was to be able to use it without the transport running, or that a row press would trigger the transport to run? If not, it can easily be mapped to midi2.amxd I'm sure. I'll let you know more as I get home in a few hours.

  • looking at the screenshot, there looks to be 2 midi tracks and 2 audio tracks, so i'm pretty sure abozzelli doesn't have the group outs loaded.

    yes samples won't play with the transport stopped. it was this way in redux too,

    i think maybe u misunderstand what the midi.amxd's are for. they're for recording your presses into midi clips (and played back into the midi.amxd like automation). there's other ways to use them though, i guess u could map start transport to a button press...

  • I have successfully midi mapped every function I ever possibly wanted in the bottom 128 with midi2.amxd ;)
    So, yes, I misinterpreted, and didn't think to start the transport because of this misinterpretation. Redux, I was aware of this need.

  • ;) I'm not a very bright man. Got it working and discovered something cool! Since I never use the final column in performances, I mapped everything I wanted to those buttons. Setting LiveOSC, and my input and outputs to the Monome IACs, then on the midi track midi to LiveOSC output, I managed to get the midi map to work how I wanted it, with interrupting the performance. Map to M4L patches, now I can launch my Ableton clips and still keep Remix going. Very nice... Thank you for your hard work!

  • can any please check this:

    can anyone record into re:mix ?
    you have to play sound into the input.amxd, then hit 'go' on re:mix.
    you should be able to see the buffer being written.

  • ^may be specific to windows because it definitely works for me.

    If u guys wouldn't mind, please post issues to the issue tracker on github, it makes it much easier for me (and others) to track what issues have been reported and if they've been fixed. Also i get email notifications when issues are reported and u get email notifications back when i reply. It makes the whole process much easier.

  • @elquinto This is an excellent bit of kit! (runs solid on a 128 non-varibright).

  • @elquinto

    SMASHED IT.......


  • did i mention it supports mp3? :)

  • @elquinto Thanks, I forgot to load group.amxd :)

  • OK, so apparently i made some last minute changes before releasing the app that broke a few things- just uploaded the update to github.

  • @elquinto

    thank you for your great work!
    if possible for a future update, could quantize have a on/off midi mapping button?

  • @elquinto

    Hey, really great work man. This is awesome!

  • @elquinto

    The "night" feature is awesome with the new edition grid as well, great work.

    Just sent you a contribution for all the hard work brother.
    You rule, I'll be using this all the time.

  • @PabsArg
    means so much! thx for the kind words and support. :)

  • @sno
    i added a 0 quantize switch (good idea). if u enable midi/key learn you'll see it next to the quantize menu.

  • thank you so much @elquinto! :)

  • been doing a crazy amount of fixes/tweaks over the last few days. i think i've reached the point where i should let u guys know. things seem good now. i'd re-download next time you're going to use the app.

  • spoke too soon. uploaded fix for group stop gesture. holding a button on a row then pressing another to the left will trigger group stop now (except in slice mode)

  • inner loops in oneshot mode fixed now too. quick tip- holding the first pad then pressing the last pad loops the whole sample.

    that's it for tonight!

  • @elquinto
    Thank you for letting me try beta version.
    It was great experience and I've learn many things .
    This app rocks!!!

  • i was off in VJ lahlahland and forgot about this awesome little ditty and a brand new thread!

    is syncing an ableton track onto a monome row/re[mix] group so i can change clips in ableton and then mess around with it on the monome possible yet? i'd gladly contribute to a coffee/adderall fund to make this function happen.


  • @Moldy Wood
    something sort of like that is on the roadmap, but it won't be easy. it's going to take a serious amount of time and effort (and coffee) to make it happen.

  • i just posted an update to github which i think is a pretty good milestone. many things have been fixed / enhanced over the past few weeks. i also included an example audio effect rack to demonstrate some possibilities with the per-row macro settings. hopefully it helps people understand how it works. u place this on your group 1-6 tracks / then click refresh on the group1.amxd for re:mix to gain focus. (if load a Live set with the effect rack already on the group tracks, refreshing isn't necessary.)

  • for the nth time - this is amazing!

    feature requests:
    1)re:"holding a button on a row then pressing another to the left will trigger group stop now (except in slice mode)" - would it be too much trouble to implement a toggle button to choose between this and the way it use to make a loop with this gesture? i'm still deciding which i like more, but i have a couple of songs where i used that 'back-looping' gesture extensively....

    2) would it be possible to implement loading .alc files? i'm imagining there is some kind of proprietary voodoo shield in front of those, but i figured i'd ask.


  • i just made some mistake that made the group stop thing not work in a few earlier builds… didn't realize i created a whole new performance technique, haha. can u remind me what 'back-looping' was like?

    Holding any pad, then pressing the first pad in the row still triggers an inner loop of the end portion of a sample, but i guess that's not what u mean by 'back-looping'?

  • another update (sorry so soon)- i added a pattern-recordable macros toggle, a record length page, and reorganized the control layout for 128/256. (check out the readme)

    just uploaded to github

  • the rule you had for a 2nd held button to the left (but not the 1st button) wasn't new - it was the way it was in the old mlrs. it basically just makes an inner loop the same as if the button was to the right, except you're starting from the further position. for reference your 2/26/15 version of this had that old behavior the way the OG mlrs did.

  • idk in old mlr's i've tried, the 2nd held button to the left (but not the 1st button)always cut off the sound for that group. (but i could still see low freq noise in the vu meter for some reason.) i just took it a step further and made it actually trigger group stop.

  • please ignore me.

  • @hiko Thanks for putting me on. Had some time to troubleshoot why my monome was not interacting with the patch. Once I loaded the accompanying max patches everything functioned smoothly.

    I still need to play with it more in depth. At first glance this app does resolve some issues I was having with mlrV. I will no doubt be spending a good deal of time with this wonderful patch.

  • @holl1f3ld
    I'm glad you are using it.:)
    Hopefully this app will help what you are achieving for.
    I think there are many possibilities with using re:[mix] and Ableton .

    I had many different issues with other mlr apps .(I don't know why.)
    I almost gave up using monome before I found this app.:)