serialosc on yosemite

  • forgive me if this has already been addressed in another thread but i did a search and couldn't find the solution.

    i just updated to yosemite and now i'm not able to get serialosc functioning to enter the /mlr prefix to use mlr. i've reinstalled serial osc into the max 5 folder (which I'm using) and i just installed monome sum. it appears now i have to have monome sum open (which works fine with my monome) in order to open serial osc without crashing. same goes when i try it on max 6.

    whenever i open up serialosc.maxpat i get a blank button [attached]

    whenever i open up serialosc-old.maxpat i get a working connect button with no option to change the prefix. [attached, 2 pictures]

    am i missing something? monome sum and monome test work fine, but i'm not able to set the prefix.

  • I don't know if it's yosemite or what, but I have the same problem intermittently and ongoing. Connection is always hit and miss, and a lot of apps do not show the connection dialogue in presentation mode. And yes, I have followed all instructions.

    For instance, I can run polygomé 104, but 105 does not work (I think I have the numbers right?)... Same is true of many other apps. And a few days ago TPV was running fine with my 64, now it can't connect to it... weird and annoying.

    The things that do work reliably are the fully packaged apps (like the new mlrv). The problems generally arise with the maxpatches in folders. At least, that's my experience.

    Having said that, mlrv does not work with 64 this morning...

    The whole thing is pretty flakey. Great when it works.

  • i think i can help.

    firstly @strettara i think you're having an entirely unrelated to @nosire. start a new thread and we can troubleshoot your setup to hopefully get passed any flakiness you're experiencing.

    @nosire
    ok -- first up i'm guessing there's some confusion regarding how serialosc works vs the older monomeserial. serialosc runs in the background and doesn't need it's own application open at all. you don't even need to worry about the prefix, as that's all handled under the hood. all you should need to do is open your serialosc-ready patch and select your device from the dropdown (the new version of serialosc will even autoconnect to your device so you shouldn't need to explicitly connect at all).

    that being said, it looks like there's a few issues happening:
    1. needing to have sum open. this sounds like monome_sum has changed your .maxpat file preferences. this is a bug in max standalones though it's easy to fix:
    - go to your mlr.maxpat (or any other .maxpat file)
    - control-click and 'Get Info'
    - under 'Open With' it will say monome_sum. change this to Max 5 /6 whatever
    - press 'Change All...' and your max patches will now open with Max (rather than monome_sum)

    2. the new serialosc.maxpat:
    first thing to note is there isn't a 'connect' button in the new serialosc. you simply select your grid from the menu and it connects. when it launches it will also connect to the first device listed. the obvious issue you're seeing is that the text is white! this is the default for max 7 (which the new serialosc.maxpat was built in) so i made an alternative version for old versions of max here which just has the background set to dark grey like Max 7. replace the file in the max5 folder (you'll still need the rest of files in the serialosc folder though).

    3. now onto getting mlr to work with your setup. which version are you using again? does it have the serialosc.maxpat selector inside, or does it still require you to use monomeserial? if the latter, it will have a little button that says '/mlr' to set the prefix like the old days. if that's the case, you don't need to edit anything, just run monomebridge to connect via serialosc (http://monome.org/docs/app:serialosc:monomebridge). you'll need to set the prefix in monomebridge to /mlr and select your grid from the dropdown there.

    ~~////

    let me know how you go and i'll try and help if there's still issues.

  • oh yes, monomebridge was what i was using before the upgrade to yosemite. i'm running mlr 2.56 and i don't think there's an auto /mlr button. so now i just redownloaded monomebridge.

    my mlr auto connects with max 5 as usual. opening monomebridge with max 5 brings up either a blanked-out drop down or it shows this [attached photo]. so far as long as i open mlr and monomebridge with max 6 or 7 then everything appears to work fine. it's no problem to switch to 6.

    question, since it's a 30 day trial and there's no runtime for max 7, does that mean mlr sets won't be saved?

  • woah that patch looks weird. normally caused by not having quicktime installed on windows machines. maybe there's some issue with max 5 backward compatibility? does mlr also have those weird greyed out boxes in 2.56? if it looks fine, then i guess patches saved in 7 are no longer able to be loaded by 5.

    which version of 5 are you using? i'd recommend 5.1.9 (the final version) if you want to stick with 5.

    honestly though, max 7 is probably just as good a bet. you might notice that files sound a bit different when pitched down in mlr though as max7 has interpolated sample playback now (the non-interpolated pitch shift is one of those nice gritty mlr sounds though that i've always liked...)

    don't worry about the different between a 'trial' and 'runtime'. basically the 'trial' is like full max, and once the trial expires it becomes 'max runtime'. you can't save *patches* but you can freely use any file save/load inside a patch. it's the same as using runtime.

    since you're using 2.56 you'll need monomebridge, but you don't need to open serialosc.maxpat and change prefixes in there. just click the button in monomebridge and set the /mlr prefix there.

  • thanks a lot for the help and detail. It was 5.1.9. i've been meaning to update my software so if things work then they work. using max 7 will be an exciting adventure.