40h kit: the lights aren't on, but somebody's home

  • Hi

    I've built up the 40h kit, but it's not doing much.

    I use XP and have tried this on two systems, one XP pro with no firewalls or anti-virus, the other is XP home with all the security & stuff. I have also tried this with Max 4.6 and 5

    I also wrote this out once and got logged off by the website... :(

    FTDI seems installed correctly - there an extra bit of USB and an extra serial port: the drivers are attributed to FTDI and it all happened pretty much like their instructions.

    Monome_serial 0.2.1.2a is installed although it seems a bit wobbly - occasionally it fails on start up (as covered in other threads) and sometimes checking the ADC or encs sends it in a flat spin. It seems to get there in the end.

    Monome_test opens in Max like you'd expect it. The prefix button changes the setting in monome serial from /40 to/test and monome serial app picks up a monome number (ending 969) presumably from the FTDI.

    No LEDs come on at all. There is a test check box mentioned for monome serial in one thread which is not apparent in my version. The ADC sliders and enc values in monome_test do not do anything. Clicking the grids does nothing, pushing the buttons does nothing.

    I have been building hobby boards for a long time and think the soldering's OK.

    I soldered the SMD diodes as per attached PDF and used T1 package LEDs as per other PDF with short leads = cathode and long lead soldered to left as per assembly instructions.

    I've spent half a day going through the forums and have drawn blanks. I would appreciate some help on this.

    Thanks.

  • After some reflection, I'd appreciate some comment as to whether the logic board can be tested independently of the grid PCB. It looks like it from the monome_test patch.

    I attach a few more pics of the boards and their soldering...

    Regards, Chris.

    500 x 375 - 168K
    500 x 375 - 166K
  • do you get a startup pattern when you plug it in?

    there's a possibility you have a bad atmel chip. e-mail me tehn monome org if so.

  • I have not had any LEDs light up at all...


    Regards, Chris.

  • Thanks for the replacement chip. Now it lights up and wiggles its ADC inputs and everything. Hurrah!

    There's one rogue LED, which can be switched on from the test software, but button pushes don't make it switch.

    For the record, the LEDs seem to have an interesting variation in their colour. They're all white, but some are more cool white than others. Not a show stopper, but worth noting.

  • LED variation has to do with manufacturing quality. if you bought cheap LEDs, there's probably a reason for them being cheap.

    the one problem LED is actually a keypad problem. check the diode solder, possibly replace it if necessary.

  • I thought they were mid-price LEDs: about 30 + pence each, which was probably about 60 cents - branded as Osram, which is a known name in lighting.

    I'm happy with the variation at the moment: if I want better, I guess I could pay big bucks for Nichia or something - that would be about the same as the kit. Or maybe go for a more traditional colour...

    I'll get on the errant diode in the next couple of weeks.

    Thanks for the support.