tintinnabulome

  • nigtmorph-
    since tintinnabulome produces only midi-events and no audio, the only way to record midi/audio is in a DAW of your choice. Or at least in any audio recorder application, just as you would record your microphone..

    Tintinn--> Synth ( DAW/Standalone)--> Recorder (DAW/whatever recorder)

  • I know; I was hoping to use the system sound device to not only produce the sounds I hear in my speakers, but to record it, without having to run a cable from the line-in to the line-out; I imagine I could get some feedback that way.

    I tried SoundFlower, but still can't get a working setup with Audacity that lets me hear what I'm recording, even with software monitoring activated. I'm calling it a night; maybe I'll have a better understanding of how SoundFlower works with Audacity tomorrow.

  • nightmorph, if you don't have a daw, download reaper and then pipe the midi from tin into that. that is the easiest way to record your noodles...

  • if you're on mac, might i suggest AU Lab? i believe you need to have the developer tools installed, but it's a great little tool for simple setups. and it lets you record the output ;)

  • So... who's gonna serialosc-ilize this? Please and thank you!!?!

  • weird! just tried to do that. failed miserably. :)

  • Here is a beta of a serialosc conversion. I'm not sure I got everything, so someone who is more familiar with the current state of this app should test it. Also, I didn't touch tilt as I haven't done tilt with anything serialosc yet

    New features added:

    integrated VST instrument host - there is a vi check box at the end of each voice that allows you to selectively route midi notes to the vi host. I tested this with the free UVI plugsound thing.

    integrated VST effect - follows the instrument host. Tested this with Eos.

    you can set the volume level and output destination.

    integrated sound file recorder. hit the open button to specify a file to record into, then click the toggle to start and stop recording.

  • thank you. I'll test it tonight.

  • Thanks!!! Will give it a go today.

  • Thanks for keeping this great app up to date. I look forward to making the conversion over to serialosc when time opens up this summer.

  • I'm still in the old- fashioned Serial style. I think I will move to OSC world over this weekend. I will check this latest update, if everything is working propertly. Thanks stretta for doing this !

  • Ok, I'm up to date now.

    Everything works fine, except a bit messy velocty page.. fixed.

    BTW great vi implementation and quick recording-ability, great features stretta !

    ------------
    V 0.96b

    - Fixed: Velocity page works now

  • Hi,

    tintinnabulome 128_1.10 recognizes my 128 walnut as monome 64

    Using serialosc1.1 or 1.2 and serialosc bridge

    Any suggestion?

  • great serial osc update!! Thanks. problem is I got no lights, all else is good. All works in monome test? I have re-booted the app and mac a few times and still no leds? Any help gratefully received monomers

  • Double bump??

  • Triple bump?

  • Quadruple bump????

  • as' last post was in 2011, btw. Let us know what you see when you look at the osc messages out, compare them to the monome test messages and osc protocol http://docs.monome.org/doku.php?id=tech:osc

  • I don't have my monome hooked up right now, but taking a very cursory glance at the source code...

    The only message that gets sent out to serialOSC follows this format:

    (/tin/grid/led/col $1 0 $2)

    That's the correct protocol. Totally in line with serialOSC; not MonomeSerial.


    Pulling the SerialOSC bpatcher up in the patch inspector, and clicking "edit" on "arguments", we see: "9001 /tin" (no quotation marks)

    /tin is correct. 9001, I'm not sure about. Guessing that's a manually assigned port number? I'd try dropping that.

    (change "9001 /tin" to just "/tin" and see if that works better)

  • Will try thanks guys ;-)

  • I can't believe I just found this app. Just checking - Has anyone serialosc'd the 128 version? I see stretta & as did a nice job of getting the 64 version up to date, just curious about the 128....

  • Be awesome if there was a 128 version!!

  • is anyone else still interested in a serosc of this for 128 and 256? i know i am...

  • 256 version! For sure interested.

  • 100% interested

  • i ported tintinn128 to serialosc over the weekend. i've wanted to try this app for a while.

    attached zip-

  • good effort! Tintinnabulome needs to be on the docs!

  • Glad to see this app is still up and running in the community!

  • I only have max runtime I'm afraid.
    Would somebody kind please post up a 64 version?

    Thanks very much. I'll buy you a pint if you're in Bath

  • I love this app but can't get it to recognise my new 128. Using the new 1.10 serialosc port. loads into max 6.1.9 runtime fine, but there's nowhere to set my grid. Any ideas?

  • yeah, i think i know why. its because of the new serialosc.maxpat's offsets.

    here's a quick fix

  • Thanks for that and it does now recognise the 128. I don't know whether I'm doing something dumb but it seems to just see the 128 as a 64 so it only uses the left hand side and it's in the wrong orientation (rotated through 90 clockwise), where am I going wrong?

  • It was already this way before i did the serialosc port. U can rotate your device in the serialosc box to make it the right orientaion.

  • OK, thanks, i've only ever used it on a 64 before now. I'm having one of those nights! Now I can't get the serialosc maxpatch (from 9Jan2015) to recognise my grid (or do anything at all). So irritating, seems to be a million versions of everything. Some nights monome is a dream, some it's a bit of a nightmare. Ah well

  • thanks, @elquinto. tried the new version after having the same problem as HateNames. my 128 (latest version) does not show up in the list. it connects to monome_sum just fine. any ideas?

  • idk…. mine shows up and connects fine. if you're using the new js-based sosc.maxpat (jan2015version?) , it doesn't have a way to rotate so i wouldn't use that.

    i use the version prior to that. i attached it for u if u want to give it a try.

  • cheers, @elquinto! using this version of sosc works. my new 128 connects just fine. now struggling to get the app to do something. will read up on the docu first and then try again.
    thanks for your help!

  • @elquinto, ok so maybe today is going to be a good monome day! that version of serial osc works great, thanks so much.