npc - no sound yet

  • Thank you peterflat for what looks like a really nice and compact app. Installed it on an Intel mac with max 5; when i drag a waveform under "Voices" the said waveform image does not appear, and i get no sound either : audio is on, dac is on... no luck.
    (tried also on a G4 mac with max 4 runtime, no go either...)

  • hey brian,

    have you generated the sounds? there's an extra step that makes it slightly less than intuitive. go to the options menu and generate a page of sounds. this first page will just map the sounds you've loaded to each of the monomes pads. after that you can recombine multiple voices to one pad and generate more pages... hope that helps!

  • thanks peter,

    i'v gone through the steps of generating a page of sounds; no go. What is curious is that any wavefile i drag in will not show up in the window. Can you see your wavefile image in the window ?

  • ya, usually you should. just as a precaution, some people have had success getting npc to run on max5, but it isn't officially supported yet. do you get a waveform when you pull down from the list of wave files you load in? what does the max window say? are there any errors?

  • i do get the waveform named in the list. Found the error in max window says :
    "can't open can't find file x" although the path for it is like dead simple.

  • ah, you might have set the preference in the _prefs.text. the 2nd entry:

    "use full path for audio files 0" change the 0 to a 1.

    it's set up by default to use files in your max search path. does that fix it? if that doesn't please load some files, select the max window and hit apple-x (this will grab the window contents) and then paste it here so we can see exactly what's going on.

  • works ! put a 1 in the place of 0 in the path; get sound now on the pads but NO wavefile image in the window; this is the max window info :
    js: NPC
    js: peter segerstrom
    js: http://flatflat.org
    binding to port 8000
    vst~: can't find plug-in, using default
    vst~: The 1 parameter of Default is:
    vst~: P1
    vst~: can't find plug-in, using default
    vst~: The 1 parameter of Default is:
    vst~: P1
    vst~: can't find plug-in, using default
    vst~: The 1 parameter of Default is:
    vst~: P1
    vst~: can't find plug-in, using default
    vst~: The 1 parameter of Default is:
    vst~: P1
    vst~: can't find plug-in, using default
    vst~: The 1 parameter of Default is:
    vst~: P1
    print: 120
    npc_file_load: blinded.aif
    npc_file_load: store file-count 1

  • @brianvega

    to get the waveform at that point, press the pad so you get a sound, then press the 'v' key to go into the voice edit mode. Congrats you are ready to rawwwk!

  • i'm actually having a very similar problem... the first fix helps, but the waveform isn't fixed (as a side note, i just downloaded npc; you may want to check the file pack you've released to make sure that the "use full path for audio files" is set to 1 in the .zip pack). also, npc is refusing to load some files. I get one of two messages: either
    Unknown Track-16.wav: bad magic number
    coll: error reading Unknown Track-16.wav
    when loading a sample or
    groove~: no buffer~ Unknown Track-4.wav
    when trying to play a sample that actually loaded. It seems to be random. Any suggestions?

  • @brian glad it's working. as jonbro points out. you have to hit v or the enter key to select a pad for editing. i have been thinking about it.... would it be easier/simpler if you just hit the pad and it popped up for editing?

    @sursiks - thanks for the tip, i'm about to do another version so i'll fix that. but ya, the full file path thing can have some wierdness with wavs that have spaces in their names. try different files. on a side note, i have never seen the bad magic error number. that's some reallly wierd max stuff. what's yr system?