Did I just fry my Logic Board?

  • Long story short:
    1. I was upgrading the interface cables, trying to incorporate a proper solder header.
    2. After that was done, one full row was incapable of sending switch messages to monome_test, in the base package.
    3. Proceeded to I guess carelessly use my multmeter to test for connectivity between various multiple points in my buttons breakout board. I could send switch messages, and light-on messages fine by short-circuiting various points.
    4. Sometimes I shorted some points which made a whole column light up, and flicker. I would see some "out of range" error in the MaxMSP console.
    5. Suddenly, I lost the whole left-half of my 40h; the first four columns just don't respond to anything, even software based messages, sent within monome_test.
    6. whenever I push anything in the left half, the right half responds as it were the left part: say I push the second button from left to right, in the second row - the second button from the second row _in_the_right_half (meaning, really the sixth button in that same row) responds!
    7. whenever I push anything in the left half of the 40h, this error appears in the console: "error: matrixctrl: cell coordinate(s) out of range"

    tried restarting the test patch; tried restarting monome_serial, tried restarting the mac. Nothing!!

    did I just fry my Logic Board?
    tehn, anyone?

    thanks,
    -h

  • FALSE ALARM peeps.

    I think the casing for the logic board was shorting something in the little USB board. ... all I did was reseat it, unplug all cables, shut down the laptop for a while. Also unplugged the ATA cable I'm using.

    Things are back to where I left them.
    Still bummed without a full row ... quite depressing :(
    Soft switch and soft light-on work, unfortunately something happens at the interface level ... won't work, nomatterwhat!!

    well, ok, thanks anyway.
    -h