40h, one button is lit but doen´t respond to press

  • Hello,

    as i metnioned in the topic one button in tthird row doesn´t respond to keypresses but the LED just works fine.

    i really have no idea what i have to do know.

    anyone out there with an idea how this could happen?

    Thanks, hr

  • the diode is probably backwards.

  • hi,

    it worked fine since i got it and everything is fine except that it doesn´t do a thing when it gets pressed.

    I just don´t have a clue where i could start searching for an error, it can´t be the diode ( i think).

    thanks

  • So it used to work, and then it stopped?

  • diode and light emitting diode (LED) are not the same thing.

    the diode is the little surface mount part that prevents ghosting.

    http://www.dribin.org/dave/keyboard/one_html/

  • @ JP

    yes, it used to worked and stopped.

    @soundcyst

    thanks for this info. Not that i know how to handle it, but hey ... ;)

  • Can you take it apart and see if you can short that button pad on the pcb so it fires a button press.

    Next step is to isolate the context, is it the rubber button, or the pcb, or something further down the flow.

  • How can i short the button? sorry, but i´m a bloody noob with such things.

  • When you have the buttons off you'll see a sort of zig zag pattern on the pcb, very gently touch something metal to the inside and outside bits of this pattern (gently so you don't scratch anything). I'd use a piece of wire and just touch one end to the inside one to the outside... see if a button press gets fired.

    If it does. It means there is something wrong with teh rubber button and the bit of black stuff (is that silicon) on the inside. If nothing fires you know the issue is more "inland".

  • JP's on it.

    if it was working and then stopped, it's definitely not the diode, as you said.

  • Its totally possible the diode actually feel off from a bad solder connection assuming you have a kit ( happened to me a few times :P )

  • check the star pattern for bridges-- any sort of conductive material between the inner and outer lines. this causes the key to be read always as "on"

    you might try replacing the diode.

    this is a kit, correct?

  • hello,

    sorry for my late reply, i was on christmas vacation for two days.

    i´ll look into it the next days.

    @then

    yes, it´s a kit. it´s just that i have no soldering experience or equipment. i´ll have to ask a freind for some help.

    thanks for a llthe replies and tips so far.

  • Hello,

    i finally managed to dissemble the 40h but from the looks it seems to be ok, no broken or otherwise damaged parts.

    however, i noticed one strange thing while using "pages". I loade the "midi trigger" page and started to learn them some notes on ableton.

    Now, the button which does not work via OSC works very well when i want to use it as a miditoggle!!


    Isn´t this strange or am i missing something obvious here?


    Cheers, hr