[update] mlr2.51+ w/ delay and more...

  • hi folks,

    here is a small update for mlr2.51 put together for daedelus to further escape from the laptop during performance. it includes a modified version of the delay patch from mlrV to add one more effect to the 64+accelerometer

    ::changes::

    + buttons 15+16 dec/inc preset respectively
    + buttons 13+14 dec/inc octave of all samples
    + button 12 is a 'retrigger' button that restarts all 4 groups from the most recent press
    + button 11 is a delay send


    + the button above the 2 filters is now a delay function
    + x-axis controls delay time
    + y-axis controls feedback from 30-90%

    + GUI has also been cleaned up
    + all volume faders load to unity gain (the dashes) on load


    hope that this helps the few that are using this version of the patch. i like the idea that a few different programmers can add an effect or two here and there => perhaps something out of dj64 could be next?

    trent.

  • OMGOMGOMGOMGOMGOMG
    OMGOMGOMGOMGOMG
    OMGOMGOMGOMG
    OMGOMGOMG
    OMGOMG
    OMG

    thanks!

  • It is a fun new couple of button pressing (mashing) alterations. Big thank you to Enjoi - Trent for taking moments to do so. As ever keeping all programming minimal and musical!

  • (edit:hangon, is the download link missing?)

    Excellent stuff! very nice sounding functions. I was just about to ask you about the details of this mod you made for Daedelus.

    I'm working on a simple mlr mod myself right now also which i think complements these new bits very nicely: the idea is that if you're holding a specific midi note (probably via a footpedal) while pressing a button, 8 is added to the x coordinate that gets sent into the system. Giving you access to 16 'columns' even if you're using an 8*8 monome.

    I'll have a go at merging my thing into this new version tomorrow.

  • embarassment abounds....
    sorry for forgetting the download link - i'll drop it on the wiki as well.


    @bitbutter:
    great to have met you last night. these are the few simple additions and modifications that i made for Mr Darlington, and I think they are quite intuitive and useful additions. i musn't take too much credit though as I was merely the tool in the machine w/ the Max skills.

    certainly still interested in our short discussions on allowing version control and essentially self-compilable versions of mlr that take advantage of which ever features an individual so desires. mlr a la carte. i fear the result might be a long way off though.



    *whisper*
    the new and highly updated mlrV is on the way... i have been procrastinating greatly of late but give a big thankyou to daedelus, bitbutter and the inspiring crew conspiring in rotown.

  • thank you so much!! i've been waiting for more additions to this...its the only mlr i use! lol

    is it possible to also add some more effects? like a kaoss pad would do?

    thanks again!!!

  • >*whisper*
    the new and highly updated mlrV is on the way... i have been procrastinating greatly of late but give a big thankyou to daedelus, bitbutter and the inspiring crew conspiring in rotown.

    joyous news!

  • @enjoi: Thanks for the link. Dloading now.

    Very curious about the new mlv.

  • wow...! thanks enjoi. this looks like a thoughtful set of alterations. i shall test tomorrow!

    thanks again.

  • This is awesome! Thanks so so much!!!

  • Need to check this out soon! Looks cool.

  • I got really excited about this, but of course i left my apt for the next 3 days, and am without my 128.

    In my excitement, and being a HUGE max5 presentation mode junkie, i went ahead and made strictly cosmetic additions to the patch. I know this is totally silly, but just in case anyone who uses max5 (or runtime) wanted to see something different (more compact, and colorful really) this is what i just spent the last 30 minutes doing.

    i don't THINK i touched anything, so it should be exactly as functional as yours, enjoi. of course my baby is miles away, so i haven't played on it yet, BUT I CAN'T WAIT.

    thanks for such great work. and again, this is totally silly, but it's optimized for a 128 (eliminated extra tracks).

  • good work! how many extra tracks!!! like the way it opens up with the levels for dac and groups up!

    need to sort this bloody tilt on my arduinome! could have delayed tilt goodness!

  • @sonicadroit:
    it's always a fun project for me to clean up big messy patches into a tightly organised patch of goodness, and i especially like the 'plugin' look of your modifications.

    it also occurred to me, during the making of these few modifications, how much easier, faster, and more intuitive it is working in MaxMSP5. After adding keystrokes to create new objects, floating helpers on inlets and outlets and a super simple inspector w/ lots of neat features - it seems almost silly to operate in the Max4 environment. i guess part of the legacy flows from that particular design, but personally after what is nearing on 1 year of Max5 patching I can hardly imagine all the time i wasted on trivial little tasks in Max4.

    anyway - this forum is for the monome related things, but i just felt the need to say at least a few words on why i recommend people to look past their love of the old pixelated patcher and embrace the joys of Max5.

  • I can't get this version to work with my 40h. I set it up just like any other version of mlr and the kill buttons light up but I can't get any sound or any lights below the kill buttons. Any thoughts?

  • this version requires 2 monomes (or a 128 or larger running quadrants). the 2nd monome is required to turn up the volumes to start the audio.

    as such it will be quite difficult to run 2.51 on a single 40h. you could of course change the prefix in monomeserial to 'mlr-aux' to set the volumes, and then change back to 'mlr' to play your samples, however i'm pretty sure this defeats the purpose. the only real change to mlr2.51 is the added use of the 2nd monome for tilt functions and volume display, and the only changes i made were to add controls to the 2nd half of the top-row on the first monome.

    In summary:
    2.27 is still the best 'standard' release of mlr.

  • So for the life of me I can not get this to work. MLRV works just fine for me and so does the MLR3 preview and the 2.27. The problem I seem to be having is that I get it all set up but the it will not play when I hit the button on my 256 (although the button in the group section lights up along with the first button on the row I presses) and the mlr-aux is not doing what it should, the 64 seems to be lighting up corectly but mlr is not responding in any way.....

    anyone else having this trouble?

  • got this trouble too with the 2.51.1+, just like your problem. Will try with a different max version.

  • drhiggens> problem solve this the demo of Max 5.0.6 and not the runtime. Maybe try that ?

  • sadly no I still cant seem to get it up and running.... humm

    I am still having the same problem but only with the 2.51 series of mlr all the others work fine.... but none of the other ones will allow me to control mlr features with a 64 and a 256.

  • i've run into the exact same problem...

  • " * CommentAuthordrhiggens
    * CommentTime9 hours ago


    So for the life of me I can not get this to work. MLRV works just fine for me and so does the MLR3 preview and the 2.27. The problem I seem to be having is that I get it all set up but the it will not play when I hit the button on my 256 (although the button in the group section lights up along with the first button on the row I presses) and the mlr-aux is not doing what it should, the 64 seems to be lighting up corectly but mlr is not responding in any way.....

    anyone else having this trouble? "

    me too, exactly, for the 256

  • yup. me too, same thing.

  • yeah i have had the same problem too since ive gotten this macbook pro. i had it once on my dell as well...and now max is telling me i have a "grooveduck" error...if you search the forums for 'mlr 2.51 problem' i state that, and someone told me to google it and i would find my answer. although im not great in max..i couldn't fix it.

    anyways im using 7up for now..probably will get back to mlr soon.

  • somehow i missed this thread. i wanna check this version out as i have a 40hse that's not being utilized to its fullest! (the 256 gets all the love lately)

    i like the idea of adding more effects to it too. taking some out of dj64, perhaps. and the earlier mlr (or mods to it) is what i love. i like that this has mappings to inc/dec by octaves, but i've already got a "page" on my 256 that does that (and reverse). still, great work! stoked to check it out...

  • i think it'd be cool to have a new page in the 64 half of this app with dj64 effects. how would one go about doing this?

    also... how does one make this app work? haha, i've been trying for 2 days now with my 256 and my kit 40h. a lot of us are having the same problem... has someone got it working yet?

  • i would love to help folks but unfortunately i only have 1 monome! i know daedelus has this working properly on his unibody MBP, so i don't think it is the computer system.
    the patch was put together in maxmsp4.6.3 so perhaps using the old max4 is actually less likely to cause any problems.
    grooveduck is a loop-crossfading abstraction for groove~ which stops the 'clicks' when you use inner(2 finger)loops. i've never used it though, so no help.

    if you're main symptom is everything looks like it works except the light turns on and starts at the beginning of the row >> this is what happens when dac is not turned on (i think). the button may be pressed, but make sure to look in the dac settings as if your audio interface has been de-selected somehow, clicking 'dac' will not actually turn mlr on. i know this is quite simple and is probably not the problem, but sometimes its the silly things that catch us up...

  • can we get a brief explanation of how to get this up and running? i'm a bit in the dark on how to get going with the normal 2.51 version, before the delay was added.

    also, do i need to set the prefixes or the port numbers to different values on my 40h (with accel) and 256? they seem to both be the same. so when i press buttons on one, the other shows the same behavior (i.e. standard mlr is happening on the 40h, instead of some tilty goodness). i can't get the tilt setup to recognize the 40h either (yes, the adc toggle is clicked in mlr and monomeserial) but i suspect this is because of a port/prefix conflict...

  • 256> /mlr

    40h or 64 : /mlr-aux

    Don't forget to enable ADC port in Monomeserial for your 40h/64.

  • nice! well that got me started, at least. the accel is *sort of* controlling the filters. i have no idea how things are mapped tho; pressing the upper-right button and tilting slows down the tempo as well as the filter. pressing the others on the rightmost column effect just the filter. no idea of the correlation; nor what the lights are doing. is there any documentation on this anywhere?

    there's a lot of lag too when i tilt left/right for the filter to move. is that normal or should a fast tilt move the filter quickly?

    again, i'm using a 40hse with accel, not a 64.

  • is it necessary to have the tilt function? my 40h has no accelerometer yet... should it work even without it? 'cause i'm still having problems... enabled every ADC port in monomeserial but still, nothing...

  • w/o an accelerometer you will be able to use it to control volumes and have a VU meter etc.

    you should only need to activate ADC 1+2 on the 40h

    on the 40h/64, the far left row:
    1>> tempo shift + retrigger upon release
    2-5 have no effect
    6>> delay
    7>> filter (lowpass?)
    8>> filter (highpass?) > hold both hi+lopass for a comb filter

    just hold the button and tilt > as to the 'response' of the accel. i'm afraid i can't weigh in on the matter.

    the leds should show the x and y parameters
    from my recollection the params are not directly correlated to the value of the tilt, but rather moves and bends towards the direction you tilt >> kind of in an acceleration sense and not just a particular angle equaling a certain parameter value.

    hope these little snippets help, but it is a little hard for me to give a detailed response w/o hardware to test it on.

  • i need some help setting up the 256 with a 64. can someone list the steps i do for the 64 to work properly? thanks in advance!

  • i got my 64 working as an aux. only one problem, though.

    i can't play my samples. my DAC is on and the tempo blinker is blinking, but no sound. the group lights turn on, but the rows of the samples are not moving or making any noise.

    any clue why?

  • are you running in max5 or max4? i think even the old versions of mlr won't work with the new max runtime due to a stack overflow.... a simple fix but due to how many versions there are, a big effort!

    try using max4

  • Great update! too bad I'm too stupid to figure everything out.
    can someone post some tutorial video?

  • @enjoi

    when you say a simple fix for stack overflow, can you explain what you changed? I'm new to max and interested how you would trouble shoot such a problem.

    tnx for any help

  • Sweet, I only just peeked at it, but it looks like it's a lot better. I liked features of mlrV like delay, but didn't like how it looked exactly. Putting it on the tilt axes is pretty smart too, it allows us to keep the modifier buttons on the monome.

    So this changes quite a bit, more than it seems.
    Thanks.

    Hmm Im getting problems too. I don't have time to read through everyone elses stuff right now, but I'll post my problem. I dropped in all the samples, etc. normal setup up but then when I try to play a sample, the group light at the top of my 64 turns on, but doesn't give a position light. Note: the cpu strain right under the dac is moving, just no audio.

  • @rawore:
    the stack overflow gives off an error message (in the max window?) which you can click and it takes you to the place where the overflow has occurred.

    i've just re-checked, and the old mlr2 (incl. 2.51+) uses the [sync~] object for the timing mechanism, so you won't suffer the stack overflow i experienced in mlrv

    in mlrv the timing system was rebuilt using max's new global transport concept because it allows musical interval based timing, and provides integrated support for rewire and external midi sources. it also runs publicly and on a global level meaning theoretically we could design one master timing patch that controlled a whole lot of different patches, and kept them all perfectly in time.

    the overflow was caused by a change cycling made to [transport] in the 5.08 release whereby any 'bpm $1' message received would echo the new bpm as set to the output. previously a direct message would not cause an echo.

    to simplify patching, i'd plugged the output of transport straight into the bpm number box which created a loop. (this was previously the simplest solution to deal with bpm being changed by rewire or midi input)

    hope that helps....

  • i tried a maxmsp version 4 and the samples are still not playing. i also tried the 5.1 version, no worky :(

    any suggestions?

  • i also tried the 256 by itself and the program still would not run the samples

  • i am having the same problem. I tried in max 5.1.3 first, but am running it in 4.6.3 and still nothing has changed. I've tried different audio interface's and drivers and messing with the ADC settings in monomeserial. Loading samples, hitting the rows and only the group button lights up but the sample wont play or show any movement. Running on macbook unibody OS X 10.5.8

  • same issue here as everyone else.

    how difficult would it be to add mlr-aux functionality to mlrV?

  • @trazmick
    it's on the cards.

  • in the cards!?!

    awesome! thanks!

  • Does anyone actually have this version working? I have messed with every setting in all versions of 2.51 and still am having the same problem that i think everyone else is having.

  • i think the problem is laying within the grooveduck2 file missing. whenever a sample is loaded into mlr, the max window reports the "error: grooveduck2: no such object". After reading about the grooveduck im pretty sure that there is a file missing from mlr for runtime users. I think if you have the full maxmsp that you can add the grooveduck2 by going in examples/sequencing-looping/audio-rate-sequencing-looping/lib/grooveduck2.pat

    anyone who is educated in editing mlr may be able to help in resolving this.


    P.S. I wish I could breakdance and freerun like a boss

  • another found bug in a version of mlr is in mlr 2.27jmelnyk with an "error: coll: can't find file vstNames"

  • here is a little fix i did. the issue that i found was in the sample drop.
    let me know if this version works.

  • error: grooveduck2: no such object
    error: grooveduck2: no such object
    error: grooveduck2: no such object
    coll: finished, 11 lines
    error: grooveduck2: no such object
    error: bpatcher: can't find file_list.mxb
    error: waveform~: 8file is not a buffer~
    error: waveform~: 7file is not a buffer~
    error: waveform~: 6file is not a buffer~
    and it repeats this error: waveorm~: " "file is not buffer~ all the way down to 1.

    In the app, the sample drop box is physically missing and the drop down file/sample boxes are empty.

    I appreciate someone trying to help all of us though. Thank you mappitymap