mlr live rewire problems

  • Hello, all.

    I seem to be having problems getting mlr to rewire with live (6.0.10). When I switch to ad_rewire in the dsp and turn audio "on", it quickly switches back to "off" and gives me the following error in the max window:

    error : as_rewire : error starting audio. Is ReWire mixer running?

    Also, Max/MSP is not showing up as an audio input in live. I am able to send midi clock to Max/MSP from live, though. And I've re-downloaded and installed Max/MSP Runtime 4.6.3, and tried opening the two apps in different orders.

    Any ideas what I'm doing wrong? Any help is greatly appreciated. Thanks!

  • What order are you opening things up in? Also, whenever you get that error it usually means it has nothing to rewire too because mlr was opened in the wrong order. Also, if this is the first time doing this, then 'from max runtime1' will not show up in Ableton Live from my experience. you have to do it all then close down then everytime after that it will show up in ableton. But, the order you open things up is important:

    1. ableton
    2. monome serial
    3. max/mlr

    also, if you are running windows xp, you might not get it to work. I have not succesfully done a rewire in windows xp, only in Mac leopard, really weird.

  • On PC you might have better luck with Reroute ASIO. I've also been testing out ASIO4ALL but thats bit different then what you're trying to accomplish. You on Mac or PC?

  • i use soundflower.

  • Oh yeah, I'm on a mac, 10.4.11. And the order noted is the order I'm opening them. I do have soundflower and it works, but I'm always hesitant to use it since it adds a tad of latency. I'm triggering all my sounds in real time (no pre-sequenced or pre-recorded loops), so I want to take every step possible to minimize latency and cpu usage. Maybe I'm a bit overly paranoid here...

    I have gotten this to work before, but it was several months ago. Not exactly sure of what may have changed on my machine since then, but I don't believe anything beyond the standard os security updates and such. Oh, and it might be worth mentioning that I'm at work and don't actualy have my monome connected, though I would think I should still be able to get live to see max...

    I'm wondering if there is some system level or max-related rewire component missing or something. Anyone know what should be installed where in terms of rewire?

  • I had a problem trying it without my monome plugged in; i got the same error. Then I did it with the monome plugged in and now it works. So try it when you get home... that might help.
    J

  • Just tried it with the monome connected and still no luck. Audio still switches right back to "off" whenever ad_rewire is selected. Same for 64 step.

    Guess I'll just use soundflower for now...

    Thanks for all the suggestions. Much appreciated.

  • I tried it in XP and it worked fine for me. I run Monoserial first , then MLR, then switch to ad_rewire. The Max/Msp prompt then says to load up the rewire program, so I turn on Ableton after all of this. The audio tab is "off" in MLR but I just select it and turn it back "on". Ableton sees the "Max/Msp" audio input and I can run audio from MLR into Ableton as well as sync MIDI time.

  • Thanks blong, but that doesn't seem to work either. Audio switches off in the dsp just as soon as I switch it on. Even if I switch to another audio source, like soundflower, turn audio on, then switch to ad_rewire, audio still shuts off and live doesn't give me max/msp as an audio input.

    Looks like I may need to reinstall live...or max...or both.

    Thanks!

  • This exact same thing has just started happening to me. I was rewiring MLR to Live happily for a couple of weeks, but today it just stopped working. I'm able to rewire the Reason demo without problems. I've tried reinstalling Max (both v4 and v5) in all kinds of different combinations, but nothing works! This is incredibly frustrating, as I know it can work, and I need it for the performance setup I'm building.

    Anybody have any leads or similar experiences I can draw from? Thanks!

  • I managed to solve the problem! Here was the solution for others in the same boat:

    The problem (from what I can tell) stemmed from the MaxMsp Rewire reference in

    //Library/Application Support/Propellerhead Software/ReWire/

    no longer pointing to an actual file. Deleting the orphan reference didn't do the trick alone, though, nor did reinstalling MaxMsp 4.6.3. I had to first remove all Cycling '74 related preference files from

    //Library/Preferences

    Once that was done (effectively uninstallig MaxMSP), I reran the installer, then opened a rewire-enabled patch, which created a new link in the above rewire directory, and now everything works just fine.

    As much as I love OS X, I've got to say- sometimes "uninstalling" an app just by deleting it is not sufficient! Wish there was a better (free) way to handle this sort of thing.

    Hope this helps others in need!

  • What are you choosing for midi/osc clocksource and midi sync in?

    I've only been able to get an external clocksource working, not rewire. Anyone have success using the rewire clocksource?

  • backup..

    go to disk utility.

    - repair disk permissions.

    fixed this for me... after trying about 1000 other things..

  • Yes indeed..Repair disk permissions works but not always, first you have to try 1000 things then turn to
    disk utilities again and pray then presss again Voila!

  • i'm having some problems with this as well.

    i'm able to select max/msp as an input in ableton but when i switch to rewire in mlrV the audio stops and the DAC turns off...?

    any ideas?

    thanks

  • try restarting ableton and reloading your live set. sometimes there's a weird initialisation thing where you have to reboot ableton to get the rewire audio driver to run properly. i think this might have been fixed in the most recent 8.2 update of ableton though...