enableton windows help.

  • Hi.

    I know this has been discussed quite a lot recently but I can't seem to find a conclusive 'how to' for this on windows.

    Basically I have found little bits in different threads by searching through the forum (and the old forum) for trying to see what I am doing wrong, and haven't been able to come up with much (except for what i've tried below) - I'd be more than happy to write a page on it myself for the Wiki once I've worked out how to do it!

    Here's what I am doing (I have midiyoke installed):

    1. Monomeserial, OSC mode, prefix to /box, Starting row: 8
    2. miniAudicle: open enableton.ck, change the following values:
    1 => int mlrlike;
    127 => int shiftkey;
    7 => int shiftrow;
    Change the midiin and midiout numbers
    Start virtual Machine and Add Shred.
    3. Open Ableton, enable track and remote for the midi input and track, sync and remote for the midi output. I then click edit midi map, click on a clip and press a monome button, but nothing.

    What am I missing?

    Thanks very much for your help.

  • I think that /box means /40 if you have a 40h /256 if you have a 256

  • those are the correct steps, except you don't need to enable sync. the only thing i can say is double check that you're using the correct midiin and midiout numbers.. also, setting your prefix as /box is correct, don't set it as /256 or /40h

    sorry it isn't more clear, this was more of a quick hack that i whipped up for a show. i'm working on a more robust version right now that's a lot more clear and has a GUI (it's not based in ChucK)

  • @tumult

    No need to apologise - thanks for writing the script! And thank you in advance for the GUI version - useful for us luddites.

    so let's say i set:
    7 => int midiout;
    8 => int midiin;
    in enableton.ck then I would set in Ableton:
    Input: in from midiyoke 8: on (track and remote)
    Output: out to midiyoke 7: on (track and remote)
    ?

    I tried it the other way around and neither seemed to work for me.

    The only feedback I am getting from the monome is if I press the bottom right pad (it flickers when I press it, then goes off once i de-press).

  • well that means ChucK is able to talk to the monome successfully.. so the problem is somewhere between ChucK and Live. also (i can't tell too well from your list but just in case) make sure in Live you're receiving on all MIDI channels, not just 7 and 8 (the numbers ChucK assigns to the devices are arbitrary and have nothing to do with channels, Enableton communicates using channels 1 - 4)

  • as far as I know ableton is receiving midi on all channels - though I'm not sure how to do this "globally" - as on a midi track you can specify this but on an audio track I'm not sure you can. One thing's for sure - I've been using midiyoke to help max and ableton talk and it has been working - so I don't think the issue is there.

    Could it be something to do with chuck not talking to midiyoke? It feels like I should be setting something in there to make sure it does... Maybe I'm using Miniaudicle wrong? This is the first app i have used it for so I wouldn't put it past me!

  • setting
    7 => int midiout;
    8 => int midiin;
    should have it talking to midiyoke, as long as you got the numbers right. i don't use midiyoke but is there some way to see if it's receiving midi data? i think midiox can do this, but i haven't used a pc for music in years so i'm behind the times.

  • OK thanks tumult I am getting somewhere!

    I installed midiox to monitor the midi data that was transmitting through the midiyoke channels and once I had that up and running, I was able to tell which channels miniaudicle was transmitting to and receiving from. It uses channel 1 for in and 3 for out - though there would be no way of knowing this without monitoring as you suggested.

    HOWEVER, it only worked when I set the starting row back to "0" - so that "row offset = 8" seems to be a red herring(?)

    The one thing I cannot get it to do (I know this has been mentioned elsewhere) is to NOT light up the "next clip" mlr style.

    I have: int mlrlike; set to 1, but still no dice.

    when you say: "set this to 1 if you want 4 rows (starting from 2 from the bottom going up)" - I'm assuming you mean:

    o o o o o o o o o o o o o o o o
    o o o o o o o o o o o o o o o o
    x x x x x x x x x x x x x x x x
    x x x x x x x x x x x x x x x x
    x x x x x x x x x x x x x x x x
    x x x x x x x x x x x x x x x x
    o o o o o o o o o o o o o o o S

    Where s denotes the shift button, o denotes leds that have clip follow and x denotes the ones you can use MLR style? (power socket top right)

  • Sorry about the /40h /256 thing. I think when using Max this is correct.
    This discussion helped me setting things up.

    We really need some good instructions for setting these thing up.

  • no need to apologise!

    it's /128 for me for when using the vst application monochrome, but not for this.

    Once I get this fully working, I intend to write an exhaustive how to with screenshots. Since I am unlikely to delve too far into the code writing side of monome, I can at least give something back to the community in a series of "monome apps for dummies" tutorials.

  • eccemusic,

    "The one thing I cannot get it to do (I know this has been mentioned elsewhere) is to NOT light up the "next clip" mlr style."

    I know what you mean. I have this problem too with Windows and Ableton.

  • hold on, i'll modify it to completely get rid of queue lights since a lot of people want them completely disabled

  • http://emgio.com/enableton-nostrobe.ck
    completely disabled strobing on all rows

    i probably won't modify the chuck version of enableton again as i'm focusing on the new version, which isn't a sloppy hack.

    edit: oops typo in the filename

  • thanks for putting this together tumult. I didn't want them completely disabled but this is great to have.

    I'll get together some screenshots and a tutorial for windows some time over the weekend.

  • so as of yet we still haven't gotten mlr style operation going on ableton in windows?

    I was planning on spending my day off today trying to get this to work but without a how to I'm not even going to spend my time doing it cause I'm pretty sure I won't be able to figure it out since others are having the same failures and I'm probably no more a wizzard than they are.

  • yes we have got it - please bear with me and i shall write a tutorial.

    Sorry about your day off but remember no one (except Brian) on here is being paid for their work.

  • once again I didn't mean to sound stingy in my request for help. I absolutely appreciate the work that any person puts into this or other goals on the board.

    last night I spent about 5 hours getting mlr style operation in live without using chuck or max. I used monochrome in chromatic mode. monoserial in osc mode. midi clips in live send midi to monochrome which controls the lights on the monome. the button presses on the monome send midi out of monochrome to an empty midi track in live which routes the midi out a virtual port and back into live to trigger clips (triggering audio clips AND the coinciding midi clips to control the lights in unison)

    so that actually works really well. currently I'm perfecting a live loop way of achieving mlr style pattern record in live. which does work currently but it's not perfected yet.

    once I get that sussed out I'll post a live set download and a tutorial on how to get it set up.

    not to step on your project, just figured people might be interested in alternative ways of achieving similar results.

    thanks for all your efforts. I'll probably still try your route of doing things so I can compare which one feels more comfortable to me in the long run.

  • This is a work in progress, but it's basically my experience with getting Enableton to run on windows, if thorough detail (written by a dummy for dummies, if you will)

    http://www.eccemusic.com/blog/?p=313

    @Johnisfaster: I'll get the MLR for EnAbleton tutorial written next - obviously getting this up had to be done first.

  • hi folks

    i got my monome 128 end of the last week and was impressed by this beautiful piece of art.
    until now i searched in the forum to find answers, meanings and tutos to have an easier start but i have one problem with enableton.
    @ eccemusic: thanks for the step-by-step on your blog. i was very happy to discover it, because i'm not familar with all the code programms like chuck or max.
    here my problem:
    - the monome is lighting up and all seems fine with it but when i start monoserial i can't find anything in the point "device" or either write in there. is this normal?
    - in chuck all is ok. i followed your instructions.
    - but in midiox i don't get any answer when i press the buttons. i get trough all the possibilities like
    in1 - out2
    in1 - out3
    in1 - out4
    ...
    in2 - out1
    in2 - out3
    in2 - out4
    ...
    but nothing happens.
    - thus the same in ableton live.

    now i'm really confused and a bit depressed.
    am i missing something very dumb?
    can i check somehow if my monome works well?
    every suggestion is helpful.

    cheerz
    ¥

  • @Ishico - don't worry - you'll get there!

    This sounds like your PC isn't communicating with your Monome - which means there's not much point in going through the steps that follow that - better to get MonomeSerial sorted before trying anything tricky.

    1. Can you get/have you got any other Monome apps to work?
    2. If not, I would recommend going back to the beginner's tutorial in the "data" section of this site and running through the instructions once again - try something simple in Monome base to make sure that your Monome is being recognised. You won't be able to write anything in "device" as that field should autofill once your Monome is connected.

    here's the link:
    http://monome.org/data/setup

    Let me know how it goes.

  • thanks for the quick response and the motivating words.

    "This sounds like your PC isn't communicating with your Monome"
    yes, this is my problem. from the setup page i saw that i didn't had the ftdi virtual com port (vcp) driver. was the problem there? i hope so and i'm crossing the fingers that it will works. i'll try it this evening, also the monome base apps and tell you more tomorrow because i'm at work for the moment.

    i totally forgot this setup section. thanks for the link.
    best
    ¥

  • hello

    it has been a while since i installed the ftdi virtual com port (vcp) driver and it worked!!!

    but now, because a long period of hard work i didn't find the time to see after my monome project for a long time. over the past weekend i had some free days and wanted to start working on it but nothing happened. i mean all the drivers are installed and it worked fine the last time.
    so i de-installed and re-installed all the drivers and apps (monomeserial, midi ox, midiyoke) but nothing changed. i also tried to de-install the ftdi virtual com port (vcp) driver but i couldn't find it into the device manager of my system (i'm on pc) as it was written int the .pdf of the ftdi and because monomeserial recognizes the device serial number of the monome, i assume that it's still fine.

    the monome blinks when it's connected but also the monome base stuff don't work.

    am i missing something??

    i would be grateful if someone have a clue for me.

    ¥

  • can anybody help me with this problem???