Ableton Live Version 5 or Live Intro OK for Pages?

  • I'm just getting started using many of these apps....so bear with me...

    I'd like to use Pages for switching apps on a single 40h.(like between MLR, PressCafe, etc...).

    I'm trying to do this with Pages synced to Ableton Live Version 5. I know, I know...version 5.. I need to upgrade already, but don't have a spare $500 right now, so here I am.

    My question is..will Live 5 work to sync with Pages for controlling external applications? As far as I can tell from Pages documentation, Live only really needs to act as a MIDI clock for any of the other apps running on Pages.

    Am I right about this?

    Also, I've been thinking about purchasing Live 8 Intro. only $99 Does Live Intro. have any inherent limitations when it comes to using it with the Monome??

    Thanks.

  • hi rah,

    actually a common misconception is that pages requires ableton. it really doesn't, it can work with anything for midi clock source. the only thing you're going to need ableton 7 or 8 for is if you want to do clip launching or use any of the ableton-specific pages. i have not tested 5 for this, nor have i tested live 8 intro, but i would guess that live 8 intro will work (live 5 probably will not). the only requirement for ableton to work with pages is to be able to load and enable 'control surface' scripts. i would be surprised if live 8 intro had the control surface functionality disabled, but you might want to double check before purchasing.

    anyway, bottom line, you can use any midi clock source to drive pages--ableton, logic, garage band probably, cubase, some external piece of gear, etc.

    edit: if you want to just check out the pages+ableton functionality you can always grab the free live 8 demo. it works with clip launcher/etc.

    edit 2: if you do manage to get live 8 intro working let us know!

  • Thanks phortran..
    I will let you know what I find out.

  • OK..
    I've decided to forego Live Intro and see how far I can get with Live Lite 8 M-Audio edition. I'm not sure how exactly this edition is disabled (there might be some mapping and warping limitations, not sure), but I thought I'd give it a try.

    So far I've been able to set everything up OK.

    I'm receiving MIDI clock info from Live to the MIDI Sequencer in pages.
    And I'm able to receive MIDI signals from pages to Live, so I think the communication set up seems to work.

    I still need to figure out how to specify grid settings on the MIDI Sequencer page so that it properly triggers MIDI instruments in Live, but I suspect that's just a matter of spending more time trying out different setttings on the MIDI sequencer page, but I am a bit confused...

    Each of the 16 fields on the sequencer page are labeled as rows. On my 40h 8x8, I only have 8 rows and 8 columns, and the bottom row of buttons are reserved for control functions, I thought.

    Can anyone shed some light?

  • hi rah, this should be helpful:

    http://code.google.com/p/monome-pages/wiki/MIDISequencerPage

    basically, on an 8x8, you can offset which rows you're seeing when in bank mode. the bottom left corner buttons (0,7 and 1,7) will switch between seeing the first 7 rows and the next 7 rows. the bottom row is reserved for control so an 8x8 gives you a total of 14 rows (so the 15th row in the configuration is ignored). a 256 would give you 15 rows of sequence data with 1 control row, hence the 15 rows of configuration.

    hope this helps.

  • Thanks for the quick response phortran..

    I think that explains why the MIDI signals received by Live seem to be triggering notes on the virtual instrument below the range with actual sounds assigned to them...

    If I'm understanding the wiki correctly, I can change the offset in bank mode to off2 and the button presses I select in sequence mode will correspond to the MIDI notes programmed on the Live Instrument.

    And each of the bank buttons in bank mode switches to a sequence of four patterns each 8 steps long? Wow..this has alot more potential than I originally thought.

    This is going to be fun.
    I'll try it when I get the chance.

  • yep, i think you've got it. mess around with it a bit and let me know if you have any issues.

  • phortran..

    Thanks for your help on this..I did change the offset and got the MIDI Sequencer working with Live this morning..

    I also tried getting an external application page working (I tried it with mlr). I must have something set up wrong, but I can't think of what it might be..

    I created a new external application page as follows

    ports 8080 and 8000, localhost, prefix /mlr.
    I clicked "update preferences", opened MaxRuntime, opened mlr, and got no display on the monome itself.

    monome serial is still set to 7000 7070 with prefix: /pages

    I do seem to be receiving clock messages from ableton.

    I searched and couldn't find anyone mentioning this kink of trouble, so I must be missing something basic.

    Any ideas?

  • hi rah,

    what o/s and version of monomeserial are you running?

  • OSX version 10.5.8
    MonomeSerial 0.20

  • I got it going...awesome...

    I'm not sure what the problem was, but with enough resetting and rebooting it started to work.

    Thanks for your help phortran..this is such a great app..