launchpad latency with monomeemu,stretta suite and 7 up.

  • @ everyone

    Hi guys, please help me to solve this problem that is really annoying me.
    I think since I have upgraded both live(8.1.1) and max(5.1.1) when I use launchpad with monomeemu and some stretta suite patches in particular with pitches, I get a big latency that makes impossible to play.
    I press one botton on the launchpad and the sound comes after a while, I also noticed that the same happens when I use it with melodizer from 7 up.
    None of this happened with live ( 8.0.1) and max (5.0.1).
    The troubles began soon after I had upgraded first to max 5.1.1 without realizing the message that said that to upgrade to max 5.1.1 I needed to have live 8.1.1
    So after this mistake I asked @ soundflower if he could mail me an old version of his lovely patch just to check up because things were starting to behave strangely. ( thank you soundflower)
    But the problem had nothing to do with soundflower patch.
    Now I am still stuck with this problem, and I can't get it out.
    I am on a mac and my OS is upgraded, java is upgraded, I don't have a clue what is going on.
    I get this message on the max window, maybe you can figure out something

    binding to port 8080
    bind to port 8080 unsuccessful.
    there is probably something already bound to this port.
    binding to port 8080
    binding to port 8081
    binding to port 8080
    binding to port 8081

    The launchpad on is own works fine with live.
    Thank you guys and forgive my english I hope you can solve this problem.

  • pffff....can't help you, damn. Sounds bad. Updating is a kind of dangerous action these days....
    hope you ll sort it out.

  • @ le k
    Thank you anyway

  • http://post.monome.org/comments.php?DiscussionID=6828&page=1#Item_1

  • @ barjnone

    thank you, I will try to do that and I will let you know.
    Unistall max 5.1.1 and install 5.0.1 with live 8.1.1

  • @ barjnone

    Nothing to do, latency is still there.
    Maybe I should formatt the computer.
    what do you think?

  • Can you reduce this problem to the bare minimum dependencies?

    Start with a fresh Live set. Only load one app..for example 7up and I guess you need monomeEMU too and maybe one component like melodizer. Don't use soundflower or any effect or anything else.

    After you connect in 7up...right click and choose "Open MAX window" make sure that all connections to ports happened without error.

    This error log from you
    "bind to port 8080 unsuccessful.
    there is probably something already bound to this port."

    is telling me that two applications are trying to connect to the same port. A common problem with monome apps.

    Are you positive you monomeEMU settings are correct? Maybe post some screenshots of your configuration to that thread to double check. Usually you need different port number pairs for each app.

  • @ barjnone

    ok I will try and I'll send you the screenshot.
    Thank you.

  • @ barjnone


    Nothing to do, latency still there, check my screenshots, see if you can figure out what I do wrong.
    Let me know if you need more informations, or screenshots.
    Thanks , very kind of you

  • @ barjnone

    Here are the screeshots.

  • @ Barjnone

    more screenshots

  • Ah ha!

    Everything looks good except. Choose "MultiColorDevice" instead of "Monome64". The launchpad cannot handle the date rate we need to use with monome's single color.

    "MultiColorDevice" was implemented in Monomeemu and it uses all the colors on the launchpad which also reduces the data rate and does not overload the launchpad, probably causing the latency you are experiencing.

    Hope that works!

  • @ barjnone

    nothing to do, still there, I also noticed that within melodizer I cannot longer record melodies, there is not blinking light.
    How come?

  • What does this mean?

  • @ barjnone

    What about this

  • @ barjnone

    I just want to thank you for all the support, I eventually sort it out by formatting the computer, now is working fine.
    Thank yuo once again for the patience