MLR wont let me drop audio files in

  • Its been awhile since I used MLR. When I try to drop wave files into the drop box to load some samples my mouse cursor changes to a circle with a slash through it and my samples wont get loaded. Any ideas of what the problem could be?

  • There's a bug report about max 5.1.1 wave file drop issue. Try downgrade max/msp 5.1 or lower version. It should work for you.

  • check these threads:

    http://post.monome.org/comments.php?DiscussionID=6935&page=1#Item_5

    http://post.monome.org/comments.php?DiscussionID=6930&page=1#Item_17

  • Thanks, that fixed it.

  • Glad to see to this comment... I was beginning to feel very technologically inept...

  • For further clarity, here's some info that will help:

    MLR version 2.27 (And variations of it such as the AES edit) were all made for Max 4.6, and as a result tend to work better in that version (especially graphically, like buttons and menus etc), though you may still get heavy button mash crashes due to a bug in Max.

    MLR V - The newest version has a fix included to make it work correctly in Max 5.1 - Most notably, the update fixes the drag/drop issue.

    See here for download and info: http://post.monome.org/comments.php?DiscussionID=6433&page=1#Item_24

    Recent versions of MLR V also include a fix that stops it crashing on heavy button mashing, meaning it's solid, and can take any amount of crazy button mashing - reassuring for using in a live situation.

    MLR V will not run in 4.6

    MLR V - older versions require max 5 - Max 5.7 seems to be the best option for these older versions, and other patches that have yet to have fixes done for the changes made in Max 5.1

    You can instal Max runtime 4.6 and 5.x on the same computer, then right click on a patch, and 'open with' to select the desired max version to open the patch.

    installing Max 4.6 first on a Mac will potentially save you hassle. If you need to instal Max 4.6 after installing 5.x on OSX, and it gives you an error saying there's a newer version installed, then go to Library/receipts and delete the receipt file with no name (it's the one installed by max) then try again.

    If you rename the max 5.x folder before installing 5.1, then you can also install 5.1 and keep your 5.x version for patches that don't yet have a fix for 5.1.

    Hope this helps.

  • This would deserve a sticky wouldn't it ?

  • I've had the same problem and found out that mlr_Aes version 0.42 works perfectly with MaxMSP 5.1. You can drop in audio files without any problem and it has 6 channels. Works better for me then mlr 2.5

  • I was having the same problem - I downgraded to max 5.0.8 and things work now.