plugged in, but no device available

  • ...am i missing something?
    I just plugged my new, beautiful 64 into my macbook pro. it lit up when connected, then started up monomeserial, the 018L version, and it doesn't recognize any device... i think you can imagine my disappointment building up to frustration and panic. help!

  • do you have ftdi installed?

  • dang, i must be missing that! i was so excited i just plugged it in and decided it must work. where can i find that, btw?

  • look in the data tab here on this site, then click on setup. Follow that to a tee...then you are up and ready to monome!!! :)

  • well, just googled ftdi, got it, installed it, had a blast! dang, i'm a happy man! gonna try making some max patches now! got some sketches in my mind that i know i can form into great patches.

  • well, i have the same problem here, but i did all that (ftdi installed, 256 connected, power connected,followed the setup instructions) and still monomeserial cant seem to find the 256, it still says "no devices available" in the device setiings dropdown menu. btw i'm running mac osx 10.5.5 .

    what else can i do?

  • Do you see anything that might be related in the system profiler?

    Did you get the Monome handshake thing on the 256 when you plugged it in (I believe it's the little ripple thing - or is that just when you plug in power?)

  • yes, the 256 is listed in the system profiler as connected under "usb-bus".
    and yes, when i connect the power to the 256, some lights light up. then disappear before others light up kind of randomly.
    but then when i plug in the usb cable -> no lights anymore and theres no device found in monomeserial
    i tried different cables and usb ports, anything else functions like it should

  • make sure you have the most recent version of monomeserial installed, along with the correct version of the ftdi driver (there are separate intel and ppc versions).

    try opening terminal and typing:

    ls -lrt /dev |grep m256

  • thanks jp and tehn for your quick help, but still the 256 isnt found by m.serial.

    i checked again and the versions should be the right ones:
    monomeserial is version 0.18
    and ftdi is 2.2.10 for intel osx

    i copied/pasted ls -lrt /dev |grep m256 into the terminal. what should happen then? nothing here.

    anyone another idea?

  • if nothing happens after the ls-lrt that means the device hasn't been detected.

    this is an ftdi driver problem. try uninstalling and reinstalling.

  • i deleted the driver from the sytem/library/extensions list and reinstalled the driver and rebooted but again -> nothing in the device dropdown :-/

    i think ill give up for today

    not my day i guess

  • is there a chance you can try this on another computer? it's hard to understand why the driver won't stick.

  • yes, i can try that tomorrow,
    thx for all your time today

  • i tried on another mac (also intel, but macosx tiger not leopard) and the same happens:
    just when i plug the 256 into the usb, its lights go off and its not listed in the monomeserial device list

    this i found in the ftdi driver installation guide this:

    "The device does not appear in the /dev directory or the text "New
    Port Detected" is not displayed in SystemPreferences-Network

    FTDIUSBSerialDriver does not support your deviceID (VID and PID). Disable the EEPROM so that
    the device reverts to its default deviceID, then replug.
    To get support for your deviceID built into FTDIUSBSerialDriver, contact FTDI quoting your
    deviceID and a description of your device."

    thats exactly what happens hear i' d say, but what about the 256?

  • ack. when you install the driver does it prompt you to restart the computer?

    we program the VID/PID for compatibility with the driver. that shouldn't be the problem, as i can't imagine how those could have changed.

    the lights going off indicates that usb power is present, and it's now ready to communicate with the computer. the firmware is doing the right thing.

    how old are these os x installs? do you have many specialized drivers installed that may be conflicting with the FTDI? (this sounds outrageous, i know)

  • yes, i was asked to restart and of course did it.

    the macosx installs should be up to date:

    i just got a new macbook with which i want to use the 256. this is running on leopard 10.5.5. on this mac i dont have so much installed. so i guess there shouldnt be a driver conflict. one uncommon software i have is one for writing called masterwriter. the rest is just some common audio software.

    the other mac i tried the installation on is a macpro with macosx tiger installed, that should also be the newest version. version is 10.4.9.11. on this mac theres more software installed, but again, mostly audio software.

    hmmm, this gets kind of complicated. sorry.

  • how long have you had the 256? do you know what serial number it is? where are you located? this is a totally random thought, but the usb jack might have some bent pins (the data pins specifically) though i have no idea how those pins only would've bent (and not the power pins). does the usb cable move around inside the socket?

  • i received the 256 already some months ago but didnt use it yet.

    i dont know the serial no., where can i find it?

    i thought about a broken connection, too but i thought b/c the 256s lights go off when connected that could also be ok.?! i dont know about the pins but the cable seems pretty fixed, not moving around or so.

    btw. i'm located in germany.
    i'll come back later, have to go to the jam room. :-)

  • so you got it directly from us? if so it should be in perfect condition.

    again, the fade out happens purposefully when it is detected.

    the serial number is on your shipping slip. not terribly important.

    just to be totally completely certain the correct driver is installed, this is the intel link:

    http://www.ftdichip.com/Drivers/VCP/MacOSX/UniBin/FTDIUSBSerialDriver_v2_2_10.dmg

    and this makes zero sense, but try this newer version of monomeserial:

    http://post.monome.org/?PostBackAction=Download&AttachmentID=514

  • yes, ordered directly.
    the serial no. should be m256-149 at least thats what it says in the system profiler.
    i reinstalled again with he files from your links. still nothing happens.
    i´ve attached some window photos of mserial and the info in the sys.profiler

    800 x 522 - 36K
    412 x 588 - 21K
  • and also 2 pics of the terminal /dev folder.

    does this help?

    415 x 731 - 35K
    415 x 731 - 36K
  • you've totally proven that it's not detecting. thanks for the screen shots.

    i'm still going to assume the driver isn't running correctly. can you contact ftdi tech support and ask them for a test to ensure the driver is installed properly and *running* preferably without a device test?

    also, e-mail me at tehn@monome.org and i'll arrange to send you a replacement logic board, if that ends up being the (although unlikely) problem.

  • ok, thanks again tehn, i'll write an email to ftdi and as soon as i'll get an answer, i'll let you know what they said.

  • I have the same problem with my 128 and new macbook. Everything works fine on my mac pro with version 2.2.9 of the ftdi driver. The ftdi driver (2.2.10) does not install properly. ls -lrt /dev |grep m256 does not return anything. I may try to install 2.2.9 on my macbook.

    Let us know what ftdi tells you!

  • Hey dBlicious and tehn!,
    Today I received emails from ftdi. They sent me the version 2.2.9. and asked for my VID/PID :

    quote:
    > OK it is default VID/PID so there should be no issue with the driver in
    > that
    > respect.
    >

    and...
    > >
    > > You can try 2.2.9, but I do not see why it would work, when 2.2.10 does
    > > not.
    > >

    Strangely my 256 is recognized with that driver version. Its not working with 2.2.10.. I told ftdi in another email.
    dBilicious, try 2.2.9 on your macbook, too. Just like you I guess youve got the same problem.

  • where did you guys download the 2.2.9 driver?

  • I had it archived on my hard drive. I don't know where to d/l it now.

  • not sure if this is kosher with FTDI's distribution policy, but here's 2.2.9

  • I'm sure that'll be fine it's on their own servers...

    http://www.ftdichip.com/Drivers/VCP/MacOSX/UniBin/FTDIUSBSerialDriver_v2_2_9.dmg

    ;-)

  • I contacted FTDI and they sent me an updated 2.2.10 that solved my problems. On a side note, FTDI was very helpful and quick to respond.