Problem with autofocus and MonoRoute

  • I just finished my 256 at the weekend (photos to follow). It is made of 4 40h kits. The cable settings for each keypad is different so it fits nicely onto the faceplate.

    Top Left quadrant is facing Right
    Top Right is facing Down
    Bottom Left is facing Up
    Bottom Right is facing Left

    When Im using a single m4l without MonoRoute the autofocus changes all the cable setting to one direction. I then have to go into monomeserial and change each cable select back. Is there a fix for this or is anyone else having the same issue? Im planning on updating to the new kit in July and i'm wondering will this solve the problem...

    The other problem i'm having is with MonoRoute. I hoped that setting up MonoRoute would stop autofocus changing the cable select in monomeserial but it wont function correctly.
    I'm using MonoRoute0.9beta5.1, It recognizes all the devices but it will only light one monome at a time. I had it working with my 128 config a month ago. It also automatically assigns the hotkeys to 7,7 and 0,7 when I thought it would assign them to 15,15 and 0,15.
    Sometimes it recognises button presses from the other monomes but not all the time?
    Also the "Start Auto Config" button is missing from the GUI.

    Hopefully I can get these resolved by the 3rd of July for my first Monome gig not related to college!

  • monoroute and autofocus don't work together, afaik. I would suggest you go into the patches, strip that autofocus shit out, and set them up as simple fixed port and name, then add them manually to monoroute. Thats the only way ive found to make it right.

    As for the 'Start Auto Config' button, have you tried scrolling down in the window?

  • I can strip out the autofocus stuff alright, I've edited a few patches to work its just annoying when the autofocus feature is there. Its really annoying the way m4l adds the /001obo or whatever number to the prefix. Is there an easy way to find this?
    For some reason the 'Start Auto Config' button isn't where its supposed to be but ill have another look when I get home.

  • if you're using obo, loopparty has made autoconfig versions of all strettas apps. The random prefix is in there so you can have two copies of the same app. Not always necessary, imo, but thats where its coming from.

    Theres a scroll bar in monoroute, for whatever reason the window isnt quite big enough to show the whole deal at once...

  • Where would I find the autoconfig versions of strettas apps?

    I understand having the random prefix but is there a way to display it as every m4l patch is a bit different?

    Ill have another look for the 'Start Auto Config' button but i'm sure its not there. Ill have another look into it all when I get home.

  • why, this very board, the search tool is your friend ;]
    and by that, i mean that i am your friend...

    http://post.monome.org/comments.php?DiscussionID=7094


    what is it you want to display?

  • Still no auto config button...... Ive attached a photo of MonoRoute. Im also wondering should it not set the hotkeys to 15,15 and 0,15 if im running on a 256?

    I would like some way of displaying what prefix that a patch loaded into m4l has chosen. It could be anything from /001obo to the amount of other monome patches included.

  • sorry, i assumed you where referring to the start packet engine button at the bottom (and that's plainly visible). You don't need anything else, just drop an autoconfig enabled patch into live, it will appear in monoroute automatically, and start the packet engine. Nothing more is needed...

    i use the midi switching, rather than hotkeys, that way you dont lose button functions...

  • I've built a small arduino unit with arcade buttons to switch through osc so I don't need the hot keys, the problem is that my monome doesn't seem to be recognised as a 256......

    Nothing happens when I drop the patches into live...

  • damn, had a longer post that didnt post, but in summary, your screencap is weird, it appears that your device is being seen as four separate devices? Thats rather surprising.

    Witht he packet engine off, if you drop a patch into live, autoconfig should automatically see it and add it to the applications section of the ac window. Dunno why you arent seeing that behaviour.

    Good luck dude...

  • I was thinking something was wrong. Even when I put it back to my original 128 config it doesn't seem to work. Maybe im doing something wring with the port settings or is it possible that its a problem with the powered hub I have? I hacked it a small bit to fit in my enclosure by soldering leads directly to the circuit board from the monome.
    It works fine on its own with say, mlrv, flin or boiingg in MaxMsp....

    il get on to loopparty and see has he seen this issue before?

  • @funk

    I'm having a very similar problem. Sometimes monoroute detects new autoconfig devices, sometimes it doesn't, and other times it detects them at a delay. Regardless of if/when a device is detected, my gs128 recieves led feedback, but no button presses register.

    edit:

    I just deleted any trace of oscbonjour and of monoroute, restarted my laptop and re-downloaded and re-installed each piece. Works like a charm now!