Problems with kit, monome test

  • haha i do say! Tehn I'm seriously impressed with your customer service.

    the fixed mk-set patch works for me. monome_test still a no go for lights.

  • ok, so now you're using the most recent version of monomeserial, and monome_test, correct?

    do you have your ports set correctly in monomeserial?

  • I think so...

    893 x 778 - 234K
  • image busted?

  • huh? I can see it...

    i'm trying to show you that i'm using the recent version of serial, test and that my host port: 8000 listen port: 8080 thing is going on.

    893 x 778 - 141K
  • that one worked. ports look correct.

    pads work, but no lights?

  • exactly! bummer.

  • is there a chance there's another computer you can test this on? monomeserial is now the problem given you've confirmed the hardware is working.

  • So,

    I was previously working on a macbook pro. I tried the kit on my old g5 imac (running 10.4). All the same result, except monomeserial wouldn't even launch for me on that machine. Does it look for the device before actually launching?

    The 256 howto patch you mentioned above DID work on the g5 (lights/buttons)

    I plugged back into the macbook. Monomeserial does launch, however i can't get the test patch to show me any lights.

    One last thing... I notice that when I first launch the test patch, for about the first 5-10 seconds, all my button presses only register as one of the top 2 buttons. After hitting pads for a few seconds, they begin to register properly on the grid. I'm not sure if this information gets any closer to a diagnosis, but i thought i'd mention it. (see pic)

    508 x 514 - 72K
  • on the g5 did it throw and error when it wouldn't launch?

    i'm going to make a frustrating suggestion: rename your serial number to m256-000

    the serial protocol is the same, but monomeserial will think you have a 256. since the aux commands aren't implemented yet if shouldn't make a difference.

    let me know if you have trouble with the rename.

  • Sweet!

    I have proper functionality in monomeserial and test patches after the serial change.

    Is this a permanent fix?

  • no, it's just that monomeserial is busted right now.

    eventually you'll need to switch it back, once we implement AUX controls.

    that is, if you want to use the AUX controls. if you just want a working grid, you're fine with that serial.

  • weird... the latest rev of monomeserial actually uses the same code for handling serial from kits and series.

    search for handleSerialDeviceMessageReceivedEvent within your browser.

    the osc is handled in

    and if you search for oscLedStateChangeEvent you'll see that it's handling /led messages the same way as well.

    so, either you're not using that link from 2010-08-07 that tehn posted above, or something far far stranger is going on.

    that it doesn't work on 10.4 is an sdk issue. i've since installed the 10.4 sdk, so i should be able to post a UB build this weekend, provided AT&T comes through with providing me internet at home.

  • @soundcyst hoss!

  • The 0.3 version of monomeserial, same as 0.2, doesn't remember all setting for all 4 of my 40h kits.

    2 of them remember everything, one of them forgets the offsets, and the 4th forgets the offsets, orientation, and last used prefix.

    Is this something that is just the way it is, or something that can be fixed?

    It's not a major problem, would just be awesome to be able to just plug in and go for live performances.

  • we're hard at work on serialosc to replace monomeserial, which seems to be suffering. all of these problems you mention will be addressed.

  • I just got around to testing the version of monomeserial posted on 8/22/10 in the mk updates! thread and it fixes the problems I have been having even with the default mk#### serial number.

    Thanks for getting that all worked out.