pages 2 alpha release

  • pages is a monome/arc application that contains mini applications and a paging system to switch between them. it is written in java and runs on windows/osx/linux. some highlights are:

    load up lots of applications at the same time
    lots of native applications for easy setup: ableton clip launchers, midi faders, keyboards, sequencers, etc.
    supports multiple devices
    quadrants / split a larger monome into smaller ones
    pipe in other applications like mlr and switch between them
    supports monomeserial and serialosc protocol, you can use serialosc and monomeserial apps together
    script your own applications with a simple API

    read the setup instructions:
    http://monome.org/docs/app:pages

    rtfm:
    http://pages.post-digital.net/pages-manual.pdf

    download the latest version:
    http://pages.post-digital.net/pages-latest.zip

    browse the source code:
    https://github.com/dinchak/pages-2

    post questions here or talk to me on live chat / irc

  • windows vista monomeserial 0.2.1.5
    monome discovery is crashing monomeserial
    greyscale 64

    tried 8000 8080 7000 7070

  • thank you! working great on my macbook.
    it took me a little bit to figure out the new set-up method but it seems pretty solid.

    nice work as always.

  • i cant wait to test this out tonight! I use pages all the time.

  • closes as soon as it opens.

    macbook intel 10.6.4 - all updates..

  • !!! :) thanks so much, will try it tonight!

    edit: hi phortran, just checking it without a monome, seems that external app page is not working

  • thanks for checking this out!

    @rawore

    i've had some trouble w/ stock monomeserial on windows (xp in my case) and wrote a python version that works pretty well for me. you might give it a try! actually i need to commit some edits i made but they're 128 specific. you can grab a copy of this here:

    http://post.monome.org/comments.php?DiscussionID=8556

    i'll upload the latest to the google code page tonight.

    @mapmap

    fantastic! glad to hear a report of success.

    @stevieraysean

    can you try to capture a stack trace for me?

    @pauk

    i will check into this! can you post any stack traces you see?

    thanks again everyone!

  • this is great! I don't know when I'll have time to mess with it, but I have been meaning to add some funky new stuff to pages for a while, so I'll be happy to get the ADC stuff working (have some ideas on how to make it much better even).

    ...actually have a bunch of ideas...will expand on them after work perhpas

  • great to hear from you stephen! and i'm glad to hear you're still into this. i definitely want to hear about what you have brewing.

    i think you'll find that development-wise things are a bit better organized and easier to work with. the GUI stuff is the biggest part of this -- i'm using an eclipse plugin called Visual Editor and have partitioned off all GUI elements into their own classes, so it's much easier to make changes and create new windows/GUI elements/etc. Visual Editor is sweet, it's like a visual basic style wysiwyg thing to create GUI elements, but works well. i did have a few issues getting it going in eclipse, basically i'm stuck using the ganymede release for now (which is fine really, it just took awhile to come to that conclusion).

    i've left most of the ADC code in and commented out so hopefully it won't be too hard to get this stuff back in working order. i also have a few other goodies in the works that aren't quite ready yet (quadrants page for example).

  • Hi phortran,

    Glad to see that pages is still alive!!!

    Same problem as stevieraysean.

    See the Console.

  • hi felart, good to hear from you! thanks for posting the console text, this should be easy to fix, i'll post a new version in a little bit.
    edit: try this one

    611K
  • ok i've re-uploaded pages-0.2.1a.zip on the code.google.com site (the link in the first post). external application should be fixed and it should be 1.5 compatible.

  • thanks phortran, will try it tomorrow!
    And soon I will be able to try the machinedrum page!

  • oh fun! i've been meaning to add a few other machine drum pages too, i have some ideas and would like to hear your ideas around that too :)

  • hey there.
    so i found one thing on the midi sequencer poly page.
    in the section with the memory banks, only the top eight banks are useable (top row, first eight buttons). if you go beyond the first eight in the top row (9-16) it just repeats the first eight banks again. on the 2nd-5th row, you can select each button and create a pattern but it will not playback any midi notes.

    any ideas?



    newest Pages
    osx 10.6.4
    live 8.1.5

  • hey mapmap, i'm not seeing this behavior when running simple tests. all banks seem to be playing back properly. can anyone else verify this?

  • i just tried it again, same results. i tried to test out the pattern storage on the regular midi seq and (other than the right half of my 128 just mirroring the left side) it seemed to work just fine.
    bummer.

  • ok, so I'm trying it and the monome is not responding :/
    can you remind me how to capture stack trace to send it to you?
    I think I'm doing the same that in pages 1, I'm in win XP sp3, trying with a GS 64, working with ports 7000 7070 in monomeserial.

  • @Pauk
    hola Pau que versi

  • Now working with monomeserial 0.3 too, but having a lot of problems when push discover monomes.Sometimes i get the message no serial and other times work fine.

    Anyone have success keeping and opening configurations? Don,t work for me.

    newest Pages
    osx 10.6.4
    live 8.2

  • @mapmap

    :( can you give me some steps to reproduce? my test was pretty basic.. select a bank not in the top row, put midi in, see if it plays back when selected. there may be some step i'm missing that's causing it to go haywire--some setting or button that gets pushed that messes it up. we'll get it worked out though!

    @pauk

    :( sure it's java -jar pages-0.2.1a.jar, that should give you all stack traces and debug output in a console window. but try the monomeserial i attached and see if it helps! i've been using it on xp throughout development of pages 2 and it's pretty solid for me.

    you will need to download python:
    http://www.python.org/ftp/python/2.6.5/python-2.6.5.msi

    and pyUSB:
    http://bleyer.org/pyusb/PyUSB-1.6.win32-py2.6.exe

    after those are installed just double click monomeserial.py in the zip file (attached)

    @bite

    unfortunately i'm not sure how well discover will work on osx :( i don't have a machine to test and the monomeserial i mentioned uses a windows-only FTDI driver for python or i would recommend using it. do most things work if you manually setup the monomes? re: keeping/opening configuration, are you having issues with save / load?

    i'm using /sys/report for autodiscover and i'm not sure how many other apps use this call, so the call may not be fully tested/working in all environments just because nobody really uses it for much. i'm going to try to switch over to zeroconf/bonjour/serialosc methods of auto discovery soon though so it might be a moot point.

  • @Phortan
    yes,oh sorry for my primitive english.I have problems with save/load.i can save a configuration, give a name.Close pages, reopen, when i load the file again nothing happens.

    Pages 0.1.4 works for me in this aspect.

  • @bite

    no problem! can you upload me a configuration file that won't load?

  • ok.
    This is a configuration with 6 pages,midikeyboard,midifader,midigenerator,midisequencer,midisequencerpoly,miditriggers.

  • thanks for uploading that Bite! i believe i found the issue and i have uploaded a new version, same download link as the first post. let me know if it solves the issue.

  • also this is kind of cool, attached a screenshot of ableton 7 running in ubuntu studio under wine with pages clip launcher working. i'm downloading the demo of the latest live 8 and will try ST8's latest LiveOSC and make sure pages still works with it.

    1440 x 900 - 149K
  • I try to load the file with the new version.Didn,t work.
    I create a new document, with the new version,i saved it.Close pages and try to load and no lucky :/

  • hmm ok, can you try this?

    copy pages-0.2.1a.jar to your Desktop

    go to a command shell and run:
    java -jar ~/Desktop/pages-0.2.1a.jar > output.txt

    this should run it and create an output file with all errors. try loading the configuration file and after it fails quit out of pages and send me the output.txt.

  • good news -- ableton integration seems to work fine w/ ST8's latest LiveOSC on 8.2.1, at least basic functions like track arm/solo/rec and the clip launch buttons.

  • Phortran is an output.txt very strange one line or two.I include what happens in terminal,too

  • hm looks like the same bug i just fixed? same line and everything.. i probably didn't upload the right .jar file, sorry, give me 1 minute and i'll get the right one up.

  • ok my fault! i uploaded an old jar last time. re-download again and it should work this time.

  • i try again with two different configurations.One not load the other remember the midi in and out but the pages i create don,t appear.
    Again the output and console.

  • sorry, here is the archive.

  • hm! same bug, it looks like you're using the old jar still.. i checked and i uploaded the right one this time :) try this one:

    http://www.post-digital.net/pages-0.2.2a.jar

  • oh nooo!!!
    now it works,but i have the message /40h[noserial]8x8 and the monome doesn,t respond.

  • well at least it's loading now! no serial is ok, if auto detect doesn't work then you won't have a serial # there.

    can you send me any terminal output when you run this one? copy the jar to your desktop again and run this:

    java -jar ~/Desktop/pages-0.2.2a.jar

    the >output.txt isn't working how i hoped it would so we can leave that off. paste me the output after you load it.

  • i should mention i tried your config file with my 40h and my monome was responsive after loading, so i'm not sure where to go with this.. hopefully something in the output will give us a clue.

  • this is the console output ,very long!!!!! so here is the file

  • hi bite, it looks like the debug output itself caused a crash on a malformed packet, i turned it off:

    http://monome-pages.googlecode.com/files/pages-0.2.1a.zip

    download that again and let me know how it goes

  • jaja phortran this is crazy...
    No lucky, now doesn,t load the configuration :/
    I think for today is enough terminal and java...i go to bed and try tomorrow more fresh.
    Thanks for your hard work Phortran!!!

  • hi bite, i don't think you're actually downloading the new one, i can tell because it still says 0 downloads :)

    http://code.google.com/p/monome-pages/downloads/list

    try deleting all of the pages 2 files you have and re-download it (in the morning of course) :) thanks for sticking with me on this

  • Hello phortran,
    here we go again ;) No lucky at the moment i go to the google page and download the new version.
    This is the console output when i try to load a conf.I hope not to be using an old jar :/

    Last login: Mon Oct 25 21:51:47 on ttys000
    MacBook-de-Jose-Barrera-Martinez:~ Bite$ java -jar ~/Desktop/pages-0.2.1a.jar
    Ableton State: set selected scene to 1
    Adding OSC listener for /sys/devices
    Adding OSC listener for /sys/prefix
    Adding OSC listener for /sys/type
    Adding OSC listener for /sys/cable
    Adding OSC listener for /sys/offset
    Adding OSC listener for /sys/serial
    Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
    at org.monome.pages.configuration.Configuration.readConfigurationFile(Configuration.java:858)
    at org.monome.pages.gui.Main$7.actionPerformed(Main.java:417)
    at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2028)
    at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2351)
    at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
    at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
    at javax.swing.AbstractButton.doClick(AbstractButton.java:389)
    at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1223)
    at com.apple.laf.AquaMenuItemUI.doClick(AquaMenuItemUI.java:137)
    at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1264)
    at java.awt.Component.processMouseEvent(Component.java:6348)
    at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
    at java.awt.Component.processEvent(Component.java:6113)
    at java.awt.Container.processEvent(Container.java:2085)
    at java.awt.Component.dispatchEventImpl(Component.java:4714)
    at java.awt.Container.dispatchEventImpl(Container.java:2143)
    at java.awt.Component.dispatchEvent(Component.java:4544)
    at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4618)
    at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4282)
    at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4212)
    at java.awt.Container.dispatchEventImpl(Container.java:2129)
    at java.awt.Window.dispatchEventImpl(Window.java:2478)
    at java.awt.Component.dispatchEvent(Component.java:4544)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:635)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
    at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
    confirm is 1
    MacBook-de-Jose-Barrera-Martinez:~ Bite$

  • hi bite, i'm sorry but it really looks like the old one to me! here's how i can tell:

    org.monome.pages.configuration.Configuration.readConfigurationFile(Configuration.java:858)

    this was the exact line/file where i fixed a bug with the serial # not being present in the config file (if you don't or can't use monome discovery). i fixed the bug here and at one point you had a newer jar (i believe i linked you to it on my post-digital.net) and it loaded ok, but then you got non-responsive behavior. i then updated the jar again to fix the bug that caused the unresponsive behavior, but it looks like you're back to the original "serial # not there" bug.

    here is what i suggest: delete all of your pages jars everywhere. then make sure you re-download the zip file from the original post, unzip it, and run that jar file.

    edit: maybe the problem is that you need to copy the new jar from the zip file back to your Desktop. if you're running that from the console and haven't copied a new jar to the desktop then you're still running the same old jar from awhile back (check the timestamp to verify!)

  • yes porthan i had a jar that says pages-0.2.2a.jar who loaded ok,but now when i go to google i swear it,s pages-0.2.1a.jar the old one :/
    Sorry if i am doing something wrong.

  • hi bite, i am doing something confusing -- i am deleting and re-creating the pages-0.2.1a.zip and jar file and not incrementing the version number. i incremented it that one time, but since then i have been re-creating the same file name but with a different .jar file. i think for these minor issues i don't want to increment the version number yet... only when i actually start adding new things.

    the reason i'm doing this is so newcomers to the thread don't have to dig down to find the latest bug-free version, they can just download it off the link in the first post and have the most up to date alpha version.

    sorry for the confusion here!!

    so it is the old name, but the file is different!

  • my hit is that if something changes, change the name. this comes from long history of software production/testing in a working group. make a "minor version" extension if you want to keep things together. uncertainty is death for testers when it comes to versions. confusion only slows the testing.

  • yeah you're probably right. it's really just laziness. i will start incrementing.

  • hey phortran, re: the midi seq poly.
    i am doing the same thing that you are doing except with no results.
    hmmmm... bummer.

  • hey mapmap, sorry i haven't responded yet, i was trying to figure out the issue so it wasn't another "well it works for me!" response, but i still can't get this to happen. :(

    what size monome are you using? is there anything else you're doing before testing the banks?

    (i'd like to add that i wrote the original midi sequencer page but i didn't write this particular mod -- it's a fantastic version but the code is a bit foreign to me, although i'm more than willing to dive into it once i can reproduce the issue)

    my test scenario:

    monome 40h, create a midi seq poly page, hit the bank mode button, push bank one, hit bank mode button again, put in some notes, hit play.. it goes. bank mode again, push another bank button on another row to activate it, back to seq mode, put some notes in, they play. disable/enable random banks, everything seems to happen as expected.

    do you have a 128?? i've only tested on a 40h, that could be part of the issue.

    ---

    in other news i made some progress on a quadrants page last night -- i'm excited to get this going. it's warping my brain a bit but i think it's almost there. i hope to have this available for testing in the next few days.