pages 2 alpha release

  • you're right phortran, ableton only sends midi feedback for controls which have been midi mapped, same channel, same note/cc.

  • HI phortran,
    i'm having problems with the scene launcher page on 8.3.3, i think i've made everything right, installed python 2.5.1, updated the liveOSC folder on the new live directory... what else? maybe i have to install python to an especific directory?
    don't know what to do.

    thanks

  • @pauk - is python is installed on C:\Python25 ? that's the default folder pages will be looking at.

    @phortran - will test a43 tonight or tomorrow. for mmj - do i need it if i'm on win7 x64? i googled and i can only find downloads for osx. thanks!

  • hey pauk! are you still on windows these days or osx?

    for windows pirx is right -- c:\python25 for ableton 8.3.3 and above using the 8.8.3 liveosc scripts.

    i've heard people have good luck with the 8.2.1 live scripts on osx. i put the 8.3.3 on my 10.6.4 machine and it seemed alright but others have had trouble with it. let me know man, or jump into live chat and we can try to figure this out.

    pirx, yay! let me know how it goes. no need for mmj on windows, only osx.

  • :( ok still no luck with it
    python installed in the correct directory,
    still using win7 tom, i'm a pc boy

    edit. everything works in live 8.2.6

  • Pages has been fairly rock solid for me for quite some time now. I've happily been using the most recent versions without any real problems.

    However, today, suddenly, Pages and my Monome are losing a connection every-time I switch pages (via the Monome bottom right button) and come back to a previously loaded page. I thought that maybe it was the most current version 2a43, so I rolled back to a version that I know has been working for me2a37 and I have the same issue.

    I'm on OSx 10.7.4 and have a 2011 walnut 128. Besides downloaded newer versions of Pages, I haven't touched my system.

    Any ideas are welcome!

  • @phortran

    i posted about this in another thread and after some thought figured i would be better to ask for help here. i've got my monome 256 sending midi to ableton via midi triggers no problem, but i'm unable to get it to receive any information from albeton. ie- my leds don't respond at all. i tried hooking up my gs 64 to see if maybe it had something to do with the newer monome model, but the results were the same. i'm running ableton 8.2.2. i'm sending midi to ableton from pages IAC driver bus 2 and from ableton to pages through IAC driver bus 1. i think it might have something to do with the Live OSC folder since i get the same results whether it's loaded up as a control surface or not in ableton. i've tried loading 8.2.1 and 8.3.3 with the same results.

    if i've missed something i apologize. i am relativley new to the monome and this forum. i have been able to figure a lot on my own just by scouring these forums, but this has me puzzled :/. thanks in advance for your help!

  • @Cc as far as i know midi triggers/faders do not make use of liveosc. have you set the page to receive from IAC bus 1 (MIDI->MIDI In-> bus 1 should be checked)?

    @phortran from my testing of a43 everything now works in my set! thanks much!!

  • With further testing... I can confirm that I don't have this problem with a39. Thankfully, all the previous versions were stored in my Dropbox.

    If I use any other version, I can confirm that Pages loses connection with my monome when switching pages. It's repeatable every time for me.

    Also, on a39, I cannot use the LiveOSC8.3.3 scripts in Live 8.3.3. I have to roll back to version 8.2.1 for any connection to Live (eg clip launcher). I seem to have Python correctly installed.

  • @pirxthepilot yes i have midi in for bus 1 checked in pages and checked in the individual page midi-triggers. still no led feedback. it appears that ableton is sending the midi info as well, represented by a red dot flashing in the upper right hand corner.

  • @pauk

    hmm it does have to be exactly Python 2.5 installed into C:\Python25 but i'm sure you checked that. glad 8.2.6 is working.. did you delete everything in the LiveOSC folder before upgrading? the .pyc files could be causing trouble if they remained, you could try deleting those. otherwise you can try opening up __init__.py and uncommenting about 8 or 9 lines in that file (remove the hash symbol) to get logging from ableton. it will create a few files, stdout.txt and stderr.txt that might have information about what is going on.

    @corneliusw

    this is pretty baffling! i have never heard of that happening.. can you change pages with the page menu -> next page/prev page? maybe try running it from the terminal window and see if any errors come up when you switch. you can do that by running terminal, changing to the directory where the .jar file is, and running: java -jar pages-0.2a43.jar

    it will say some stuff about log4j when it starts up, that is fine, but any other messages might indicate a crash. if you see anything let me know and i'll try to fix it!

    a39 working is odd.. i did start using a new build process right around then. do you have java version 6 installed? probably but worth checking. version 7 should be fine too if you have that. if it's version 5 you may need to upgrade java.

    @cc

    yes pirx is right (thanks for jumping in to answer things pirx), liveosc is not needed but midi is needed. you do have to make sure that the 'remote' button is enabled in ableton for the output you want to get feedback on (iac 1) so you might check that. also you should make sure you are using 2 distinct iac devices for this.. the setup could be like:

    iac #1 is midi out from ableton to pages
    iac #2 is midi from pages to ableton

    if you try to use iac #1 for both you will have trouble but splitting it out should fix it. also make sure all the midi settings everywhere are exactly right for this.. only the right inputs/outputs enabled in each app, etc.

    @pirx excellent!!

  • hi tom, no luck :( tryed what you say but not getting these files either.
    this is what i did in the code (attached) but can't see the files
    :_(

    edit. changed py to txt for attaching

  • hey thanks for all the quick responses. i believe that all of my routing is correct though. i've taken some screen shots. maybe i've missed something. please let me know.

  • pauk, try running ableton as administrator so it has full access.. just realized i run it this way all the time for a few plugins that don't work otherwise, but it might also prevent files from being written to c:\

    cc, yes this all looks correct, try installing this library:

    http://www.humatic.de/htools/mmj.htm

    download link here:
    http://www.humatic.de/webapps/php/download/pick.php?app=mmj

    copy the included mmj.jar and libmmj.jndi to /Library/Java/Extensions to install, then restart pages. this solves a lot of midi related things for me on osx but you do end up with 2 copies of each IAC device (at least i do), either one seems to work though

  • @phortran

    I'm away from my studio, so I will try running it from my terminal tonight and let you know how I go. Also, I am running Java 6.

    But for the record, it loses a connection if I change pages form the menu (menu -> next page/prev page).

    I'll let you know how I go running it from within the Terminal.

  • ok so i copied mmj.jar and libmmj.jndi the the java/extensions file, restarted pages (and my computer a few times) and still no led feedback. my computer is a 2007 macbook running in 32bit mode so i tried to install the 32 bit version of both these files and pages wouldn't start at all. i'm not sure if this is important, but i thought i would mention it. thanks for trying to help me get this worked out. i'm sure we'll eventually get it functioning properly!

  • i remember reading a dialogue between you and edison a few weeks ago (sorry if some of this is incorrect!!) where he was having trouble with the leds after switching songs.... and his final solution was to switch back to monomeserial. i wonder if my problem has anything to do with serialosc? unfortunatly i can't switch to monomeserial bc i have 2012 256. anyways, i was eating a chicken wing in my kitchen when this thought came to me and i thought i would share it. sorry if i'm way off!!

  • @phortran

    I might be missing something very fundamental, but I can't launch Pages from the Terminal. I keep getting "permission denied".

    On the bright side, I upgraded Jave to the latest build of 7, and now Pages launches instantly, as opposed to the 30" or so it took with Java 6.

    Now, with Java 7... I can switch Pages from within the menu, but as soon as I press the bottom right hand button on the grid, to switch pages from the monome, I lose my connection.

    Weirdly, 2a39, is the only version fine.

  • this is weird stuff guys! i did get confirmation from pauk on irc that admin mode fixes windows issues.

    @Cc

    i think the version of mmj directly in the folder is multi-architecture so it should work on your 32 bit machine (hopefully!) i would try that one. you can tell if it's working i think by checking your midi devices in pages and seeing if you get duplicate devices (ie. 2 IAC #1's with slightly different names). you will have to restart pages after copying the files in.

    with edison i'm pretty sure it was specifically when opening new sets, closing ableton / re-running seemed to fix it (after also re-running pages). i wasn't able to duplicate that issue but i think his stuff generally works under serialosc/etc until switching sets in ableton.

    @corneliusw

    that is odd.. maybe move the pages jar file to your desktop or home folder? if it's in your home folder you should be able to just drop right to a terminal and:

    java -jar pages-0.2a43.jar

    glad to hear new java is helping a little, and happy to hear that there is a working version for you. i will review the differences between a39 and a43 tonight and see if i can come up with anything.

  • as corneliusw mentioned above i too have to put the 8.2.1 LiveOSC script into ableton for the cliplauncher page to work. using a43 on osx 10.8, java 6 and mmj (etc) installed ... apart from this everything else seems to work fine with the 8.3.3 script, after some short test runs that is ...

  • sorry, you're running script version 8.3.3 or 8.2.1 now? i understood it as 8.2.1 script on ableton 8.3.3 but correct me if i'm wrong :) unfortunately i can't update my mac past 10.7 (work policy) but script version 8.3.3 seemed good for me on 10.7, wonder what changed in 10.8..

  • idd running 8.2.1 script in ableton 8.3.3

  • phortran, tested the cliplauncher page some more ... i'm using ableton 8.3.3 on osx 10.8. when i put the 8.3.3 script in the midi remote scripts folder this page is broken. i get only led feedback for the overdub button, but pushing it doesn't toggle it. mute buttons are also not showing/active. also, there's no 'focus' on the tracks in session view (the yellowish square - which indicates displayed tracks on the monome).

    all this seems to work fine with the 8.2.1 script ... might have something to do with mountain lion since it all seems to work properly on your system ...

    just thought i'd let you know ...

  • thanks for the clarification ithkaa!

    so OSX 10.7 can use the 8.3.3 liveosc script
    OSX 10.8 needs 8.2.1 still

    8.3.3 and 8.2.1 are identical except for some windows-specific config so you really shouldn't be missing out on anything on osx. 8.2.1 just won't work on windows.

  • hey fluxsta, this conversation is kind of spilling into different threads but i thought i'd bring it back here :) it could be that the particular app you're trying to hook up through external app is trouble. i've tested a few apps (mlr, 7up, stretta stuff, etc) and they seem alright.. i guess the best way is to load up monome_test and see if you have any luck there.

    if not i'd bet on a more general networking issue. do me a favor and turn off all of your network devices and see if that makes a difference. i'm thinking either a firewall or something is binding to the wrong device. it could also be an ipv4 vs ipv6 issue -- you could try setting the OSC Hostname to '127.0.0.1' instead of the default 'localhost'.

  • Thanks again for the info mate. Got a bit of time tomorrow minus kids do will post back. FYI I had always had it going ok with most versions of mlr and mlrv, polygome and a few others. Thanks bud

  • Weird, turned off wi fi and i was able to connect apps and pages? Steps i took:

    1. open pages
    2. open max
    3. open apps-mlrv and polygome
    4. pages new config, 2 new pages
    5. select in drop down on app (was able to connect this time and recognised my monome).

    Didn't need to change host name, but I have that to try next time I encounter problems. Thanks phortran....legend. Patience and perseverance my friend

  • Hi phortan!

    Feedback works in a43, but the triggers can only send notes and set as toggle...

  • @phortran

    thanks for all your responses!! sorry i haven't been back with an update, it's been a crazy week. so it looks like the mmj files are working on my 32 bit machine bc i do have duplicates of each port showing up, but still no midi feedback/lights happening :/. any other ideas?

  • hi all,

    been improvising a bit with pages ... thought i'd share ;-) : http://vimeo.com/48228914

    thanks for this great app!!

  • ooh allow me to share a vid too:

    (also posted this on the stikshift thread)
    http://vimeo.com/48253538

    thanks so much @phortran for the great app and being very accommodating with our requests :)

  • hey guys, sorry been really sick this past weekend and finally getting better, i will review the latest stuff soon :)

    i did check out your vids ithkaa, really awesome stuff man! love it! i'm going to check yours out next pirx :)

    thanks for sharing guys!

  • thx phortran ... get better soon!

  • hey man, no worries about the questions! :)

    sync is a bit tricky across a lot of separate apps. basically you need to designate one program or device as the midi clock source or 'master' and the rest as 'slaves'. each page in pages can run off of the same midi clock signal / midi device, so that makes it a little easier, however this doesn't really count for external apps. i think in max/msp if you're running multiple apps in the same instance of max they can all share the same sync signal / midi device as well. so if you're using pages and a few max/msp apps you will need 2 midi devices sending the same midi clock messages to keep everything in sync.

    i'll give you a concrete example using ableton as a master / midi clock source. first you need to pick two IAC devices to use as sync sources. you will go to midi preferences and enable the 'sync' button for both of the 'Output' sides of the 2 IAC devices and turn everything off on the 'Input' sides of those devices.

    now ableton will send the same sync signals to both of those devices and you just need to tell each application to use them. it would be much easier if applications could share midi devices nicely but they just don't really do that unfortunately. this is also why you need to disable the 'Input' side of these devices in ableton -- you can think of each IAC as two devices, an input and an output. so Ableton is using the outputs and each application (pages and max/msp) will use one of the inputs.

    let's say IAC #1 has been designated for pages. you'll load up pages and load up a midi sequencer page (this is the easiest one to test midi clock i think). next you'll turn on IAC #1 input in both the main midi menu and the midi sequencer page's midi menu. turning it on globally makes it available to the pages and essentially 'opens' the device (making it unusable in other applications***). selecting it in the page midi menu routes it to that specific page instance. the pages that use midi sync will pick up on this signal and start going and you should see the midi sequencer moving in time with ableton.

    the process is similar in max/msp but it's going to be dependent on each individual app and how/if they use midi clock (and how you set it up in that app). however given that max/msp is really one application you should be able to use that same IAC #2 to sync up all of your max/msp apps (say boing, mlr, etc).

    another small detail in how pages works -- enabling a midi input from the global menu is enough to drive the non-page-specific midi sync features (such as pattern recorders) for every page.

    *** footnote on using midi devices across multiple applications: sometimes this sort of works for awhile, but it never ends well, best to not go there. :)

    hope this helps!

    edit: un-whispered this in case it can help anybody else

  • @matino

    i will look at that! a bit short on time at the moment but when i get a chance to test.. thanks for the report.

    @Cc

    well that's a good start at least! mmj is good stuff from what i've seen. i reviewed your screenshots/setup again and it looks perfect to me. we must be missing something else -- try the super simple case: create a clip in ableton and midi map it via triggers and see if you get some feedback.

    if you're trying to get midi feedback off of a drum rack you'll actually need to create a second midi channel, set it's midi input to the drum rack channel and output to iac #1 and then set monitor to In.

    you could also try a midi faders page, map a fader to the volume on a track and see if you can get feedback off of that when moving the fader up and down.

    hopefully one of these three tests gives you -something-!

    @ithkaa

    again great vids, love the use of the midi generator page!! and thanks for the well wishes.

    @pirx

    love the setup!! that lpk25 is fantastic isn't it?

  • thanks for detailed description bud! Hope ya feeling better now? I have had a host of evil bugs and just getting there myself now, beginning to feel human. Now when I did have pages configured correct and working, minus wi-fi and network connections all was well but as you said

    'footnote on using midi devices across multiple applications: sometimes this sort of works for awhile, but it never ends well, best to not go there'.....yes i will actually leave alone! ha ha.....

    Now, I am currently battling with the set up AGAIN!!!!! It simply will nor connect to apps whatever i do, and when I click 'connect' nothing....It simply eludes me what the issue is? So temperamental for me, I also changed the hostname as you outlined and still nothing. It doesn't matter how i set up and in what order this is just really hit and miss my friend. Any ideas about any other steps to take? When it works this is just an immense piece of work and is what i had always envisaged doing with the monome after first getting one and tinkering with one or two apps, but it just seems to be so temperamental on my machine? Brand new mac, all steps followed and sometimes it works, sometimes it doesn't

    Cheers mate

  • Ignore...i am being dramatic and a pain in the a**

    Just went back to using a previous version of pages and it seems to set up fine. So have finally saved a config that works. To add insult to injury the gear junkie in me has just delved into the Arturia Spark. In terms of 'midi sync' i ain't even going there........Ableton as master and all is well......

    Rocking 4 apps on pages though, phortran...huge work mate and glad that (at present) seems to be the end of my issues.....damn newbie fluxsta ;-)

  • hey great! that worries me that the latest release has a problem...

    if it comes back up again randomly let me know, i have an idea since disabling the wireless seemed to work once, but if it's working now then that's great and let's hope it stays that way! :)

  • good news!!!!!! i did get feedback from the midi faders page!! it was pretty exciting, i'm not gonna lie. with the midi triggers though all i've mapped is clips. i'm not even ready to mess with mapping a drum rack right now. pages and the monome seem to be sending midi info just fine, but still no lights. i think we may be getting closer though! thanks for all your help!

  • Hi phortran, thanks for checking things out!

    I also have the same problem as others with midi. Sometimes the midi income in Live shows its receiving notes from the sequencers of pages but don't trigger anything. It happens pretty randomly...
    When it happens, the only thing that works for me is to restart my computer totally...

    I added mmj.jar and libmmj.jndi to /Library/Java/Extensions, but no luck...
    Mac 10.7.3 / Live 8.2.8 / java 6 (14.3.0)

  • Don't know if this has been addressed yet, but my MIDItriggers page is pretty inconsistent.

    I've set all columns to ableton clip but in a43 only the leftmost half of the monome gets any LED feedback at all.

    In a40 the entire length of my 128 picks up on where the clips are in ableton, but only the left half gets blinking feedback when playing. The right stays solid. I've swapped clips around in session view and found that clips that didn't blink back on the right, do in fact blink on the left.

    When experimenting with rows as opposed to columns, everything responds as expected in both versions. All solid LEDs to indicate the clips, and all clips send blinking feedback back. Problem is, a vertical monome is not possible with my performance technique.

    If this gets figured out its my ideal setup. Something that resembles a basic ClipLauncher page, but with the quickness that I've found plain MIDI has more so than LiveOSC.

    Thanks 'tran.

  • Re lpk25 - yes very handy for gigs and composing while travelling! I can say the monome can be a keyboard too, but nothing beats the real thing :-)

  • i should have some time this weekend to figure out midi triggers feedback.. ugh, bugs! some of the groovy pages might be a good substitute in the meantime..

  • Take your time my friend. No rush. I was doing everything completely blind without pages, so even what I've found here is an awesome improvement over how I was triggering before. Thanks again as always.

  • hey phortran, i've jumped onto the pages bandwagon and i'm liking what i see -thanks!

    one suggestion - i have a variable brightness monome and i'd love to be able to send MIDItriggers a MIDI velocity of 64 and see a half lit led on the monome.
    no idea how easy/hard that would be to do; surely not as simple as changing the OSC command to level/set x y l?

  • hey guys.. haven't had a chance to look at this stuff yet, but i haven't forgotten! soon.. some of these issues will take a bit of work, especially the 128 vertical mode stuff, but it does need to get figured out.

  • hi phortran! thanks so much for the great work!

    pages-0.2a37 works great but i'm having trouble with pages-0.2a43. My problem seems to be a lot like corneliusw, i loose all connection as soon i switch a page or even perform an action (like launch a clip.)

    here's what see in terminal :


    Exception in thread "Thread-15" java.lang.ArrayIndexOutOfBoundsException: 10
    at org.monome.pages.configuration.MonomeConfiguration.redrawLedLevel(Unknown Source)
    at org.monome.pages.configuration.MonomeConfiguration.handlePress(Unknown Source)
    at org.monome.pages.configuration.MonomeOSCListener.acceptMessage(Unknown Source)
    at com.illposed.osc.utility.OSCPacketDispatcher.dispatchMessage(Unknown Source)
    at com.illposed.osc.utility.OSCPacketDispatcher.dispatchMessage(Unknown Source)
    at com.illposed.osc.utility.OSCPacketDispatcher.dispatchPacket(Unknown Source)
    at com.illposed.osc.OSCPortIn.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:680)

  • thanks for the error report, should be an easy fix! will see what i can do.

  • Is it possibru to have two pages contained in one quadrant?

  • sorry, one page per quadrant, not sure how that would work anyway? both pages get the presses?