pages 2 alpha release

  • Well, the ability to switch between two apps in a single quadrant.

  • the way it's coded that's not very easy to do unfortunately, however you can make 2 full quadrants pages with the same stuff in the other quads except for the one quad you want to change. if you're using midi feedback / liveosc feedback they should mirror each other pretty well.

  • So you must mean:

    Page 1:
    Quadrant [L]: extapp-XXXX1
    Quadrant [R]: extapp-XXXX2

    Page 2:
    Quadrant [L]: extapp-XXXX1
    Quadrant [R]: extapp-XXXX3

  • Okay so I got a new 13" Macbook Pro last week and was hoping this would solve my ableton to pages-midi-triggers feedback problem, but had not luck. I did however install serial osc 1.1e earlier this week and started to do some testing. I was unable to get any of the newer versions to communicate the feedback effectively, but I was able to get pages v 2.36 working perfectly :). I'm not sure if any of this feedback helps but I wanted to pass it along. If all continues to go well I will be using pages in a performance situation soon. Thanks for the great program!!

  • Glad to hear it's an easy fix! Sorry about the strange formatting of the paste from terminal text. Dunno what happened there :P

    Also, i've been enjoying coastal and mysteries of the universe - good stuff!

  • hey guys, again sorry for the delays here, been doing a few remixes and haven't had a lot of free time outside of that but i'm all done with that and actually preparing for a little show in the next month, so updates should be coming! :)

  • I'm having an issue with Quadrants crashing Max. For some reason every time I use 64faders controlling parameters in Live, Live will show cpu spikes and eventually Max will crash. However this does not happen when 64faders is standalone, or if is its own page. Any idea why this is happening?

  • pages a44 is up, it has some quadrants bug fixes and some new groovy pages.

    https://github.com/downloads/dinchak/pages-2/pages-0.2a44.zip

    quadrants fixes:

    * column drawing had an issue that caused weird artifacts
    * pattern recorders for individual quadrant pages (only accessible via groovy) had issues

    new groovy pages:

    DrumRackPage -- another take on the 64 fingers / pattern recorders, but maps better across multiple drum racks

    ArcLivePage -- a lot of the features from ArcControlPage condensed into a simpler interface. sets pattern lengths of a DrumRack / MIDILoop page, moves playhead on DrumRack patterns, and has midi CC loopers/recorders.

    MIDILoopPage -- slightly modified to have a 'baseMidiChannel' variable at the top defaulting to 12 (channel 13).

    @bwandace

    re: ext app / quadrants setup, yep you got it. re: quadrants issues, try this release, hope it fixes it!

    @Cc

    try this latest release, hope it fixes it!

    @simardown

    this led level code has been backed out completely in the a44 release, i'm just not going to attempt multi level led stuff now since i don't have a device that supports it and can't really test it. this was what caused the crash so hopefully it's fixed now.

    thanks for the kind words re: the music!

    @raja

    LOL :D

  • @phortran
    Please share some of your music with us! I'd love to give it a listen.

  • @nowawakelow

    thanks! here's my latest release: http://phortran.bandcamp.com/

  • Your music is inspiring mate. All vey atmospheric and crosses many genres..... All made with just a monome?

  • @fluxsta

    hey thanks man, actually i don't use the monome when writing music much at all. it works better for me as a live performance interface. i usually write with a midi keyboard and mouse in ableton arrangement view.

  • hell yea man sounds awesome, loving the artwork as well friend.

  • thanks man! my girl made the art :)

  • Hmmm, I'm still having the same issue with 64faders in its own quadrant crashing Max. Ill also get this fuzzy (sounds similar to a dirty pot) sound every time I change a parameter in 64faders.

    Any ideas?

  • Having a bit of an issue when I change pages using the monome. If I double tap the Page change button or hold it for too long the tempo will jump up or down quite drastically. Any ideas?

  • hey bwandice, eekrecordings, not really sure on those issues but will try to look into them...

    in the meantime we have a45 with tilt support in external application page / groovy page!

    https://github.com/downloads/dinchak/pages-2/pages-0.2a45.zip

    thanks to CheeseNoOnions for helping test this out!!

  • hiya phortran. finally had a chance to test out the new version. my issues are resolved and everything works great - cheers!

  • hi phortran,

    when working with a midifaderpage the connection (to ableton) gets lost after a while (30 to 45 minutes). a bug? or something i missed maybe? any idea? ... was hoping to use pages for an upcoming gig. everything else works great, just this midi connection getting lost is preventing me from choosing 'the pages way' ;)

    osx 10.8.2 - ableton 8.3.4 - pages 0.2a43

  • hey ithkaa, have you tried out the mmj library? check out the bottom of this page for instructions:

    http://pages.post-digital.net/docs/installation

    hope it helps! i don't do enough on osx myself to really know beyond that unfortunately :/ but it did clear up midi issues i was having, which was ableton's global midi indicator flashing when sending messages but the messages never getting to tracks. curious if you're seeing that same behavior w/ faders.

  • tx for the swift reply phortran. yeah, installed those initially, don't think they're helping ... for me, the global midi indicator in Live doesn't show any midi action (of a midifaderpage) at all, after some time, say 30'. will test some more ...

    another problem : when loading a configuration file, pages sometimes doesn't load anything up ... or something 'unworkable' (midi options and monome options greyed out, etc.). don't know what's wrong here, but saving in my User folder brings this problem. seems like when i'm saving to another location the config loading is fine ... will test more on this too ;-)

    tx in advance!

  • hi phortran,

    been playing around with different versions of pages and switched LiveOSC folders (8.2.1 - 8.3.3) but still ableton loses its midi connection with pages (not only the faders but also f.i. midikeys and midipads). sometimes takes 50+ minutes, sometimes only 25 minutes. any idea of what's going on?

    is there a way to monitor this connection? i'm on osx 10.8.2 - ableton 8.3.4. any help is appreciated. this really is a great app ... would use it all the time if only this problem would 'go away' ;-)

    cheers!

  • hey ithkaa, you can try running it from the terminal and see if any errors come up when it stops working. use the command:

    java -jar pages-0.2a45.jar

    if you aren't familiar with the terminal you'll use the cd and ls commands to navigate folders and list folder contents. if pages was in your downloads folder you would type:

    cd Downloads
    ls
    cd pages-0.2a45
    ls
    ** at this point you would see the pages-0.2a45.jar file
    java -jar pages-0.2a45.jar

    it should run as normal but some output will be displayed in the terminal, once it stops working see if it prints anything out (all other output should be considered normal)

  • Tx! Will give it a shot later today!

  • hello phortan,
    i was using balron with pages and pattern recorders,
    i would like to know if you are planning to add some new functionality to the pattern recorders?.It would be nice to have a mute pattern too instead of erase the pattern and record again as actually works.
    and, Are you excited with the new device by Ableton?? Pages for Push? or not interested at all ?;)

    That all!

  • hi phortran,

    after watching this awsome video, http://vimeo.com/34207934, i tried to set up the midiloop groovypage, with no luck. I've got everything else running perfectly, but it seems like there needs to be some input by me on the groovy page, and I can't seem to get it right. Any help would be greatly appreciated.

    I'm running the most recent version (pages-0.2a45)

    Thanks

  • hey bite, sorry i am probably not going to change the way the pattern recorders work in the current version. it is possible to change this behavior with a groovy page by creating your own custom pattern control logic. i can give you some pointers on this if you are interested.

    as far as pages for push goes... yes :) i've been working on some experiments in node.js with the end goal being rewriting pages to work with all the grids. all of them. it will do this by creating a serialosc emulation layer that makes any grid act just like a monome, so it will be usable outside of this new version of pages itself. the new version will be the same sort of idea but more configurable (ie. the ability to rewrite the pattern logic easily) and i'd like to build in solid spanning/splitting from the get-go and a few other things we've been missing for awhile.

    *** ALL FORMS OF HELP ARE WELCOME ***
    feel free to look over this stuff and try it out, come find me on live chat / irc if you're into it and i can help you get it set up / we can build this thang.

    here's what's in the works so far:

    https://github.com/dinchak/node-monome -- a serialosc / monome communication/abstraction library. makes it easy to send led commands.

    https://github.com/dinchak/node-serialosc -- node-serialosc, a serialosc emulation module.

    https://github.com/dinchak/node-asciimonome -- simple implementation of the serialosc emulation module to create an 'ascii monome'. textmode display and takes keyboard input.

    https://github.com/dinchak/node-midigrid -- this will be the future "midi-based grid serialosc emulation" module. livid blocks, apcs, launchpads, probably Push as well, any grids that speak midi. not much here yet.

    https://github.com/dinchak/node-monome-pages -- bringing it all together, at some point, into an actual usable app. there is really nothing in this module yet.

    thanks james, the midi loop page does require a source of input (a keyboard in the video) and you need to select the device in the midi input menu of the page. this will route the keyboard's midi output into the page and you can then record / loop it. i also route the midi out of the loop page and into ableton. it basically looks like this:

    loop page midi inputs:
    IAC 1 -- clock from ableton
    LPK25 -- midi input from keyboard
    outputs:
    IAC 2 -- midi to ableton

    [##keyboard##]--->[groovy page]--->ableton

    hope that makes sense :)

  • thanks Phortran, that does make sense. So there's nothing i need to type in the midiloop groovy page itself?

  • that's right james, you shouldn't have to change the midi loop page groovy code at all. if you click run and nothing is happening you might open up the log window and see if any errors are coming up. paste those up if so and i'll try to help debug it.

  • Thanks for the responses, I'll let you know how it goes.

  • Hey i figured it out, i was sending midi from keyboard on midi channel 12, instead of 13......doh!

    Thanks again Phortran!

  • Thanks phortran, but it,s not neccesary ;) !!
    code is not my thing and have no idea about making my own groovy page.I don,t want to mess with more things now than i have already ;)
    I think the only way i can help you it,s cooking for you, or make your daily work so in this way you,ll have more time to do it ;)

  • you'll cook for me? do you have a couch i can sleep on? i'll be at your house tomorrow :D

  • jajajajjajajajj...you.ll love andalusian/spanish food. " Potaje"and " Gazpacho" are masterpieces.

  • hey tom, you have another couch here :D
    I wait you tomorrow for dinner!
    bite is invited as well and the couch is pretty big for you two

  • lol!! alright moving to spain, you both are too nice

  • been trying to get pages working on my mac for a bit now. I've read through the majority of this forum and still can't seem to get it to work. What I've done is this:

    Installed 0.2a45
    Tried the mmj extensions

    When I create a clip launch page, square c8r7 is lit but pressing buttons does nothing.
    When I create a sequencer page, the line scrolls across monome but pressing buttons does nothing.

    When I run from terminal, I get the following:

    log4j:WARN No appenders could be found for logger (socketLogger).
    log4j:WARN Please initialize the log4j system properly.
    log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
    resolved device: monome\03264\032(m64-0796)._monome-osc._udp.local.
    OSCFactory: began listening on port 12345
    creating 8x8 monome with prefix /m64-0796
    Exception in thread "Thread-12" java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
    at java.util.ArrayList.RangeCheck(ArrayList.java:547)
    at java.util.ArrayList.get(ArrayList.java:322)
    at org.monome.pages.configuration.MonomeConfiguration.handleTilt(Unknown Source)
    at org.monome.pages.configuration.MonomeOSCListener.acceptMessage(Unknown Source)
    at com.illposed.osc.utility.OSCPacketDispatcher.dispatchMessage(Unknown Source)
    at com.illposed.osc.utility.OSCPacketDispatcher.dispatchMessage(Unknown Source)
    at com.illposed.osc.utility.OSCPacketDispatcher.dispatchPacket(Unknown Source)
    at com.illposed.osc.OSCPortIn.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:680)



    Been at this for a few hours now. Any help would be appreciated.
    Oh yeah. On MBP with 10.7.5, using Ableton Live 8.3.4.

    Thanks in advance!

  • hey dieselsynth, there was a bug in the tilt code but i think i have it fixed now. i also fixed a faders bug in this release:

    https://github.com/downloads/dinchak/pages-2/pages-0.2a46.zip

    let me know how it goes.

  • That seems to have done it!! Thanks a heap!

  • great, thanks for confirming.

  • Hi there.

    trying to run pages on OSX 10.8.2 with 2012 monome 256. Ableton 8.3.4.

    Got all but the ableton remote apps eg clip launcher working fine, sync, midi etc.

    I assume it's a LiveOSC problem.

    Could anyone confirm they have this working on a similar setup. It would give me impetus to keep trying.

    thanks for all help

  • hey Richarde, try the 8.2.1 LiveOSC scripts, I think 8.3.X still has some problems on OSX. i need to get this sorted out, sorry for the confusion. 8.2.1 should work fine on 8.3.X.

  • Hi Phortran,

    I got the same issue as ithkaa.
    Pages stop sending any midi data after a while and whatever the type of page.

    The time for the problem to happen is a bit random.
    I modified a Groovy page to get a FingerLooper that works with my foot controller FC-300, I bought it because of pages groovy page possibilities :'( .

    The weird thing is that it still receive the inputs' data.
    I tested in a groovy note() function to verify that.

    I'm on OSX 10.6.8 with Ableton 8.2.2
    I'll try to run it from the terminal and send you the error message.
    I just hope it's not a bug from the mmj library...

  • hmmm yes please send a stack trace if you can get one, also i released a46 which may fix the bug?

    check the groovy log window as well.

    drop by the live chat as well, might be easier to debug it realtime.

  • thanks Phortran, that's got me going. Thought I was losing my mind!

  • Hi Phortran,

    I'm using a46 atm.
    I didn't get any error messages from the terminal
    here's what I got:

    Macbook-de-Vincent:pages-0.2a46 vincentpalumbo$ java -jar pages-0.2a46.jar
    log4j:WARN No appenders could be found for logger (socketLogger).
    log4j:WARN Please initialize the log4j system properly.
    log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
    Reading configuration file: /Users/vincentpalumbo/_MonomeSetLooper2
    MonomeConfiguration no serial: created org.monome.pages.pages.MIDIFadersPage page
    MonomeConfiguration no serial: created org.monome.pages.pages.MIDISequencerPolyPage page
    MonomeConfiguration no serial: created org.monome.pages.pages.GroovyPage page
    OSCFactory: began listening on port 6001
    Added listener for /128/press on port 6001
    MonomeConfiguration no serial: created org.monome.pages.pages.MIDISequencerPage page

    I made a test by recording the step sequencer in ableton
    Pages stopped sending the midi notes after 28min
    but it didn't stopped right away
    before that the notes started to look longer randomly.
    Here's a screenshot of the recorded sequence when it happened

    1102 x 383 - 24K
  • Hi Phortran,
    Thank you for helping me out on the live chat.
    I modified my Preferences in Ableton so it didn't use the midi inputs/ouputs used by Pages. Even though there was no midi feedback there might have been a conflict between the two apps.The problem seems to be solved now since I manage to work with pages open for 7 hours today. Just to let you know.
    Thanks again :)

  • thanks for updating the thread!! glad to hear it's resolved now.

  • Hi, I have pages 0.2a46 on OS X 10.7.5, and when I launch the JAR, no window appears, and nothing else happens. I get the org.monome.pages.Main menu (with no options in it) and nothing else. Can anyone help?

    I do get this when I launch from the terminal:
    log4j:WARN No appenders could be found for logger (socketLogger).
    log4j:WARN Please initialize the log4j system properly.
    log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
    Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError: /Library/Java/Extensions/libmmj.jnilib: no suitable image found. Did find: /Library/Java/Extensions/libmmj.jnilib: no matching architecture in universal wrapper

    Edit: NEVER MIND, this was FIXED by installing mmj. http://www.humatic.de/htools/mmj.htm