New App: Tilty Magee... Now with Max4live!

  • Tilty Magee is an open ended tool to allow you to turn the accelerometer data of your monome into midi cc data. One of the advantages of this tool is that it remains active regardless of monome serials current prefix.

    Edit: Now with max4live!

    http://docs.monome.org/doku.php?id=app:tiltymagee

  • Outstanding, thanks! Tilt is way underutilized, although I keep trying to integrate it more into my monoming. This will help.

  • Sweet. This will definitely make tilt much more accessible, and could allow for very simple but welcome things like controlling an effect in ableton. In fact, this seems great to add effects after a m4l mlr page and control that.

  • Actually have you tested this out in Ableton? I'm able to calibrate and set everything up and when I hit send x or send y the nice little yellow light in ableton turns on, so I know the MIDI is coming in. However, when I tried to map a control of an effect to just my incoming X-axis data it never picks it up. I'll rethink everything for a bit longer tonight and write if I figure it out.

    EDIT: Didn't figure it out but did make it crash, which is always good to know. I turned off the send X-Axis toggle when still moving my gs64 and it stopped completely. There was no movement on the test axis. My monome was still plugged and recognized by monomeserial so don't think that the issue....

  • @McDelta...

    Make sure that your midi device is set on for remote

    @all

    I just realized the app will not work if you are trying to use max4live devices... so I'm working on a max4live version but running into problem sending out the midi data...

  • Cool will remember that. But actually the tilt stopped working on me now, which is weird. Jumping between tilty and gome to pseudo-debug.

  • If you are running max4live... you can't have a max4live instance + a max/msp instance both connected to the same host port with monome serial

  • Hmmm. Not running a max4live patches. The tilt in gome is picking stuff up.

  • Is there any way to get an M4L version of this going? It's a lot simpler to have it right there inside the Ableton.

  • There is a max4live version in the works.

    I tried to port it the next day but ran into some trouble with the way ableton handles midi / the way abletons api route device information.

    So it requires a pretty big rewrite... thankfully I think there is another app I can take some stuff from to make it essentially have hte same functionality.

    May not get a chance to get to this until next week though

  • @jeffromusic,

    "a lot simpler" is relative. Remember, Live won't map to the CCs it generates through automation or M4L apps. Not directly, anyway.

    Make sure you're up to speed on IAC / midiyoke / etc. A M4L version is going to require that you have a few virtual MIDI ports installed, know how to use them, and know how to configure Ableton to let it map those.

    This is something you should take the time to set up, whether you use this app or not. It's crazy empowering, and overcomes a great many limitations within Live.

  • Max4live version made...

    tp://docs.monome.org/doku.php?id=app:titlymagee

  • Well, this isn't next week!

    All right, scratch what I said about the virtual MIDI cables. Still worthwhile, but not required for (or used in) the approach TheAlphaNerd chose.

  • i don't get them to work?
    the max 4 live one started working when i loaded it. i calibrted everything was fine. then i pressed the tilt input toggle and now i can not get it to send tilt again.
    do i need to some how turn it on in monomeserial?

  • The tilt toggle box's are there to turn tilt on and off the tilt without having to go into MonomeSerial... If you hit the toggle and are not getting anything try hitting it again!

    Which monome are you using?

  • i use a grayscale 64.
    here is a video.
    i have also tried opening the max window. no errors...
    https://dl.dropbox.com/u/1832226/tilt.mov


    this also happens in the standalone one. and my tilt works in mlrv..
    anyone have a tips?

  • For now enable tilt in monomeserial and don't hit either of the tilt toggles... Perhaps the grayscale deals with the tilt command differently

  • and how do i do that =) ?
    what to i have to write, and where? bit of a noob maybe. sorry..

    so i know that my tilt is working on my monome 'cos i have used it, but i can't turn it on :(

    so i saw a video with what looks like another version of monomeserial. and it had toggleboxes for tilt. mine doesn't.

    what?

    i have version 0.30

  • @thealphanerd

    have you tried this with djfx? thinking about the way the fx mod in mlr 2.51++ uses the tilt to modulate a set of built in fx on a 64 a la daedelus.

    possible this way using djfx and tilty?

  • Definitely... you could connect the outputs to a slider in any app... :D

  • @Kris thats interesting that your having the same problem as me in both the m4l and standalone version, because I have a gs64 too. Maybe there is something that the Greyscale does differently with tilt. I'll try out your suggestion in a bit.

  • ok so i found a workaround. if i turn on tilt i mlrv. close mlrv. then it is on and works in tilty to. but if i toggle/unntoggle tilt input in tilty then nothing works before i turn it on in mlrv again...

  • Yeha I have an idea what could be causing that... I'll try and take a look at the code in the next couple days

  • Sooooo... Tilty version 1.1 is now available... I believe I have fixed the issue that stopped non kit monomes from being able to activate tilt

    Let me know if this works!!!

    http://docs.monome.org/lib/exe/fetch.php?media=app:tilty_magee_v1.1.zip

    http://docs.monome.org/lib/exe/fetch.php?media=app:tilty_magee_m4l_v1.1.zip

    One thing also... you have to hit a button on the monome after turning on tilty for it to get the prefix in order to set tilt on...

    So
    1) Open Tilty
    2) Press Button on Monome
    3) Open Tilt Calibration Settings

  • now works flawlessly on my gs 64 =) thank's so much!

  • but one question. since the m4l version is working with live api(?) in stead of midi. Is it higher resolution than 128?

  • @Kristoffer

    Yes and no... The max4live version works using beautiful floats... but you will be limited by the actual devices in live... Tilty in live auto scales to whatever effect you connect it too...

  • Thanks much, just saw this update and it now works beautifully without any flaw and really is as universal as I thought. I will definitely use this in my next show.

    To test it I just made a quick square wave synth in Ableton's operator and then mapped the LFO rate to X and Filter Freq. to Y and went to town. It made me extremely giddy with that kinda sci-fi / fast dubstep sound.

  • Glad to hear you are enjoying it so!

    I just uploaded a custom version of Tilty I just put together for someone... it is essentially midi_press_64 with tilty built in

    http://docs.monome.org/lib/exe/fetch.php?media=app:midi_press_with_tilty_v1.zip

    This version is not universal at all :D

  • so my filtherresolution is now much bigger than with midi? that is pretty sexy!

  • This is fantastic. Just got it setup and I can't stop throwing around some sick filter sweeps in conjunction with mlr.

    Although, I have to remind myself in the future to not get too crazy with my 128. Its already sort of fumbled out of my hands and onto my desk once. :/

    @thealphanerd Thanks so much man! This is exactly what I was looking for.

  • Hey guys,
    I used the midi press with tilty max patch for a small set this past weekend. It was a little quirky, but still fun. The the patch would suddenly stop receiving input so I had to keep the tilt setup screen up and click on "tilt input" when it became non responsive. I also couldn't get it to work with quad. I'd love to be able to use something else with it.


    Anywho. Here's a video.
    http://vimeo.com/32828680

  • Are you using serialosc?

  • lolol.. yeah I havn't updated tilty in quite some time... and I could see there being problems with serialosc

    if it is not receiving input there is one possibility... are you changing patchs? the way that tilty was designed, it needs to receive button press data before it can start snaggin the tilt data

  • I'm using MonomeSerial. I wasn't changing patches at the time. At the beginning of the video you can see where I have to occasionally hit my trackpad to toggle "tilt input". What would happen is I would be shaking the crap out of my gs128 and could hear where it stopped working (0:49 & 0:57, for example). For some reason clicking the tilt input on and off would fix it.

    I haven't tried pages, yet. I like quad. It's really simple. For some reason, though it doesn't like the midi w/ tilt app. Thanks for the patch though, alpha. I was pretty nervous going on stage. I asked a buddy if I could play a short set that night. It turns out he squeezed me in after a really rockin' (prog rock?) band whose set was cut down to 15ish minutes so I could play. I had no idea. The crowd was pretty upset when they got off. I wasn't sure how they would handle an improvised electronica set. With tilty, I was able to avoid bodily harm.
    The whole moving around thing seemed to get people's attention.

    "I'm alive today because of Tilty, and I approve this message"

  • Looking for some help. I'm fairly new to the monome. I have a 2011 128. I can see tilt information when I run the monome_test_grid but haven't been able to have any other application see that data stream. In tilty when I go to setup there is no raw data. I'm not sure what I'm missing at this point. Any help appreciated.

  • Are you using serialosc or monomeserial?

  • The 2011 GS are SerialOsc, but I've tried using the conversion patch for MonomeSerial as well and haven't had sucess either way.

  • they won't work with monome serial?

  • I'm pretty sure the 2011 greyscales will work with monome serial. Tilty does not work with serialosc

  • I was running the app that converts SerialOsc to Monoserial for older apps. And still nothing. But, I might be still missing some piece of this puzzle.

  • I think you should try uninstalling serialosc. There's a script in the same folder as serialosc. Don't worry, though, it's easy to reinstall. Install monomeserial and give that a go. I've found that the monome bridge doesn't work with all apps. I'm kinda in the same boat as you and I think I'm going to start trying to get into Pages2. A lot of people recommend it.

  • hmmm I think that the best way to use this port with serialosc would be to use my serialosnoopy patch... that should work out of the box me thinks

  • Is there a simple way to use OSC data with Ableton? Could Tilty be bypassed completely and just use the tilt data directly in to map to parameters?

  • Do you have max4live? there is a max4live version of tilty that does just that

  • Yes, I have max4live. But, I'm still missing something because I'm not getting any raw tilt data to show up in the Tilty Max4Live window.

    I'm pretty sure the problem is Tilty is not designed for serialosc and the bridge app doesn't seem to work with the tilt data. And I don't understand how to use the snoopyoserial workaround.

  • ok... so it looks like there is a big difference in the way the serialosc deals with tilt compared to monomeserial...

    The issue right now is that serialosc does not support tilt on 40h models... so I am unable to test my code.

    If you give me a week or two I am going to try and get all this stuff up and going. The plan is to try and get support for 40h tilt in serialosc first... and then update tilty with a version that supports serialosc... most likely via serialosnoopy.

    There is a possibility that this could be done fairly easily in pages using groovy as well...

  • Thanks for checking this out. I don't really understand how to program with groovy, but maybe phortan would know how to do this.

    are there any other applications for serialosc that use the tilt function? i can't find any.

  • Bumping this thread up. Still looking for help getting tilt data on serialosc GS 2011 in order to convert to midi.