MK Vista Setup Help with Soultion

  • I have been trying without sucess, to set up my MK kit on my 32bit vista laptop.

    I have been previously using a gs128 on the vista laptop with the older monoserial (2.1.2a?) When I tried to install the 3.0.0 version of monoserial (the version used for the MK) I get the following error:

    "this applicaation has failed to start because API-MS-Win-Core_Localregistry-l1-1-0.dll was not found".

    I have been using both my gs128, and the 40h mk kit suscesfully for months on my desktop (64bit Windows 7)

    I have reflashed the MK Kit with each firmware update, and have absoutley no problems with the MK on the Desktop with Windows 7 with the newest monoserial.

    The gs128 works great on the Vista Laptop with the older monomeserial. So I am starting to believe the issue lies with some kind of conflict with the MK, Monomeserial 3.0.0 and the MK.

    I also tried monomeserial 2.1.5

    In which I have sucess with the mk-set on Vista Laptop with the MK, but no communication between the MK and monomeserial when moving onto monome-test in the monomebase patch folder. (I can get monomeserial to read the prefix from maxpatches using this version of monomeserial)


    Any Suggestions would be helpful

    I searched, and all I could find was
    http://post.monome.org/comments.php?DiscussionID=9231
    which is the issue I am having, but this topic, dosent really seem to have a soultion.

    Thanks in advance.

  • Vista Mk user here. Went through all this same trouble. Monomeserial 3.0.0 will only work on Windows 7 unless you download the API Library I believe it was called, either way, I didn't do it. Using monomeserial 2.1.2a everything works fine.

    I found that with my vista laptop, If I plugged in my Mk kit before installing the FTDI drivers, it would install the generic windows ones and they messed everything up. I couldnt even even install the FTDI drivers on top of them, it just wouldnt work. So the generic windows drivers may also be a problem

  • Thanks for the reply,

    So mabye ill try unstalling the FTDI drivers? then reinstalling the FTDI drivers?

    got nothing to lose..

  • Yeah well you would want to unplug monome -> uninstall drivers-> install driver from FTDI website-> plug in monome-> jump for joy

  • is your mk flashed to m128-000 or similar?

  • @tehn,

    It flashed with the latest firmware and has been working flawless on my Desktop running Windows 7 x64) with makefile edited to COM-4, and shows up in Monomeserial as mk000034, just no communication
    ....hmm
    running on COM 3 port on the vista laptop,
    ... Mabye changeing COM Port might reslove...
    still dosent slove error in monoserial.

    did some uninstalling, about to reinstall and try again.

    thanks for helping me get this working.

  • OHH YEAH, forgot about that tehn,

    Housefly, reprogram the name of your device, let me see if I can find the thread

    http://dangerousprototypes.com/2010/01/27/pirate-rename-get-a-nicely-named-serial-device/

    and rename your device

    I believe the names were m64-0000, m128-000, m256-000 depending on your model

  • @ FingerTappin,

    when you say "rename" are you refering to the makefile?

    The link to the rename device tutorial, seems to be for OSX, (could be mistaken)

    How did you rename your device?

    Thanks again for your help.

    I seem to be cool, as far as getting communacation with mk-set, and I know its not a problem with the mk solder joints, as I have been using it for months on the desktop.

    Oddly I can plug in the gs128, and it works fine.

    all suggestions listed above, with the exception of rename device.

  • No I am actually referring to renaming the physical device. It wasn't fully working for me until I did that. It renames the device on the FTDI chip after it has already been given a name. Follow the instructions on the site and rename your kit accordingly, it should work.

  • @ FingerTappin,

    I must be thick headed, because I am missing something, please bear with me : )

    I understand the concept of renaming the device, and I have went through the tutorial, and down loaded Piraterename from the site, when I go to open the windows (priate-rename.exe) version, a terminal window pops up for about .01 seconds, then nothing. I can see its a ms-dos looking window, but cannot see what it says as it dissapears so quickly.

    any suggestions?

  • @housefly

    for windows, use ftprog: http://www.ftdichip.com/Support/Utilities/FT_Prog_v1.10.zip

  • @ Tehn & FingerTappin,

    Thank you both. It is working now.

    Here is the soultion for anyone who wants to use Windows Vista with an MK series/Kit:

    1. Install the latest Ftdi Drivers http://www.ftdichip.com/Drivers/VCP.htm
    2a. Install ftprog http://www.ftdichip.com/Support/Utilities/FT_Prog_v1.10.zip
    2b. ftprog needs .NET Framework 2.0 (You probally already have 4.0 installed, so no need to install if you already have .NET framework 2.0 or higher installed.
    3. Plug in mk into usb port
    4. Run the ftprog.exe
    5. Scan for devices under the device menu at top of ftprog
    6. Under FTEEPROM tab, in the device tree, expand "USB String Descriptors"
    7. Change values acordingly. (See attached Screen Shot)
    8. After changing values, right click on "USB String Descriptors" and click program device (by chooseing this method, you only change the USB String Decsription, and not the whole EEPROM)
    9. Close ftprog.exe
    10. unplug USB, and then plug back in.

    Use Monoserial 2.1.2a

    11. Run Monome_test

    The above is condensed it into a step by step, which I could not have done without the help of FingerTappin and tehn.

  • Great little guide. I apologize for my misinformation above regarding the program to rename in vista, I did it so long ago. Glad to hear you got it working! Enjoy!