mk updates! important!

  • UPDATE!

    major optimization and bug fix just posted! **all logic kit users are advised to flash your firmware:**

    http://docs.monome.org/doku.php?id=tech:mk:flash

    =============================================
    check the mk page for recent updates:

    http://docs.monome.org/doku.php?id=tech:mk

    i am happy to announce that all mk sources (firmwares, bootloader, circuit schematics and boards) have been posted:

    http://github.com/tehn/mk

    i've also written up a tutorial on how to reflash your firmware:

    http://docs.monome.org/doku.php?id=tech:mk:flash

    and a tutorial for 40h keypad users:

    http://docs.monome.org/doku.php?id=tech:mk:alt

    and i'll have a tutorial on adding encoders up in a short while.

    new monomeserial about to be posted, though we're having a few bumps that will be ironed out shortly.

  • bah!

    despite my best testing intentions, i discovered after finishing the 40h keypad compatibility firmware that the "standard" firmware (that i shipped with the first 50-ish logic kits) has a bug in row/col/frame messaging.

    **if you received one of the first 50 logic kits, you can easily flash your firmware for a fix!**

    http://docs.monome.org/doku.php?id=tech:mk:flash

    the new sources have been uploaded to github. follow the instructions, let me know if you have problems.

  • hey tehn, how do I open the .sch and .brd files? These seem like the extensions used by KiCad, but I can't open them.

  • most likely Eagle.

  • correct. they're made with eagle.

  • peek at aux: http://docs.monome.org/doku.php?id=tech:mk:aux:encoder

    will finish up the tutorial mid-week. must pack and ship orders now.

  • i was able to flash and it said ok.

    when i plug in device it get a diagonal line on both grids. checking to see if that i have it correct.

    i still get no button response, but i assume it is due to monomeserial update which is forthcoming? I do get button response with the mk-set patch but that is only program.

  • I'm assuming I'm in that first batch, considering I just received it. =D

    Will I need to flash the fix if I'm not using 40h keypads?

  • @flplsx: yeah, the standard firmware has a problem. it's pretty simple to flash the firmware.

    @scubasteved: i'm about to post the new monomeserial but i haven't tested it. let us know!

  • http://docs.monome.org/lib/exe/fetch.php?media=app:monomeserialsetup.rar

  • monome serial wouldnt even load up

    error message attached.

    1201 x 289 - 25K
  • i'll forward it on to kevin.

    did you try serial-pyio? also, yes, the firmware flash worked! the diagonal line indicates the alt-firmware.

  • just saw. that is obscure indeed.

    you said you're on win7, 64 bit, right?

  • on my laptop at the moment
    win xp

    using serial pyio v0.4.1, some of the test apps work like random and animation test. but no button press

  • so, msvcrt.dll is microsoft visual c++ runtime, which /should/ have been included in the bundle. i'm not getting that error on my machine cause i have the runtime installed (comes with visual studio)..


    it looks like it wasn't in the installer's dependencies, so i added it and built the installer.

    now at:
    http://docs.monome.org/lib/exe/fetch.php?media=app:monomeserialinstaller.rar

    sorry that you have to be the guinea pig for this, but it worked over here! =/

  • ah xp might be the culprit.

    the attached rar has both an msi and an exe setup.. try the exe?

  • exe didnt work.
    i got the visual c++ runtime from MS, but still no luck

    switched to my desktop, which is win7 64.
    monomeserial opens, i dont get the error message. i tried monome_test no led activity or anything.
    tried mlr also. nothing.

    also i noticed when i click the send prefix button, it sends nothing to monomeserial.

    do i need a certain version of python or max?

  • ack, one more known issue -- you need to adjust the host and listen port before they work properly. so, bump each one up, then down, and you should be good to go.

    sorry for that inconvenience. i'm looking into why that's the case and how to fix it.

  • lights work after that, but not button response in monome_test

  • you sure you changed both ports? also, what is your cable orientation? there are weird issues right now with it set to anything other than left

  • i have it set to left.

    my grid is laid out according to the pictures from the wiki

    do you know if the firmware if specfic to certain size of grid?? i have a 128. Should i disconnect a grid and try just one?

    man i wish i could get this to work.....
    wish we had more testers, to see if its just me doing something wrong.

  • oh, um.. this is a shot in the dark (i've been doing my testing on a 128 flashed with an mk serial number and presses work fine), but, i think you need to send "/sys/grids 2" to 8080 so that your firmware goes to the right place.

  • things are now working
    very happy
    thanks for the help
    :)

  • I am going to join in the testing on my 128 report back shortly : )

    //Windows 7 x64 intel

  • question -- when you close monomeserial and open again (in windows), do you have to fiddle with the port, or does it remember them from your defaults?

  • I posted my results eariler, but for some reason they didnt post...

    @ soundcyst - No there was no saving of ports or cable orentation as a default, the only save was the current sys prefix.

    upon restarting of app, you had to go back and again change the host and listen port as well as orentation.

    You mentioned eariler that you were having issues with orentation, but that seemed to be fine (with the excetption of cable orentation) I use down (as my cable is phyically on the right).

  • Could someone confirm what format the schematics and board image are in? I've tried opening with KiCAD, and now Eagle. No success with either.

    Error message:
    "Invalid data in file /home/johnny/electronics/monome kit/mk-logic/mk-logic.sch!"

    any chance someone could do an MD5 checksum of this file so I can see if the file is perhaps corrupted? Even if the schematic was made on windows or OSX, I assume it should open on the linux version.

  • nvm, I realized that I tried to right click the file name and save as on github. It seems this downloaded the page... which is weird. Kind of confusing that the page address is also the name of the file.

  • so a few times half of my 128 the led brightness will fade to about half. It is happening to both sides randomly. One side will be full brightness and the other will fade.

    any ideas?

  • @stkmtd: there's a download link at the top of the github page which allows you to download the entire repository.

    @scuba: i've never seen this happen myself. can you take note of when this happens? are you using a full-powered usb port? (what type of computer is it? no hub right?) does it go half bright but still function?

  • was using ableton with m4l, mlr 21, pitches and obo running. using auto focus

    the button press still works, eventually the lights will fade out to nothing but still functions.

    win7, 64
    ableton 8.13

    no hub, plugged into usb port directly to pc.

    it tends to happen when i push buttons on both grids.

  • what kind of LEDs did you use?

  • jameco 333340

    someone posted them somwhere on one of the threads.

  • i don't think it has to do with the LEDs.

    once it fades, could you try going to monomeserial and activating the "test" mode to light up all LEDs?

  • not sure i follow on what you what me to do.

    the test patch in monome base apps?

    Edit:
    attached is shot of max window from m4l app pitches. Something not happy.
    i was running pitches when buttons went out (along side mlr, obo), all leds on left side stopped, button press still worked. right side remained fine.

    Both sides go out, its not like its just one side that keeps droping.

  • I'm having an issue updating the firmware. I got the serial # from my dev folder and added it to the makefile in the alt-encode folder then rank " make boot" in the terminal and got an error.

    JH-MacBook-Pro:alt-encoder JH$ make boot
    avrdude -p m325 -b 115200 -P /dev/tty.usbserial-mk000006 -c arduino -e -V -D -U flash:w:mk.hex:i
    make: avrdude: No such file or directory
    make: *** [boot] Error 1

    tty.usbserial-mk000006 exists when I "ls -l" in the dev folder

    Any ideas what is going wrong?

  • @tehn, soundcyst

    Fried my arduinome board today so I thought I would give the mk kits a try. Running windows vista ( i know i know), 32bit. Drivers installed immediately. Just to check opened MProg, blank devices=0, Programmed devices=1, sounds good. BUT, when I installed monomeserial off the doc page with the mkkit updates, it asked me for the API-MS-Win-Core dlls. Not being sure what these were, I looked them up and they seem to have recently been added to the OS in windows 7. Am I just missing something, like .Net framework or is this a windows 7 check that has been added to all versions?

    Monomeserialsetup seems to work, ill have to flash the new firmware seeing as I have mk00049.

    Its Monomeserialinstaller with new mk support that give me the problem

  • Just tried flashing the new firmware, same error as the poster above me. I made sure to change "Serial= COM4" as COM4 is what my logic is connected to

    679 x 513 - 69K
  • @fingertappin:

    i have to fix the makefile for windows users. type (copy past):


    avrdude -p m325 -b 115200 -P COM4 -c arduino -e -V -D -U flash:w:mk.hex:i

  • @ralin: did you install crosspack? it seems like avrdude isn't being found.

    at the prompt type: avrdude

    to check if it's there.

  • @scubasteved: i was able to replicate this fading-out issue. i'll have a new firmware fix in a bit.

    for some reason a grid gets sent an "intensity" message when it shouldn't be, so it lowers the brightness. you can set the intensity back to normal by using this extra patch: http://post.monome.org/?PostBackAction=Download&AttachmentID=3171

  • it also seems to get thrown into shutdown mode sometimes.

    here's a "reset" patch. for the moment you can just keep it off to the side and if anything weird happens, hit "reset"

  • edited top post.

    major bug fixes. LED refresh optimized massively. bug removed where keypad mashing may trigger unwarranted LED dimming and other weird behavior.

    the new firmwares pushed to github, re-download the sources!

    also fixed the makefiles! remember to re-enter your serial port. "make boot" will work on all platforms now.

    updated instructions here:

    http://docs.monome.org/doku.php?id=tech:mk:flash

  • big thanks to scubasteved for the testing and patience.

  • glad i could help.

    i will try out the new firmware and report back later tonight.

    has monomeserial been updated yet?

    changing the ports up and down everytime is somewhat annoying. And i still forget a few times.

    I did notice that i tried out serial pyio and it seemed to make button press stop working, i had to reactivate the grids with mk-set patch. So i would suggest peeps avoid it.

  • @tehn

    Yep, I was missing crosspack. Silly mistake. Thanks

  • Firmware good to go on windows. Thanks tehn

  • yea new firmware much better so far.

    anyone withi windows makes sure when editing the make file be sure to type the "COM" in caps. messed me up for a bit.

  • i haven't reupped monomeserial.

    @fingerTappin, i have a vista desktop at home that i will try to make the next build on.

    the next posted build should have the fix for the up/down port thing too.

    re: serial-pyio and button presses -- the serial protocol for the kits is subtly different from the series. the grids message is the same as the "activate auxiliary ports" message, but the different devices handle them differently, so if serial-pyio sends that message out thinking it's talking to a series device, you're going to get unexpected results.

  • Running Vista 32, I should note I have no button pad until tomorrow. I am using a livid keypad from the starfire arduinome groupbuy.

    1. Loaded new firmware, plugged in Monome, get led diagonal
    2. Reinstalled Max
    3. Made sure msvcrt.dll was installed
    4. Ran mk-set and monome_test64, nothing
    5. Opened Monomeserial, bumped ports up, then down, orientation left.
    6. Opened Max, then nerdscroll ( since I have no buttons). Listening on port 8000. Nothing

    -Sometimes when I plug in, I get three leds, 2nd, 4th and 6th rows, 4th column that stay on and will not turn off ( hardware problem, or firm/software?).
    - Also tried the "encoder" firmware, get a wave when i plug in. Same happens as above

    Sorry about the length, just giving as much info as I can.

  • @fingertapping:

    mk-set only sets keypad input. LED activity should work regardless.

    how many grids are you using?

    LEDs staying on (alternating columns) sounds like something might be going on with hardware. but then, if the startup pattern looks right (either a diagonal or a round explosion depending on the firmware) something else might be going on.

    always good to double check your solders. headers are key.