mk updates! important!

  • @tehn

    1 grid

    Tried both firmwares, got the diagonal and the explosion.

    Double checking solders now. Will edit post when done

  • how does the ft245 chip look on your logic board? there aren't any small metal bits stuck between the legs?

    does the keypad press data come in perfectly?

  • Ft245 looks good, no bridges.

    No keypad yet, coming by UPS today at 5pm est.

    I am using the livid keypads, so I should be using the alt-encoder firmware right? I assume that the firmware, "encoders", is solely for the mk keypads with the direct driver attachment to the boards.

    Any other tests to tell if this is software or hardware related? I have a multimeter.

    On the driver, is the header next to the electrolytic cap input or output?

    Also, in my quest for knowledge, I was changing cable prientation like crazy, including opposite orientations between the logic board and the driver. Could I have fried the driver?

    USB serial device COM4 appears when plugged in, loading firmware is successful everytime.

  • alt is only for 40h keypads, where the grids are rotated. it shouldn't matter for only a single board. they have identical functionality.

    you didn't mention if the keypads sent data correctly-- that's important.

    i doubt you damaged the max chip, but hard to know.

  • Just got the pads. Tried almost every possible roataion of the cables for the board and no key press functions. I also don't get the start up led indicator anymore. Clamping new cables as we speak.

    At this point, because of no indicator, I am leaning towns a hardware problem at the moment.

    There is a certain orientation, in which I get sporadic led activity and button presses without touching anything in mk-set

  • yeah-- no startup pattern means LED driver problem or cable problem.

    so are you using a full mk kit now? or still parts of something else? why would you have to rotate cables? did you check the assembly guide? the cable layout is all there.

  • I had the startup until I started messing around too much. I'll put together my other led driver and see if it helps.

    I am not using the full mk kit. I have a v1 button board from the starfire group buy. In v1 of the button boards, the header pins where switched on the input of the keypad. A workaround for this was crimping a ribbon cable on one end with every pair of the 16 flipped, so up is now down and vise versa. The cable had no problem in the beginning, leading me to believe its the driver. Assembling now.

    If the 2nd driver works, ill obviously know I fried the other.

    btw, thanks for the help!

  • OK, Figured it out with @tehn and @soundcysts help. It's the generic drivers windows vista installs for the FTDI chip, then subsequently blocking the driver installation from FTDI because windows drivers are there already. Now I just have to figure out how to get rid of them. :)

    Thanks!

    @VISTA USERS: INSTALL FTDI drivers/exectuable BEFORE plugging in your device!! It will save you a big headache.

  • windows port fix:

    http://docs.monome.org/lib/exe/fetch.php?media=app:monomeserialsetup20100805.rar


    looks like presets may also save for kits.. =)

  • @ soundcyst

    Thanks a million buddy, testing out now, although I'm quite tired

    Still needs API-WIN-CORE dlls, not included with vista, should i download?

  • @ soundcyst Who0t!

  • Is there only one way that you can attach the driver to the keypad or should I be able to flip it so that the ribbon cable connector points into the monome?

  • is it possible to combine the old keypads and the new ones in case i decide to upgrade ever?

  • @scubasteved http://docs.monome.org/doku.php?id=tech:mk:alt

    @ ralin, there is only one cable orientation from the driver that will work correctly.

  • @ralin cable must point out. you can fold the ribbon under if need be.

  • @scuba yes i think so.

  • new mac build. not entirely sure if i fixed the problem, but it looks like it's behaving better on my end.

    :: link edited out.
    visit http://docs.monome.org/doku.php?id=app:monomeserial for the latest version ::

  • looks like that didn't fix the problem, i still found a stray -133bajillion in a button mashing stream.

    new update posted again. i mashed buttons for a good 10 minutes straight and didn't get a single -130bajillion, so, this one is much less likely to be broken.

    as a tradeoff, the kit's response from /sys/version never makes it through to osc.

    :: link edited out.
    visit http://docs.monome.org/doku.php?id=app:monomeserial for the latest version ::

  • Could it be that the Eagle layout files miss some information for some components? A friend of mine that has knowledge in electronics and that I asked to help me building a monome from the scratch told me that. Below I'll list the details for every of the three components (logic, driver, pads) and I hope to get some answers.

    ----------------- LOGIC --------------------------

    C7 4.7k PANASONIC_B rcl (0.6 1) R0
    information missing: Voltage specification

    C9 470u PANASONIC_E rcl (0.2875 0.9) R270
    missing: Voltage specification

    L1 L3216C rcl (0.5375 0.8) R90
    missing: value

    X1 USB_B monome (0.4875 0.4) R0
    missing: type specification


    ----------------- DRIVER --------------------------

    C9 10uF TT2D4 rcl (0.175 1.575) R0
    missing: Voltage specification

    R1 iset 0207/7 rcl (0.225 1.425) R180
    missing: value

    RN1 SIL10 resistor-sil (0.775 1.575) R0
    missing: value / type specification / parallel or serial connection?


    ----------------- KEYPAD --------------------------

    E$65-E$66
    missing: type specification

    -----------------------------------------------------


    Thx for your help!
    Nube

  • @nube: are you trying to learn or save money? you won't save money doing this from scratch, especially if you're going to directly replicate the work without trying to understand what's going on.

    for example-- the usb port on the logic board. if you looked at the photos and have even the most basic idea of usb plugs, you'd see it's a type B.

    i don't mean to be rude, i simply want to encourage some learning. also this should be a new thread.

  • I'm on linux, and although I was able to discover my serial number through Visinin's monomeserial, I had to set my serial to be "/dev/ttyUSB0" to get the firmware to load. Is this a linux thing?

    Also, I've tried using serialpyio, but I can't manage to add my device. The device is in fact at /dev/ttyUSB0, but I can't add it, I get an error. I am trying to add this mk device as a 40h. Is serialpyio currently lacking code for these mk kits?

    Anyone on linux know if I can do anything at the moment? I tried libmonome, but the example programs don't work. The device is working though, I get the explosion effect when I turn it on.

    Also, there's two versions of the firmware, I used "encoder". What is the difference between this and "alt-encoder"?

  • @stmktd

    From what I gather, the difference between alt-encoders and encoders is the keypad you are using. Alt-encoders are for tiling different keypads together, for example, if you are using 40h keypads with the new mk-pads so they can be tiled correctly. Apparently, as tehn mentioned above, there should be no functional difference between the firmwares if you are using a 64.

  • serial-pyio doesn't have mk support right now. theoretical support is there, but i've had bad luck with devices newer than 40h (i have a 256). i'll add the serial prefixes for mk devices, but I don't want to dive in too deep and start adding the additional serial commands.

  • the mk protocol is nearly identical to a 256. it's a 256 with some extra stuff.

    also, thanks for the heads up with the firmware programming in linux. which linux are you using? i'll add this to the wiki.

  • Hi there,

    I'll add support for the mk to serial-pyio as soon as I get my hands on my kit. A friend of mine should bring it to me beginning of September. Avoiding customs takes time...

    @Tehn: did you post somewhere the doc for the protocol ? Or should I just look into the firmware ?

    @visinin: can you mail me with your problem for the 256? It should work just fine (at least for buttons, leds, and accelerometer). I got multiple reports that the series are working correctly. Skore, a former dev of serial-pyio, had one of each device and used them without any problem.

    Jul

  • Nice one, got my kit in the post today.
    Can't wait to put this together, have to finish my thesis first!

    @ jul: actually got a surprise when I went to collect it. Customs didn't get there hands on it this time! No extra charge- First time in a while.

    @ tehn: I flashed the newest version firmware so everything is in order when I build it. It was pretty straight forward which is nice. Do you think the firmware version with the dimmable LEDs could be ported to the new kit, I can't see why not but I don't want to go messing with the code if theres no point.

  • re: intensity hack. yes, it's possible, but you'll never get completely flicker-free operation with the current hardware since there's no way to perfectly synchronize the refresh rate of the driver and the PWM of your packets. there are lots of old threads that discuss this.

    but yeah! go for it!

  • @tehn, Ubuntu 10.04. If the address is different, monomeserial seems capable of detecting where the device is under /dev

  • correct me if i'm wrong, but according to the driver assembly photos, that state that the ribbon cable should be attached such that the flat parts of the connectors are facing upwards at both the driver and the logic board, should there not be a twist in the cable in the last photo of the assembly guide showing the the logic board connected to the driver and grid?

  • Just finished my 80h kit yesterday, but when I ran monome_test.mxb I'm getting pad input from a whole row when I press any single pad on that row. I ran a couple other patches and same issue. The buttons are triggering themselves sometimes also, without being pressed. I have a screenshot of the malfunctioning pads in monome_test attached. Anyone know what might be causing this? I'm running Snow Leopard on a Macbook Pro if that helps.

    423 x 750 - 60K
  • @chthonic: correct!

    @elquinto: is it only on that one row? did you run mk-set and set it to 2?

  • Thanks for the help. I did run mk-set. I later disconnected the second board (the one with the problem) and set mk-set to one, and then the first board started acting up. random pads were being triggered without being pressed and monomeserial kept crashing. I followed the setup and how-to guides to the T. Any help is much appreciated.

  • I re-heated my solders, and the pads seem to be responding better now. Thanks for the advice Tehn!

  • I just assembled my mk kit and flashed the device w/the bootloader. No problems there and I got a diagonal LED line when I plugged it back in.
    When trying to launch Monome Serial I get the error message attached. I tried re-installing but still got the same thing.

    Also, I can run the mk-set.maxpat but it doesn't seem to do anything. I get this message (2nd attachment) from Max. The patch runs and I can click on the grid and all, but nothing happens on the monome.

    I'm using Vista 32bit.

    Any ideas about how to make Monome Serial work? hard/impossible to move forward without it. I don't think I missed any set-up steps. Thanks!

    487 x 110 - 16K
    502 x 198 - 25K
  • fingertappin had this same problem, and it seems to be related to vista. we're in the process of compiling monomeserial for older operating systems... developing on win7 doesn't help things :[


    re: the com port thing, (and i might be a bit off, as i'm not a frequent windows monome user), it could be that you don't have the FTDI driver installed?

    on mac i usually get something more like USB-blahblah-serialnumber.

  • @pang: did you set your device to a com port between 1-4? i wrote this up in the wiki for flashing.

    also are you using old 40h keypads? just checking since you flashed the alt firmware, not the normal one

    do they keypads or leds work in mk-set?

  • The pads on my 80h are still being triggered without being pressed. I thought I had the problem solved, but it seems it just shifted to a different spot. Now its the top left 2 pads that are being triggered randomly. After a lot of troubleshooting I think I've isolated the issue to the logic. When I plugged in either of the grids individually, the same pads were acting by themselves on both boards. I've triple-checked all my solders, all looks good. Looks like I may need a new logic. :(

  • i followed the advice of @fingertapping and made sure that the FTDI drivers were properly installed and NOT the default ones that Windows installs for you. That fixed my error message in Max.
    No error message in Max, but no responsiveness either. Nothing happens when I push a button down on the monome and nothing lights up if I click on the grid on the screen.

    I'm using all new mk stuff (serial number mk000020). I redid the firmware using the regular encoder firmware. so i've seen both the diagonal and now the LED wave pattern work properly when i plug in the monome.

    re: monome serial. should i try to install the missing API-MS-Win-Core-LocalRegistry-L1-1-0.dll file? or is that being fixed with a Vista monomeserial update?
    thanks!

  • Monomeserial is crashing almost every time I start it up a patch now. I've been testing the pads with either monome_test or boiingg, but now in boiingg I have columns of leds that are lighting up from top to bottom, then instead of bouncing back they just start at the top again without any sound. I saw the top row light up from right to left, while others were going up to down, and even leds going from top to bottom while another led will be bouncing in the same column. Not all the led activity is even being shown in the 128 visualizer. I'm new to using a monome, so I'm really confused. been tryin to make it work right for a while now.

  • the only part of the kit instructions I did not understand was that I couldn't find the white dot on the circuit board that matches with the one on the resistor network. Can someone post a picture showing where its located?

  • @elquinto: it's not really a 'white dot' on the circuit board, but a extra white outline around that hole. just make sure your resistor network matches the orientation seen in the assembly photo (http://docs.monome.org/lib/exe/fetch.php?cache=&media=tech:mk:assembly:mk-driver05.jpg) and you'll be fine.

  • okay i did the right orientation. thanks

  • @elquinto: responded to your e-mail.

    @pang: before getting monomeserial working we need to get mk-set working. which com port is your device set to? you see the device detecting fine in your windows device manager?

  • my device is set to COM4, and as per instructions i put SERIAL = COM4 in the firmware Makefile that is now loaded onto logic board. It is being recognized in my device manager, and looking through the device's properties i found the mk000020 serial number so drivers/etc seem to be installed correctly.

    I've tried opening mk-set.maxpat in both Max 5.1 and Max Runtime 5.1 but i still get no interaction. i've attached a screenshot of what i see (which is not much). the error message is back, but it appears it's related to COM2 port, which i'm sure the monome is not on. and when i use the mk-set drop down arrow for serial port list i get port COM1, port COM3, and port COM4.
    i set the mk-set to port COM4 and number of grids to 1. if i close and re-open the maxpat again it defaults to port COM1 and grids 0.

    1310 x 575 - 106K
  • the patch doesn't have bidirectional communication, so when you load it won't tell you what you set it to last time.

    do you get the error when you select COM4?

    after you set grids to 1, can you mash keys and see anything?

    and you've been able to flash the firmware, so your drivers are probably all fine, correct?

  • no error when selecting COM4, the error just displays when i first open the patch. button mashing after set grids to 1 and port to 4 does nothing. no LEDs light up, no response from Max.
    i've flashed the firmware just fine (currently getting the LED wave when i plug in).
    i just happened to unplug the device while Max and the patch were open and got "serial: error reading from serial buffer" repeating endlessly.

  • @pang

    I wanted to know If i had a software or hardware problem. I still haven't gotten my kit running on my vista computer as I still have the generic USB serial device drivers and can't find/overwrite them. I tested my kit on my sisters windows 7 laptop ( that comes with the API-WIN-CORE dlls) and everything worked except light test in mk-set ( I used a different test patch from @soundcyst where press and lights worked). I will be reformatting my vista laptop in the next two days and we will get this working. Try the monomeserial without the mk-support in the wikidoc, might help.

  • @pang: something must be busted somewhere. if you can flash your chip, the logic board is working. if you see the explosion LED pattern, your boards are connected correctly. if you can flash via the bootloader, serial communication works with your OS. the last link right now is that max isn't working with serial for some reason.

    which version are you using? (apologies if posted already)

    could you try running 256serial_howto.mxb in the base patches /howto folder? any response?

  • @ tehn: I remember you had a problem where the LEDs could be sent a random intensity message, when you fixed this did you fix it in the alt-encoder firmware. Im running a 256 on the old keypads, I've noticed a few times in the last two days where one of the 8X8 grids goes dim (pretty random which grid). Its defiantly an intensity issue because I can fix it by sending /sys/intensity/1.0
    Maybe the new monome serial has something to do with it?