Problems with kit, monome test

  • I have just finished putting together my 64 from the new kit. FTDI and monomeserial are installed and my device is detected. When I run monome test in Max, I get no response from my 64, as if max cannot detect it. When I press the sys/prefix/test button in monome test, no change occurs in monomeserial. If I manually change the prefix in Monomeserial to /test , I still get no response.

    I don't have any experience with this stuff and this is my first project, so let me know if I left any important info out

  • what operating system and version of monomeserial are you using?

    do you get a startup (lights) pattern?

    if on windows, try adjusting the ports (set them up/down) back to the original ports... kevin mentioned that in the mk updates thread. might help before the fix arrives in a bit.

  • Windows 7 64 bit. Monomeserial version No lights at all so far though all of my solders look good and I'm sure I used the right orientation for LEDs and diodes.

  • tried changing the cable orientation and still no lights. thanks for the help eager to get this working

  • whoops.. monomeserial

    The installer says but when I run from the start menu it says

    Pretty sure this was addressed somewhere and I think is the right version?

  • Ok..

    Reinstalled monomeserial, bumped the ports up and down and I now get a response when I press the change prefix button in monome test. I get a lot of seemingly random activity on the left grid in monome test which seems to fluctuate when the buttonboard is moved. Doesn't seem to react to pressing the buttons and still no LED activity.

  • hi cptkirk, the vs. issue is mentioned in the wiki as a known bug.

    sorry if it threw you off.

    flickering like that may indicate intermittent connections, or may just be the way your LEDs work.

    have you run the mk-set patch to set the number of grids you have wired up?

  • Alright, I ran mk-set, intially I made no progress and got the same sort of erratic behavior with no light at all. I took everything apart and looked at all of my solders, decided to go over the right angle header on the logic a second time. Plugged everything back in and ran mk-set again, this time with some success. A few flickering lights at first, then I assigned the grid and was able to run monome test. I was able to test all the LEDs and they all worked, but after playing with monome test for about 2 minutes the LEDs stopped lighting up. My keypresses are still registered on the grid but no light. Could there be a connection issue somewhere? Where should I start looking?

  • sounds like a connection issue to me.

    since your button presses still work, i'd start looking around the max7221 chip (it's the LED driver)

    make sure all of your solder joints are shiny and look like hershey's kisses. if they're matte or look like spherical beads, then you probably have a cold joint that needs to be resoldered.

    when resoldering, it's best to use new solder. using solder wick dipped in a little bit of flux will help you get the old solder off efficiently.

    also, and this is kinda basic, so apologies if i'm underestimating your soldering skillz, but i've seen it happen at least twice around here -- make sure you don't have any bridged connections. from what you described, i doubt you do, but i figure it couldn't hurt to mention.

  • Last night, at the height of frustration, I decided I would redo anything that looked questionable on the logicboard. I finished up and went to bed without testing, and this morning I find everything works, as far as I can tell, exactly as it should! Monome test runs flawlessly, all my LEDs work and my button presses are registered. Thanks for the help tehn and soundcyst, now I get to spend the next week figuring out all the fun stuff!

  • thanks kevin!

  • I'm having similar issues with my mk. I see the start up pattern, then in monome serial the test mode switch lights up all the led's, but in monome test i cant get any led's to light up. all my button presses show up but i cant get led's to work. They worked for a bit but now they arnt working any more. All of my soldering looks good, is there a way for me to see if the joints are actually good or any chips I should focus on?

  • operating system?

  • OSX, snow leopard

  • hmmm. if your lights are lighting up in test mode (with the checkbox), then it's probably not a hardware issue.

    but if the lights were working and suddenly aren't, it sounds like it isn't a software issue either.. maybe a configuration issue?

    are you sure your prefixes are correct?

    more details about exactly what works and what doesn't and what your configuration is will help us figure out the problem...

  • I may be starting programs in different order or leaving them open instead of closing them which could be causing the different behaviors if that stuff matters. Right now I plug in the monome with all software programs shut own. I see the test pattern then start up monome serial version .3 and hit the test button which lights up all led's. Then I open mk-set.maxpat and set it to one grid. Button presses don't show up in mk-set and it doesn't turn led's on either. Then I shut down mk-set and open monome test and hit the button to set the prefix. Monome test shows my button presses in the upper left 8x8 of the 16x16 grid, but neither setting it to press or toggle (and pushing buttons) or clicking buttons on the right grid lights up any led's. Monome test was the program that very occasionally had the ability to control the led's.

    Last time I had it working I unplugged the keypad from he driver to repair a diode solder and when I reconnected them it didn't work anymore.

    Let me know if there are other programs I should be trying or other infomration you need, I'm still very new to this. Thanks for the help.

  • are you unchecking the test mode box in monomeserial?

    you should only need to do the mk-set thing once, by the way.

  • also, read this thread:

    if you haven't flashed your firmware, that could be part of the problem.

  • I'm unchecking the test box and I flashed the firmware to the lastest version posted in that thread. Do I need to set a prefix for mk-set? It's hard to tell if its having an effect since it's not getting any key presses which work in other programs.

  • ok, so, do this in order:

    1) open the mk-set patch, set your number of grids, test pushes and lights

    2) close mk-set

    3) open monomeserial

    4) set prefix to whatever it needs to be for the test patch

    5) open the test patch and push buttons.

    monomeserial and mk-set will probably compete for serial resources, so that is another area of concern.

    if the test patch reads presses and gives you lights, then you don't need to worry about using mk-set again unless you change your hardware.

  • If I open mk-set first then click to select usbserial-mk000006 and set it to one grid I get button presses to show up. They don't show up unless I select usbserial manually even though it is selected by default. Lights don't work.

    After I close mk-set and open monomeserial and set the prefix the button presses show up like normal, but still no go on the lights. hitting test mode from monomeserial still lights up all the led's reliably.

    I tried this about a dozen times and it pretty consistently does the above. One time the led's worked just fine though and one time a whole row lit up a bit slightly on a button press.

    edit: I was unplugging the monome between tests, and the sequence plugging -> monomeserial -> monome test got the lights working once but I can't repeat it.

  • huh.

    well, if lights don't work with mk-set, then it's probably not a monomeserial problem, which makes me feel better, but doesn't really help you any.

    i can't think of why the lights would work in test mode and not in normal use..

    maybe the intensity is at 0?

    sounds like a question for brian at this point.

  • I will look into the intensity and wait for brian's input. Thanks a ton for the help.

    Update: I messed around with it till the lights worked in monomserial + monome test again an played with different apps for an hour with no problem. I then quit monomeserial and started up mk-set where the lights would still not work then opened monomeserial back up but the lights would not function there anymore either. It went from working to not working without unplugging or moving the monome.

  • ok--

    mk-set only sets the keypad input. it has nothing to do with lights. you should only need to do this once (unless you flash your firmware, you'll need to do it again).

    after that-- open monomeserial. open monome_test from the base patches. click the prefix from monome_test. now try both keypads and led testing. make sure ports are set to 8080 and 8000.

    let me know what happens.

  • I tried this about 20 times unplugging the monome and shutting down max and monomeserial after each test then starting these steps all over again. The led's functioned correctly about 20% of the times I tried steps. It showed the test pattern every time, but it did not hit the test mode switch to see if that worked (it worked every time I tested it previously)

    monomeserial ports are
    listen: 8080

    I guess it might also be worth mentioning that the rotations in monome serial are not working properly either. Left makes my button presses show up in the upper left section of the 16x16 grid in monome test. Top and right don't show any of my button presses in monome test and bottom only registers button presses in an 8x4 area of my monome.

    more info: I just tried plugging the monome in and opening monome test then leaving those plugged in and open but launching and quitting monomeserial. It shows the same behavior as above. Some times there is no led activity when I click on the monome test led grid, but other times it works just fine. All of this was done without touching the monome. I am setting the prefix each time.

  • @ralin - restart your puter

    1. Plug monome in to USB port

    2. Open up monoserial and leave open, then change your cable orentation and host and listen ports (even if they show your correct settings when you open monome serial,change them to something else) example; change the orentation to left or down then back to the setting you want, then change the host and listen port one click up or down then back to 8000 and 8080 (example; 8000 to 8001 then back to 8000 and 8080 to 8079 then back to 8080)

    3. Double click Monome test, DO NOT TURN OFF MONOSERIAL, and click the prefix button in the patch. (the prefix in monomeserial will change to "/test"

    4. at this point you should have only two applications open, monoserial and monome_test.maxpat

    if still not working, then report what your issues are having.

    //not trying to sound harsh, just trying to help. : )

  • @housefly
    Thanks for the suggestions.
    For the most part that is what I have been doing with the exception of changing the ports to a different value then back. Changing the ports to a different value and back does not make a difference though, same behavior as in my previous post.

    edit: Here is a youtube video of the problem. skip the part from 1:00-5:30 unless you want to watch me open and close monomeserial a whole bunch of times

  • i'm confused. it looks like it's working at the end?

  • It's working at the end, but it took me 5 minuets of opening and quitting monomeserial to get it that way.

  • try this.

    plug in the device.

    open 256serial_howto.mxb in the base patches howto folder.

    click your port on the upper left.

    push some keypads.

  • 256serial_howto registers the key presses and lights up that keys light every time I plug the monome in or start up the program. Everything seems to be working fine with that one.

  • ok, that means it's probably a monomeserial thing then.

    i'll see if i can post fixes for all of these things by tomorrow morning.

    thanks for the details, and sorry this has been so complicated!

  • Thanks for the help. I look forward to the update.

    Let me know if you need any more info from me.

  • thanks for you patience and testing. we'll get this nailed quick. on the positive side you passed the hardware test, well assembled!

  • well, this is /definitely/ a monome serial problem.

    poor max is receiving:
    /mlr/press -1341649412 -1341649352 0

    i hope to be able to post a fix tomorrow morning, but the problem seems intermittent. it doesn't really show up in the debug build (so maybe i'll just post that, but it'll have bloat and run slower than a release build), and it shows up occasionally in the release build, but sometimes it fixes itself.

    so, here's the debug build while i continue to figure this out...

    edit -- all bets are off, debug does it occasionally too.

  • Hey Guys, Ive managed to get all the keypads working and when i plug it in i get the diagonal sweep on my 128 ... the only problem im having right now is that all the leds only light up in test mode on monomeserial but not on any of the patches. Even thou all the keypads are working perfectly in all of them. Any ideas ?

  • There is an issue with monomeserial which is being worked on. You can try the 256serial_howto.mxb in the base patches howto folder to see if everything works ok as all your key presses and led's should work there. You can also open and close monomeserial repeatedly until it works well with max.

  • new build has been posted to the wiki. see the mk updates sticky or the wiki for the link.

  • I am also having similar issues with the new kit. I'm using 2 old button boards in a sidebyside/128 configuration, with the rotation as suggested in the setup tutorial. It has been failing intermittently over the past two days of testing and playing with apps. It has always worked with the 256_serial_howto patch, and the buttons have always functioned perfectly. The LED updating is the issue. For a while, only the first row of LED's would light on each board(with the rotation, it was the bottom row, 8 across, and the 9th column) Once one half worked fine, and the other half didn't except for the aforementioned column. It has also had no led response, and it has lost response while being plugged in. It seems that closing monomeserial, max, unplugging the device, plugging it in again and opening the 256_serial_howto, testing there, and then reopening monomeserial again revives it.
    The synopsis seems to be that monomeserial is the issue, I would tend to agree.
    I'm on OSX 10.6.4
    using yesterday's build of monomeserial.

  • new build posted, again.

  • I'm still having the same issue with both of the new builds.

  • ralin, was your issue ever resolved?

    just got stuff together, and am finding that i have a similar issue:

    - flashed logic board
    - used mk-set patch
    - "test mode" lights up all LEDs in monomeserial
    - test patch shows button input.
    - hardware does not light up while using test patch (or mlrV)

    any help is appreciated! thanks!


    snow leopard 10.6.4
    max 5.1.4

  • @lennox:

    do the buttons and lights work in mk-set?

    which version of monomeserial?

  • whoa thanks for getting back so quickly.

    version 0.30 of monomeserial

    button presses show on the grid in mk-set, however trying to light up LEDs using the patch does fail.

    hardware issue?

  • just to be sure:

    since there are some suspected software problems it's been difficult to target hardware problems, but before moving on to monomeserial make sure it works in mk-set.

    i'd check and reheat your solders around your max chip (on the driver) and all of the connectors.

  • oh, do you get a startup led pattern when you plug it in?

  • went over the connections quickly.
    had a second driver assembled and tried it with the same keypad.

    used the linked version of monomeserial.

    same result.

    dunno if this matters, but the grid definitely lights up in a pattern when plugging into usb right away. I'm assuming this is written into the firmware though...

  • oh, yup that would be the startup pattern that i'm getting.

  • can you try running 256serial_howto.mxb from the base patches howto folder?

    which firmware are you using?

    don't worry about monomeserial yet. it's lower level. in fact, make sure monomeserial isn't running at the same time as mk-set

  • ah! yes THAT patch is working (relief).

    The firmware used was linked on the flash tutorial page. (

    and got it, monomeserial definitely wasn't running.

  • you guys aren't going to believe this. mk-set was broken, didn't even work for me. fixed it.