serialosc, proper

  • http://docs.monome.org/doku.php?id=app:serialosc

    new installer that actually includes everything.

    run the serialosc-load.sh script or restart to get it running.

    protocol update: http://docs.monome.org/doku.php?id=tech:protocol:osc
    migration guide: http://docs.monome.org/doku.php?id=app:serialosc:migrate

    new max5 patches on the serialosc page. testing, etc.

    for old apps! there's a monomeserial bridge. monomeserial.maxpat. you can run this, and old apps *should* work fine.

    please post questions!

  • sorry to say, stretta's quickly updated serialosc patches don't include the protocol updates.

    we're quickly going to run into a organization problem with updated vs not-updated apps. i was hoping to have the new wiki structure sorted by now, but there's a bit too much going on. i'll try to get a simple area set up on the wiki for serialosc-ready apps.

  • ps. will says windows will be ready by the end of the weekend. wish him luck.

  • congrats brian and will! eagerly awaiting the windows version.

  • seems to be working fine for me except the grid in the serialosc-test doesn't change at all but the key presses are showing up below it. thank you guys. nothing is showing up in the max window that indicates an error

  • wow... looks like a great system... now I just need to sit down... play with it... and figure out how to re approach everything.

  • since i have no idea whats going on, i just install reboot and i'm good? wait for new converted apps?

  • @watson: correct. try running monomeserial.maxpat with old apps.

    if it doesn't work out, there's an uninstaller. we're still in the early-adopter phase, though all the new editions will require serialosc... a sort of forced evolution.

  • @wed: fixed the problem and re-uploaded. thanks!

  • @tehn

    what did you exactly re-upload?

  • re-uploaded the max5examples

  • I had permissions problems with that plist. I fixed them by hand, but others may have the same problem.

    The symptoms were that the script would not run, even in terminal. " Dubious ownership on file (skipping): /Library/LaunchAgents/org.monome.serialosc.plist" was the error

  • I just unplogged my monome and did not get that device unplugged error.

    O happy day!

  • @griotspeak:
    hrm. maybe i need to set the file owner to root in all of those cases...

  • Ha. Note to everyone: Put the zeroconf externals in the runtime folder. I just pulled that dummy.

    Second note though: in the serialosc-test patch there seems to be an error displaying the correct button pressed. When I press '0 0 1' and quickly switch to pressing one to the right it displays '0 0 0'. This incorrect display of values happens across several buttons when switching quickly. Not sure if it's an issue or not.

    Screenshots below: pay attention to how the grid indicates the 'on' on that pad but how the message directly below is reading out something completely different.

    EDIT: I'm also not sure if this is what tehn meant above, but Stretta's apps from the other thread don't seem to work, at least in my case.

  • @mcd thanks, will check!

  • @ tehn works perfectly now! i also re downloaded the zero config files and replaced the old ones that may have been the issue.

  • is there a message to query whether a client has focus? I ask because I need to check without actually grabbing focus unless i had it whenever my patch reloads.

  • "if it doesn't work out, there's an uninstaller. we're still in the early-adopter phase, though all the new editions will require serialosc... a sort of forced evolution. " _i just ordered a walnut 128 from the most recent batch .does the above fore mentioned mean that i cant use monomeserial to run the older apps ? this is my 1st monome,so ive been getting ready and practicing on a steep learning curve with an ohm64 and mlrV getting that to run properly was challenging to say the least .will my new 128 not be backwards compatible? if so what do you recommend i start studying so i have a head start before i have it in my hands thanx respectfully chud_

  • Just to report I'm on mac os x 10.6.6 and have had three kernal panics since installing serial osc. Though it looks as if the FTDI driver is the problem.

  • @jsph:
    bah!!! i ran into a lot of panics during development and thought i had narrowed the causes down and fixed them, but evidently this isn't the case. the FTDI driver is really shaky right after a device is plugged in, and actually registers the serial device about a second before it's ready to be opened.

    the panics you're seeing also happen with monomeserial. it has something to do with how quickly both applications open the monome device after it's plugged in. my guess is there's a race condition in the driver that's leaving some internal data structure in an inconsistent state.

    thank you for the error report, i'll be putting together a bug report for the FTDI peeps soon. this problem stretches all the way back to the 10.4 system i tested on.

    if anyone else is having kernel panics, post the error report here so that i can batch them all together and send them to FTDI. i'll spend some time narrowing down a test case.

  • @griot: yes, monitor /sys/port and compare it to the port of your app. there's an example of this in the serialosc-test.maxpat (it's built into serialosc.maxpat)

    @chud: i've written a monomeserial bridge which works for old apps. my suggest to watson was for the short-term next few days while we confirm this version works. it'll be solid by the time the new edition ships in a few days.

  • thank you, sorry for not picking that bit out

  • blinken park and nerd scroll are updated with the new protocol. others to follow, but these two can serve as examples or testing.

    polygome updated (OMG. version 1.00)

  • ran the installer, restarted, put the zeroconf mxo's in the externals folder, opened serialosc-test.

    nothing populated in the drop down and 'not connected' is displayed next to the connect button.

    so i double clicked the serialosc-load.sh, which opened in TextEdit (is that what it's supposed to do?). copied the command to clipboard, entered it in Terminal, which returned:

    "launchctl: Dubious ownership on file (skipping): /Library/LaunchAgents/org.monome.serialosc.plist
    nothing found to load"

    so... one thing that seems wrong is that there's no serialosc plist in my user/prefs folder. spotlight search found nothing on my hd when searching for "org.monome.serialosc.plist"

  • are

    /grid/led/row x_off y s[..]
    /grid/led/col x y_off s[..]

    reversed or am I going donuts?

  • I thought the number we provide for port was a 'suggestion' and could not be guaranteed so wouldn't checking against port pose an issue if two apps had the same default port?

    @kramer there is a file but search will NOT find it. it is exactly where it says in that error.

    1. go to Macintosh HD -> Library

    2. click LaunchAgents once to highlight it

    3. go to the file menu and choose 'get info'

    4. If the sharing and permissions section is not visible, click the disclosure triangle next to the words 'sharing and permissions'

    5. make sure that the lock in the bottom right is unlocked. if it is not, click on it.

    6. then click the Cog that is to the left of the lock and choose 'apply to enclosed items'

    7. done

  • @griotspeak - you're right, i was looking in the wrong place. thanks for the workflow, the only other thing i had to do was (after your step 5) add my username to the list and set privilege to read & write. clicked cog but the apply to enclosed items wasn't there, instead i clicked "Make username (Me) the Owner"

    restarted

    serialocs-test found my monome

    i'm in...

  • @tehn. We should add a table with app name and port number to the documentation wiki for developers to make sure the port isn't taken. Although there are plenty of ports from 10k-40k we might just want to make sure.

    @stretta. Thanks for posting those three working examples. I think I'm going to kill some time today and see if I convert a few.

  • @stretta:
    the commands themselves were reversed in an earlier version of libmonome. make sure you're using git HEAD of both that and serialosc right now.

    sorry about that, [[https://github.com/monome/libmonome/commit/df4f29843f6548776eb8d45adf2f4eceea0fb956|was pretty embarassing]] to find.

  • @anyone. Real fast. Almost done with a revision on a patch but I'm having an issue with displaying the serialosc.maxpat in the bpatcher. When editing the patch in Max in design time I use the horizontal and vertical scroll bars to place the patch in the view, then get rid of the sliders and save. When opening in the run time environment it doesn't display. How do I fix that?

  • Sounds like an offset issue. you could just use fixed initial window position

    I think.

  • ok will check it out.

    EDIT: Yeah. Just changed the offset. Max noob trying to help, sorry.

  • EDIT: I believed that any apps that used Jim Drakes abstractions couldn't be converted until they were updated. I was wrong. Sue me.

    Again, there is no need to update those abstractions.

  • You could edit the abstractions...

  • so we are going to go with a registry for port numbers?

  • @kramer are you using leopard or snow leopard? I am on snow leopard

  • conversion is pretty quick. if anyone has priority apps they'd like converted, i'm up for suggestions. i can churn out conversions very quickly.

    re: max is bad at checking if ports are in use. ideally your suggestion is best-- like serialosc, grab a random unused port. any suggestions for doing this in max?

    @will is the perms thing fixed on the installer?

  • @thealphanerd.

    I know I could, I opened em up and took a peek. Just not sure if it's in good taste to re-do his abstractions. I think I might though and then pray he doesn't kill me.

    Jim drake, if you are reading this now, please forgive me.

  • I think it will be fine if you just publish the changes and make it clear what you changed.

  • @griot.
    Thanks for the input. Hopefully I'll have those up by tonight but for other programming assignments so not sure.

  • hmm forgive my newbness, but with serialosc, how is one supposed to set cable-orientation of his device ? edit the config file by hand ? or it's up to the software using the monome via serialosc to do the orientation thing itself ... ? .. and what about rotary encoders ? or analog pins ? or tilt sensor ? how to enable them ? (config too ?)

    r.

  • @rud /sys/cable has been replaced with /sys/rotation x where x is 0, 90, 180, or 270 degrees -

    i know serial osc will handle tilt which uses the adc (not sure if that's working yet b/c i don't have an accelerometer on mine).

    there's no mention of the encoder in the protocol that's been released so far. i'm assuming it will get addressed eventually?

  • Other than having to change the permissions on the file referenced in the load/unload scripts setup on this was pretty easy. I tested stretta's three patches and the monomeserial.maxpat with raptor for awhile and everything worked as expected.

  • Just revised 64faders to work with serialosc. Tested and fully functional. Find it here:
    http://docs.monome.org/doku.php?id=app:64faders

    In case you didn't catch it, we don't need to revise Jim Drake's abstractions. They work fine, I'm just silly and forgot a '/'.

  • Speaking of the FTDI driver - that seems like the weak link at this point - the only bit that is not open-source - am I right? Any thoughts on recreating that driver from scratch?

  • dont know if this has anything to do with serialosc but something strange has happened.

    i installed serialosc and then ran the uninstall patch.

    now monomeserial crashes each time i open it. it seems a restart does the trick but then after awhile it crashes again and will not reopen.

    i tried reinstalling monomeserial to no avail.

    OSX 10.5.8

  • @tehn - errm... The most hopeful external i found was this: https://github.com/Sciss/PDOSCClient

    but i do not sprecken ze java

  • ok, i am still having monomeserial crash problems. it just takes awhile :-/

  • @everyone.

    I'm gonna extend the same offer that tehn gave here, if you have requests for specific apps to be converted over list it here. I figured it out and plan on changing over a bunch in the next few days.

  • @watson: that's no good. perhaps the uninstaller didn't work.

    open a terminal, run:

    rm /usr/local/bin/serialosc

    you'll be asked to enter your root password.

    if it says "file not found" then your crashes are very confusing and need investigation.