app: mlr 2.27 + aes 0.4 M4L update 21-01-10 (autofocus/autoconfig)

  • i either didn't put in, took out or hid the output audio recorder from the original mlr patch.

    because, as you mentioned you can send it to another track in live and record there which is better than the other way and it means theres less clutter in the maxforlive device..

  • excuse my stupidity, but i have been reading around all day and can't seem to find the answer... i'm not really understanding how to "configure device" i can get my monome to talk to mlr (standalone version) and i can get it to talk to other patches in live (like 7up) but i seem to be getting no interaction between the monome and devices with that configure panel on the right... like this mlr and like clip chopper... doesn't anyone know what the heck i'm doing wrong.

  • a little update... i had everything shutdown and brought it back up.... the mlr (non aes) works fine, but when i run mlr aes no communication with the monome at all.. it gets the audio and records it fine... but no monome interaction. i delete that track and bring back the non-aes mlr. it plays fine and dandy, but no LED feedback at all, i have to look at the onscreen monome feedback to see what its doing.

  • so i let my brain rest some.... read some more... and downloaded the previous version... mlr aes works now thus far.

  • I'm really loving this so far. Thanks! If u plan on doing an update, it would be awesome if the reverse buttons had a midi learn function too.

  • would be great also if this had a float window so you dont have to view the channel to check what preset is loaded - also agree with mrsilverbox with the preset changing needs to not change the current pitch of the playing loop (if possible) - by the way i do love this - its been like a year of christmas days

  • Hello everyone, this is my first post on this forum. Inb4, excuse me for my poor english.

    I don't have monome, but I got an ipad and I configured TouchOSC + TouchMonome m4l patch so now it works almost like monome. I tried several m4l apps (7up, mlr-like, LCC or something and MLR M4L port) and mlr m4l port works perfect, thanks for this, stevieraysean. MLR is what i really need but i got one problem:

    after mashing some buttons and playing for 2-3 minutes (i mean active and fast playing with fast touches and pressings) one of "rows" stops working at all. It happens when I stop rows or when I'm rewriting patterns. For example when i'm using "stop row"-button as kill-switch to make fast choppy parts.

    I checked if it's because of ipad and touchmonome - but it's not. After reloading m4l mlr - it starts to work again just fine, until it bugs again.

    Is there any way to fix this?

    I'm running Ableton 8.2.1, Max/Msp 5.1.0

    p.s. - i tried several versions, including old ones, they all work in same way for me (+aes too).

  • Are you using Stevie Ray's version or my edit of his version?

  • thealphanerd, i tried both versions - and i got same issue with your ver and Stevie Ray's too.

    Btw, I installed old MAX/MSP Runtime (4.x.x) and now I'm trying standard MLR and it works without any glitches or bugs. Just as m4l port, but without that "stucks". I'm playing for 20 mins for now and it still works great.

    Strange thing, when one of rows stucks I'm still able to play on other rows. After some time another row can stuck too.

  • did you try using my edit "without watcher"???

    there are issues with the max4live port... hopefully we can get something working in the future

  • Yeah I tried all versions. without watcher, non aes, aes, etc. + I tried your edits + older versions of your edits + older original ports etc.

    I hope it will work better in the future. Maybe it's because my MAX/MSP is 5.1.0, not 5.1.1.

  • Latest max is 5.1.7

    I highly suggest updating

  • I was wrong - I still have this issue on usual MLR (Max Runtime 4.6, not M4L port). Got it on several versions. Going to try mlrV...

    I guess it's because of M4L monome emulator.

    Thanks for info, theaplhanerd, i'll try to update.

    upd:

    Okay, so I tried 5.1.7 and I got same problem. Trying now with TouchOSC LiveControl template + LiveControl MAX/MSP Router (which provides OSC->Midi translation from Ipad) + Midi Monome + Different versions of MLR (M4L and usual MAX/MSP). Same problem.

    I don't know how Ipad+TouchOSC with wi-fi connection can interrupt work of MLR, so I guess it's MLR problem overall. Strange, that I'm the only one who got it.

    Also I noticed another thing: after a while that bugged row will start working again. It's strange too.

    Gonna try this setup now:
    ipad(touchosc + livecontrol), which sends midi to Midi Monome MAX/MSP patch and then OSC messages straight to mlrV.

    upd2:
    mlrV looks pretty stable (with different routings). So it was mlr and mlr+aes issue, I guess.

  • mlr 2.27 + aes 0.4 M4L - both works like charm here.

    so good to see my favorite app inside ableton!

    i was wondering is it possible to divide 256 verticaly to have mlr working on bottom 8 rows and to have upper 8 for starting clips and scenes... like launchpad. i think that's my dream setup. got m4live just yesterday but maybe somebody thoguth about something like this before. maybe it's possible without modyfing current patches.

  • just a wonderment out loud...

    but what is the technical differences between the 2.27 version and the AES 0.4 version please?

    They both work for me im just wondering what the differences are and what AES stands for?

    thank you

  • @onetwoonetwo
    i suppose it's called aes because aesoteric made this version. it has different top row functionality, and 6 groups/outputs.
    check http://docs.monome.org/doku.php?id=mlr:aes_edit and also try the help button in the instrument for details.

  • it appears that the record quantize is not functioning properly. there are times when i am unable to readjust the downbeat. if the record quantize lands on the second downbeat, and i want to move it to the first, i press the button again, it flashes on the first downbeat indicating it registered my press, but then quickly blinks again on the second downbeat, it's position unchanged. all of this is relative to ableton live's clock.

  • I have the same issue as away message. If I hit the the record button and the set downbeat button at the same time, and slightly ahead of the beat, it does one record pass starting at the right place, which seems to fix the problem, but you have to punch in slightly early.

  • I truthfully don't use that part of the patch.. but I can take a look at it and try to see what the issue is :D

  • +1 scubasteved


    I have the same issues (using thealpanard edit): can only record one buffer. If I record another then it just overwrites the other.

    and this is actually the only thing I want to use this version of mlr for (mashing up own recordings live in ableton alongside with using 7up) so top of my 256 for 7up and bottom for mlr.


    I have a gig this friday, and it would be SO awesome to get a deacent version of mlr inside ableton that I can use for recording my own stuff live and mashing it up... :-( Does any of your version support this, steveraysean?


    the hopeful!

  • OK it seems now that I used the "with watcher" version, that recording different buffers works (though the display doesn't update the waveform).

    So I'm quite happy now, BUT it seems that I'm running into some crashes once in a while. Especially when I've been messing about for a bit (making beats, sequences, loop-patterns and melodizer-patterns in 7up - while mashing up on the bottom-half with mlr). Suddenly the lights just start bugging up totally: leds acting weird and not responding plus just turning on all kinds of random places on the monome).. It seems the only way I've found to fix this is by restarting ableton live. I tried reinserting the 7up core-unit, but that wasn't enough.

    I also tried changing ports on mlr and 7up (7070+7000 for 7up and 6060+6000 for mlr) to avoid any possible conflicts with the common 8080+8000. Didn't help.

    Hmm... I would really sacrifice my legs for this to work. it's SUCH an awesome setup and fun to play with, but so sad that it crashes. I just have to give it a go anyway on friday, and then I'll probably tell the audience that it might suddenly stop for a second or two and then go again.

    Did anyone experience something alike ? or now anything that I could do that would help?

    for your info:
    mac osx 10.5.4
    ableton live 8.2.2
    max runtime 5.1.8
    monome 256 (2011 jan)
    pages 0.2.1a41 (for splitting up my 256 in 2 with the pages-quad app)
    mlr_2.27_aes_0.4_m4l_thealphanerd_edit_2011_01_04
    and 7up 2.0.4

    plus I'm using my Audiobox USB sound interface and a Behringer rotary for controlling various stuff.



    and btw: THANK YOU thealpanard, steverayshean and that guy who made 7up (can't find his name) - for making this possible (though not quite yet 100% stable).. this stuff has so much potential I can't believe it, and it's so ridiculous funny to play with!

    love

  • sorry for spamming this topic...

    but perhaps it would help with some sort of "panic" or "refresh" button for pages, or the monome.. it seems I can push all the buttons (and get response in ableton and the apps), but it's just the leds that go insane.. something gets overloaded in led-info somewhere in the programming perhaps. hmm. does anyone know if there's such a panic/refresh button in pages? or an app that can do this..

  • +1 for a record quantize, fix

  • WowZa..finally got this goin after givin up for a bit on mlr and the Launchpad.
    It was really straightforward actually:
    -Put MLR to MaxAudioEffects folder
    -Dragged monomeemu0.9.6a5 onto midi channel
    -dragged mlr 2.27_thealphanerd_edit with watcher onto audio channel
    -went back to monomeemu and ticked autofocus, selected size 64
    -went back to mlr and ticked connect circle on the far right
    --dumped 8 loops in dropbox and Voila..
    its recording midi patterns as well.

    Also, just sent mlr a loop from another audio channel,
    clicked Thru on mlr, clicked Resample, and go!
    its working!!!!
    I can't thank you enough for the update.
    Now me 2 launchpads can roll as 128 and chipch0p away!

  • @ himstregims @ thealphanerd

    Yes, I keep running into crash issues as well. Its been an amazing program for a while now but I must say, it crashes after like 1hr or so and you tend to lose everything.

    Im running os 10.6.7
    ableton 8.2.2
    max 1.6.8
    monome [3yrs old]
    and Maschine as a plug in

    I also run into downbeat issues....

    hmmmm

  • oh and using aes version (alphanerd edit)

  • i've found that it runs through pages but i have to open pages first.

  • Unnable to make it work :-(
    As soon as I drag the plugin over an audio track Live crashes.
    Actually it shows the GUI and crashes one second latter.

    Here's the report:


    Thread 3 Crashed:
    0 libSystem.B.dylib 0xffff0820 __memcpy + 128
    1 com.cycling74.MaxAPI 0x234006fd sysmem_copyptr + 61
    2 com.cycling74.adoutput~ 0x2c0cf530 adoutput_perform64 + 89
    3 com.cycling74.MaxAudioAPI 0x234a50d3 dspchain_tick + 323
    4 com.cycling74.MaxAudioAPI 0x234ae1da plugrunner_tick + 96
    5 com.cycling74.MaxAudioAPI 0x234ae57d plugrunner_process + 157
    6 com.cycling74.patcher 0x22b113c2 Wires::Process(plug_DeviceRef*, int, int*, int*, float**, float**, __t_epii_REChunk*, __t_epii_REChunk*, __t_epii_MEChunk*, __t_epii_MEChunk**, __t_epii_REChunk**) + 1359
    7 com.ableton.live 0x000af716 0x1000 + 714518
    8 com.ableton.live 0x0004a34e 0x1000 + 299854
    9 com.ableton.live 0x0004a34e 0x1000 + 299854
    10 com.ableton.live 0x00072612 0x1000 + 464402
    11 com.ableton.live 0x00072969 0x1000 + 465257
    12 com.ableton.live 0x000633c8 0x1000 + 402376
    13 com.ableton.live 0x00043f91 0x1000 + 274321
    14 com.ableton.live 0x00043e7d 0x1000 + 274045
    15 com.ableton.live 0x003a0c7b 0x1000 + 3800187
    16 libSystem.B.dylib 0x97f85259 _pthread_start + 345
    17 libSystem.B.dylib 0x97f850de thread_start + 34


    Anyone has a clue?

    using live 8.2.6 and MAX 6.0.1 on OS 10.6.8

    Thanks

  • I would guess that it would be from using max6

    max4live is not yet stable with max6 and you really should not be using it

  • Still trying to figure out crashing issues. its so random too. Some days it works amazing and never crashes other days, like today, it crashes everytime you stop ableton

    tried it with 8.2.5 and now 8.2.7 runtime 5.1.8 and tried 5.1.9

    question, you still need to run monomeserial yes?

    please any assistance would be grand.......

  • I've been playing with the latest version of this for the past day and it works fine except one major problem - and maybe you have a workaround. I keep seeing "inlet: list: wrong message..." in my max error window. That's fine, but the window jumps to the front and takes over. I can't get back to Live unless I click like mad on it. Any way to hide this message, or better yet, stop this message?

    Using the MLR AES edit for the quantize of the input buffers.

  • The other problem I just noticed is that my patterns are lost after I stop Live.

  • I can't seem to use the Aes 0.4 2011_01_04 edition.


    It keeps crashing Live without any other effects or anything else in the set.
    And if I try to open it to debug, Max also crashes pretty quickly.

    I didn't have this problem 6 months ago when I used it. Perhaps there's a conflict with the newest version of Live or Max 6 ?

  • same here...keep crushing alla the time, what is wrong?

  • i have started using the mm4lr which seems more stable ,but lacks of input quantize,

    which version of mlr for live do you think is more stable?

  • How does one use multiple monomes with this and what should we expect in terms of functionality? Is it like mlr 2.51?

    Thanks

  • Okay. Baffled.

    Got this working. Using aes version with the outputs set up across six different tracks. All routing fine. The different tracks are being sent to the right channels, but when I try and record the six outputs.... nothing.

    I've tried putting an audio effect after and you can hear that the mlr output is being routed through that, so that proves... something. Not sure what!

    But when I arm and record, nothing. I've tried selecting 'Audio From' as both 'Max' and 'External In' - same result. Both perfectly audible but not being recorded by Live. Also tried different monitoring, again no change.

    Only way I've found is to add another track which gets its audio input from the mlr track. But surely that's not how it's supposed to work? Probably some basic setting I'm getting wrong but I'm stumped. :/

  • i take it your wanting to record audio to clips?

    essentially the audio for these tracks is being generated at the effects signal chain, not at your audio-interface input.

    think of them as audio tracks with clips in them already.

    so routing the audio to another track for recording is probably the only way to do it..

  • Thanks for the reply. As long as it's not something obvious I'm doing wrong!

  • Just downloaded this, every time I open it Live crashes straight away, never has this problem before..

    Might have already been mentioned in this tread but I cant find it.

    I'm on OSX 10.5.8 using ableton live 8 with a monome 128

    Anyone else had this problem?

    x

  • Maybe its the version of live... 8.?.?

    I'm not on mac for now but should change anything...

  • Has the aes edit of mlr ever been ported to serialosc as a standalone? cheers

  • ^^ would looove to see that! ^^^

  • Shouldn't the reverse mode be activated by keeping pressed one pad & press one before that?

    How can you activate reverse from monome?

  • @ restlessboy etc ... i converted the aes edit of mlr for m4l (serialosc). you can download it here :

    http://post.monome.org/comments.php?DiscussionID=14824&page=1#Item_19

    didn't fully test but seems to be working ok over here ... if there are any problems let me know ...

  • now i'm confused.

    i use a m4l mlr version which also is an aes/alphanerd edit, with 6 groups route-able to 6 different live tracks.

    what version is that?
    and where's the difference to your mod?

  • oh, that new one is for serial-osc.
    got it.

  • I've been looking for the serialosc version of this all over!!... this should go into the wiki... I'm about to give it a shot now so we'll see how that goes...

  • nice on ithkaa!

    a few things:
    - I can't get to edit the length of the bottom row since it's almost out of the presentation area.
    - the record-sync button isn't working probably (but I don't think it was in the previous version either, so..)
    - I can't seem to get the multi-out function working. Have you tried this?
    - did you freeze it? I can't seem to unlock it to fix these things myself. Perhaps I just oversaw something.