mk firmware / serialosc

  • > avrdude: can't open input file mk.hex: No such file or directory

    it's not finding the file.

    are you running avrdude when in the same folder as the .hex file you're using?

    for example, copy the 64.hex to your desktop.

    then in the terminal:

    cd ~/Desktop

    then run avrdude

    also try running this patch and tell me if the box is grey or white

  • OK, from your input I was able to successfully load firmware, and apps respond now.

    I'm having to press harder than with monomeserial to receive LED and button feedback, and when I ran zeroconf-test I received a white box

    I also just unplugged the monome and was abducted by a kernel panic :0
    ...time to scour that forum topic....

  • Same thing here as at robotjones' - since i reset the serial to m000000 and flashed the firmware, i have to push some of the buttons (about one quadrant) harder - or even wiggle them while pressed - to get a response... since it's a mk, i suspected i somehow got dirt under the button pads but i can't imagine how this could have happened. How could a new firmware cause lower sensitivity?

  • the new firmware may have excessive debouncing? i'll have to make sure the firmware is optimized. in the meantime you may want to switch back to the old firmware. it's definitely not a dirt thing, as i doubt there was a chance for dirt to get in there.

  • tehn thanks for all of your help

    Which old firmware should we revert to? if it's serialosc 0.8 how can I find installer? it's not on serial osc page ( or on github

  • serialosc is the server/router. you can use monomeserial with the old firmware:

    use "debug"

    all good in the hood. obrigado, tehn

  • I'm sorry but I think this isn't fair for MK users.

    I can't get monomeserial to play nicely with my MK, because it apparently keeps resetting my mk grid count, which i'm supposed to fix using mk-set, of which repeated use does not fix my issue.

    Although, before taking a couple months away from monome (using monomeserial), I would have this same issue occasionally and using mk-set WOULD fix it.

    These threads seem to outline a similar issue, although I am not sure if they are related.

    The fix is apparently to reflash, again, and use serialosc (backwards-compatibility with older monomeserial-needing apps makes it easier). Only this thread seems to discourage me from doing just that, at least for now...

    But I am still stuck with a MK that does not apparently send button pressing data to the patches I'm trying to use (Soyuz, and Polygome for specificity). And, when running the mk-set patch, it seems that functionality is normal, and I believe I can rule out a hardware issue.

    Is there anything I'm missing? Is there a way for me to use my MK now using monomeserial, or do I have to wait for serialosc optimization? and how long?

    - serial: m128-000
    - freshest FTDI driver installed (VCA) (osx 10.6)
    - monomeserial 0.3 (with MK support)
    - 'debug' firmware used
    - mk-set used to reset grids (without monomeserial per instructions) to no avail.

  • i'm sorry you're having trouble and thanks for posting-- it's important for people to voice their trouble so i can prioritize.

    migration to serialosc is going to be inevitable over the coming months. once the arcs are shipped out i'll be shifting onto improving the user experience and docs tremendously.

    i should be able to make a quick modification on the mk-serialosc firmware tonight, to correct the button lag.

    thanks for your patience.

  • whoa 10pm on a sunday.

    i checked my mk with the serialosc firmware and everything seems to be working fine.

    is there a chance you guys were running monomeserial at the same time as serialosc?

  • ok,

    I did finally manage to get serialosc working with MK and everything is working as expected.

    There were a few hiccups, i.e. I had trouble getting led feedback from any patch after the flash and installing serialosc... but after a couple restarts and re-plugging of device, that issue appears to have vanished.

    I am not experiencing any latency with buttons or responsiveness at all, either, which was ultimately discouraging me from the upgrade... but it shouldn't have.

    BTW serialosc is totally sweet, I get it now. Way easier workflow. Cheers!

  • horray!

  • @tehn

    Can I migrate to serialosc regardless of what keypads I am using ( the livid keypads) if I am using debug firmware currently?

  • correct

  • @tehn: I think I'll post a feature wishlist for the future serialosc MK firmware:
    -good button response (same as before)
    -LED level implementation (individual)
    -AUX port communication - that's actually one of the main reasons i bought the kit for, the idea of being able to use it as my sensor interface as well.

  • all of these features are planned.

    is your button response actually not as good? i tested mine here, and i believe it's actually more consistent.

  • Been putting off my upgrade to serialosc also. Am I right in thinking that the mk firmware update will break all communication with monomeserial and if I need to go back I will have to reflash with the old debug firmware.

    Does anyone have issues with dropped quadrants on serialosc, these are my main issues with my mk256 on monomeserial. If these were gone I would update straight away.

    My issue is that lights on a particular quadrant will stop working, go dim or all light up. Button presses are never affected.

    I've noticed it tends to happen a lot more using mlrv2 than it does using older apps such as mlr 2.51++ where I could get away with it for days. .

    I usually run 2.51++ in 4.6 runtime however and mlrv2 in the latest runtime.

  • this would be either a monomeserial or firmware issue, so i'd suggest trying the new firmware and serialosc. though you may want to wait until there is a native serialosc mlrV.

  • @Beatpoet

    I was having the same problem with my MK128. I would usually get a grid blackout, sometimes a dimming and sometimes all light up.

    I recently made the move to Serialosc and the new mk firmware and the frequency of the occurrence is substantially less.

    With Monomeserial and old firmware, it used to happen, almost every time, about 20 minutes into using the monome.

    Since Serialosc/new firmware migration, it has happened once, and only once, in probably the 8 multi-sessioned hours I have used it.

    Edit: Better language

  • for everybody on the fence:
    i caught the dimness issue while doing some of the final testing for serialosc 1.0. the firmware that tehn posted earlier in the thread fixes the dimness problem for me 100%, i can no longer reproduce it.

  • Thanks for the info everyone, looks like it's time to get off the fence :)

    Must have a read the serialosc documentation properly. Will probably do the changeover this weekend, I'll let you know if I find anything.

  • hey everyone

    just made the jump today to serialosc, and while I haven't gotten the monomeserial patch to play with mlrv2 yet, at least the LEDs are lighting properly in the test patches.

    However, I'm also having the button response issues people have been mentioning. Sometimes button presses won't register at all, sometimes they register but with noticeable lag, it's really a big step down from before using monomeserial.

    Anyway, just wanted to get that out there. Hope there'll be a fix soon :) I'm using the 110224 firmware from this post and monomeserial 1.0b.

  • hey kumakae, try this:

    let me know if it fixes anything up for you

  • hey thanks! now the button presses either register immediately, or they don't at all, so at least the lag is gone :) Somehow it seems that if I press harder than what i'm used to from before, I can get consistent response. Is that even possible? Maybe there's some sort of threshold value for something that has changed in the newest firmware?

  • there could definitely be some changes, but i can't say offhand. tehn, thoughts?

  • i'm not sure how the the detection threshold could've changed. is everything assembled and properly aligned? do you have a plate?

  • i dont understand something.
    My mk kit works fine under serialosc.
    But I never updated the firmware.

    I just installed the serial package.
    And when I try to reflash it i get command not found error.

    anyone with same probs?

  • what's the actual error?

  • when i type make boot i get

    -bash: run: command not found

    But serialosc recognizes my mk as mk-0000112.

  • it seems you're typing "run"

    what command are you typing?

  • cloudhoppers-macbook:Desktop cengzarslanpay$ cd ~/Desktop/mkk
    cloudhoppers-macbook:mkk cengzarslanpay$ make boot
    -bash: make: command not found

    Also the makefile and hex file doesnt have any icon.

    129 x 193 - 14K
  • Hi tehn just tried it on a snow leaopard system.
    And it worked.

    the make boot command is not responding on leopard I think.

    thanks for help (:

  • @tehn:

    no, I don't have a plate yet :) this is actually a very good reason to finally get my monome in a case. but i've been playing with it as it is for a while now, trying out different apps, and subjectively, the new firmware feels really different. i didn't used to have to mash the buttons so hard to get a response.

    but anyway, i've collected a few offers from local manufacturers for a top plate and i'll probably order one soon. once i get it, with the additional leverage offered, the response shouldn't be a problem anymore :) and as long as i can use my monome to make music, i'm very happy.

  • @woofy it doesn't seem like you installed macpack (see firmware flash instructions)

  • for some strange reason my 64 doesn´t connect to serialosc anymore :(
    when i connect via usb it lights up and i can see it in the dropdown, but when i press connect nothing happens.

    my 128 works fine tho, everything as expected...
    does this mean my poor 64 has a problem? :/

  • i worked it out. i had two .conf-files for my 64 lying around in the library preference folder located at


    deleted one of them, now everything is working again :D

  • @tehn:
    any updates on when we can expect a serialosc firmware for mk that has the full list of features you mentioned earlier?

  • it's on the list of priorities for this month.

  • Just to add some details.

    I renamed my original m256-079 serial to m0000079 (using piraterename).

    I then ran the "make boot" after changing the makefile to match my serial, and got the following output:

    avrdude -p m325 -b 115200 -P /dev/tty.usbserial-m0000079 -c arduino -e -D -U flash:w:mk.hex:i
    avrdude: stk500_recv(): programmer is not responding

    avrdude done. Thank you.

    make: *** [boot] Error 1

    I can still connect to my device with serialosc, but it shows up as "monome 12c" in the test patches like osc_test.maxpat, and none of the messages seem to do anything.

    If I unplug the usb the unit still starts its regular idle mode "game of life" thingy.

  • you need to rename your serial back to m256-079

    make boot didn't do anything as there isn't a bootloader on these early editions. it should be fine once you rename it.

  • Great. Everything's back to normal.

    I just really liked the idea of led levels. Looks like I'll have to start saving then...

    A bit off topic maybe but is there an overview of what has changed since the early units? Have they been improved in other ways besides the addition of led levels?

  • Hey Everyone,

    Question Ive been trying to figure out,

    I've got the 2010 September MK... I finally got SerialOSC up and running perfectly.
    Now, I saw that on the protocol page, the Tilt message isnt up and running yet. I could be wrong, but Ive been itching to use my Accelerometer with this kit.

    I may still have to rename my device?

    any help would be lovely :)

  • do you have the accel installed?

    thanks for the reminder, i'll check it out.

  • Yes sir I do!

  • how did you wire it up? there's no tutorial, so just curious what you did.

  • I followed this.
    Soldered to the Analogs

    " solder gnd to gnd, 5v to 5v, AY and AX to two analog-in
    pads on the logic board."

    Seemed simple enough, was I completely off base?

  • you're using an MK or an old 40h kit? did it look exactly like the photos?

  • Im using an MK from the 2010 September editions. It looked pretty spot on to the pictures, I found all the information that was on the tutorial was also on the board and the accelerometer.

  • just making sure. the pin layout for the mk is substantially different, but i'm sure if you followed the first tutorial it'll be relevant. that said, you'll need to flash the firmware-- and i haven't publicly posted the analog firmware yet as i deserves some minor refinement. i'll get back on that.

  • the tilt and enc firmwares are done, on github. waiting on new serialosc installers for mk tilt support.

    enc works presently.

    working on tutorials for aux setup.