grainstorm

  • @interstitial

    works perfectly. now i'm more blown away by the grainstorm. wow!

    thanks! ^^

  • @interstitial
    thanks for your patch. now i can control the other parameters with my arc2, tho i don´t have any visual feedback for knob 3+4. the leds keep showing the parameters of knob 1+2.

  • @flur - which version of the original grainstorm have you got? should be 0.16.

  • hmmm, i do have 0.16. strange...

  • @ flur

    that's probably true. for some reason i thought the led feedback on the grid and arc wasn't fully implemented in this (stretta's) early version of this app so I didn't mess with it. for example, knob 1 reflects what's going on in the patch but knob 2's led spin around - quite beautifully - but I am not sure what that's supposed to reflect (that knob should be pitch). also the grid buttons aren't cleared on launch so if there were buttons lit up from previous use, they stay on. don't know if i am being obtuse, my setup is odd or what it is. just wanted to explore the application a bit and start the process of figuring out what i can do with the arc.

    in any case, my edit is just a quick hack to enable me (and others) to get a better sense of the app and what it can do. the original is a very early version (0.16) so i imagine stretta will probably come back to it and revisit it. in any case, it's a great introduction to what you can do with the arc, how you program for it etc.

    i don't know how much time i'll have this weekend, but i may poke around and see what's going on.

    on a side note, i am finding that i don't use the visual feedback on the arc as much as i thought i would - partially because my hand covers the leds when i move the knobs. of course, i just got the arc and so am still working through it all.

  • @ flur

    ok, just looked to see what needs doing. pretty straightforward but probably can't get to it today.

  • had a chance to play properly now - this is truly amazing

  • Indeed, this is an amazing patch. Causing me to rethink everything. Would love to see this implemented: http://post.monome.org/comments.php?DiscussionID=11646&page=1#Item_2

  • i m trying now arc 2


    in grainstorm pacth


    i don t see speaker icon

    why ?

  • there's no speaker icon anymore. instead you'll have to click the "dsp off" to "dsp on" on the top right corner.

  • thank for answer

    i've seen this

    http://post.monome.org/?PostBackAction=Download&AttachmentID=4494
    -------------------------
    now i turn on dsp ...but I have no sound

    I use monome 2011 that working ...I've change only oscserial to new version

    i did this but i can t start Grainstorm


    max5 .18

    MBP corei5

    some help where is my error ?

    excuse for my question

    thank

    Bob

  • @desnos

    Do you see any output meter activity?
    If not, have you enabled a voice?
    Have you raised the volume of a voice?

  • I like grainstorm a lot, really mindblowing app!

    Also regret not having an arc4 but an arc2 now :) Would be great if the arc2 could act as more banks...

  • probably a stupid question but can anyone explain how adsr works a bit more?

    I enabled voice 1 and sustained noise comes out by default, then toggle adsr with the monome, but no sound comes out; the documentation says it plays only when a keypad is pressed but I'm not sure what it means by that from looking at the button reference file...

    thanks

  • @Stretta

    no i don't see any meter activity in out put to speakers

    only meter activity of internal internal mic

    that i stoped

    what is wrong ?

  • @GetTheLEDOut

    ADSR is how you form a sound.

    A = attack. sound will "fade in" when attack > 0
    R = release. sound will have a "tail" after you release the button when release > 0

    in sustain mode, you press a snapshot and the sound will remain until you press the next snapshot.

    in ADSR mode, the sound only remain when you're pressing a snapshot. like a piano key.


    @desnos

    have you enable any voice? by pressing the 2nd button of row1~4? you should be hearing sounds when any of the 2nd buttons of row1~4 is pressed and lit.

  • i'm encountering a strange problem, not sure if it's a bug or a deliberate design choice...

    i don't have an arc, so i've been using a 64 to trigger presets, record audio and so on, and using my mouse to move sliders. the first time i opened up grainstorm, it worked a charm (it really is a great app, so much fun to use).

    however, every subsequent time i've used the patch, i can't save any new presets at all. i can re-save any of the "factory default" presets into any other preset slot, but if i try to save and then trigger a new preset, it just reverts to whichever "factory default" previously occupied that slot.

    i assume that maybe the patch only saves values if they are changed by an arc, and ignores any modifications made using the mouse, but it was *definitely* working the first time i used it. and it would also seem slightly un-monome-like to have deliberately set things up not to work with a mouse.

    i've tried reinstalling serialosc, and grainstorm, to no avail. button presses are all showing up as expected in the serialosc test app, and anyway saving works fine for pre-existing presets, just not new ones.

    any suggestions as to what i might be doing wrong, or whether this is an innate function of the patch?

  • Hey all,

    Everything working like a dream for me except the encoder controlling pitch. The reset to 0 works, and I can see the digits twitching on screen like they want to change, but it's not happening.

    Thanks again Stretta!

  • @aryschien

    @Stretta


    ok now works

    thank !!!!!




    thank for help

  • @tenmen
    what version of grainstorm are you using?

  • @stretta
    0.42

  • @stretta




    i like to understand something more in Max 5 / monome development

    can be useful this book

    Music and Sound Design - Theory and Practice with Max/MSP ?

    and where do i found doc for max and monome ?

  • @stretta

    Hey, apologies just spotted my earlier typo - i'm on v0.16

    (also, i just tried this on my laptop also, and ended up with the same issue)

  • @desnos
    The tutorials included with Max are excellent.
    Beyond that, I don't have any experience.

    @tenmen
    Does your arc works fine with other applications?
    Can you change the pitch with your mouse?

  • @stretta

    yes, all seems fine with edw etc. I can change pitch with the mouse, but it snaps back almost immediately if i have previously pushed in the 2nd encoder and reset to default - otherwise i can change pitch without an issue with the mouse.

  • @tenmen
    It sounds like there is some arc automation present. Try clearing the sequencer. (use the sequencer 'clear' menu option)

  • @stretta
    I've tried that and had no luck.

    I just took a closer look and i can change the pitch completely normally with the mouse, but when i change the pitch, the digit representing it on the screen does not alter. I can reset to 0 with the encoder, which does change the digit, but that is all.

  • @tenmen
    The numbers won't change when you move the sliders with the mouse, grainstorm is intended to be driven by the arc. This is normal.

    When you move the pitch encoder, is the LED ring responding to the movement?

  • i have begun to wrap my head around this app a bit more and am loving it. thanks for all of the work you put in and sharing Stretta! wonderful wonderful wonderful!

  • @stretta

    Looks like my grainstorm issue, was actually a malfunctioning encoder issue, sorry for the confusion!

  • hello,

    @ stretta : thank you for sharing this app. i enjoy a lot playing with it.
    @ interstitial : thank you for your edit, allowing me to fully play with this app.

    i would like to report that i can't use the overdub feature. when i press the dedicated button, it enables 'record' to the track on focus, and it just wipe out the sample. incoming audio cannot be recorded.

    i would really like to be able to play with this function. my skills with max are very poor, that's why i need help to figure out why it doesn't work and how to fix this.

  • anyone about this overdub function ?

  • overdub is for the sequencer, not for audio.

  • indeed. that's why i'm surprised that this button enables 'record'.
    i'm asking for help to make it behave as you intend to. besides, i might learn something.

  • oops sorry. I'll look into it.

  • .161 update available

  • it works perfectly. thank you !

  • here is the update of interstitial's edit, in order to use with .161

  • .17b1 uploaded

    I moved a bunch of things into the voice bpatcher to clean things up, but I may have embrokenated things in the process. So, it would be great if you could test this.

    A couple new features.

    One: a VST FX host with sends from each voice.

    Two: continuous sampling so you can use grainstorm on a live input.

  • hello,

    .17b1 is working fine.

    as i saw the channels menu : do you plan to affect one plug-in per voice ?

    playing with the continuous feature is interesting, and gives surprising results. i think i'm gonna use it to pipe audio from one or more voices to another one. very nice feature. thank you.
    i've noticed that i can record (or get audio streaming) by selecting channels 1-2 only in the 'audio recording' field. i can't get audio in with other channels. (with both .17b1 and .161).

    my set up : max rt, ableton live, soundflower 16, 64, arc 2. rec from max to multi tracks in live. streaming audio from live to max.

  • is anyone else having a problem with the filter/volume setting not being saved per voice in grainstorm 161? when i set a grain location on the sample timeline and assign it to a button, the filter/volume setting isn't being saved with it. quite annoying.

    win 7
    M-serial rc2
    max 5.1.6

    or am i missing something?

  • hmm. maybe a bug when using an arc 2? i deleted the receivers for the volumes and filters. seems to be fine now.

  • @oootini - the snapshots record the status of the arc knobs. since filter/volumn are controlled by knob 3 & 4, which do not exist in arc2, we arc2 users cannot store those settings with snapshots.

    if you want to do that, you'll have to use a modified patch showed up earlier in this thread, the one modified from v1.60, not 1.61.


    @beo - there is a problem with the grainstorm_arc4to2_edit0161 patch: i cannot connect my arc2 with the application. the original 1.61 works fine.


    @stretta - the VST FX send & continuous sampling features are amazing! thanks for the update.

  • yeah figured as much. i pretty much leave the vol/filter as is per voice so it doesn't bother me really.

  • anyhoo. what a greaat app!

    http://soundcloud.com/oootini/short-grains-of-reverie

  • @aryschien : did you put both 'arc-handler-xbpb.maxpat' and 'grainstorm_arc4to2_edit0161' in the .161 folder ?

  • @beo - thanks, it works now. i did forget about the arc-handler-xbpb.maxpat file....

    can you show me which section of text (code) i should copy and paste into the original patch? i love the new features in 1.7b1 but also can't live without knob 3 & 4. if the modification can be done by copy and paste, then i'll be able to do it myself. thanks. ^^

  • @ aryschien : hello !

    open interstitial's edit
    go to 'arc switcher' panel
    select all elements-copy

    open .17b1. save as '...'
    paste
    make connection
    in the connected panel, go to 'arc-handler-x n' objects
    change names to 'arc-handler-xBPB n' (in order to communicate with the 'arc-handler-xBPB' patch)

    switch to presentation view
    zoom out
    move '1-2' '3-4' tabs where you want
    zoom in

    lock. save. close. you're done !

  • @beo - does it mean that i need the full max to do this, not just a text editor?

  • ok i couldn't do it with a text editor, so i just downloaded the demo version of max (full) and modified the patch for arc2.

    there are still a few things i can't figure out, but at least now i can fully enjoy the grainstorm 17b1 with my arc2. really, really love the vst send and continuous recording features!


    @ stretta

    i'm sharing the patch here in case other arc2 users need this mode like myself. if, in any cases, you feel this is not appropriate, please let me know and i'll remove the attachments asap. always respect your work and don't want to be offensive in any way. ^^


    (i don't know why i can't upload the rar file, so i add "doc" to the extension filename. please rename it back to rar after download.)