mlrv 2.2 [new version]

  • It's been answered earlier in this thread: in that first video, "too many," he was using an unreleased version of mlrv2 that had native support for the MPD18. However, 'goose said that code wasn't ready for general distribution, so it's gonna show up in a later version. In the meantime, yeah, it's Ableton for beats and effects with the MPD18, plus mlrv2 for the monome.

  • Can someone tell me why my presets aren't saving or loading properly? Windows 7, launchpad.

  • @mrkymrck,

    I tried that but to no avail. I still get no response in mlrv when I hit any buttons on my apc20.

  • @drfronz....i read somewhere that the help file is unnecessary if u are using the runtime, i think its used to help w/ editing, which is only available on the full version max.
    i think your problem may be elsewhere.

    @mrkymrck...have u checked out the slice feature? that would allow u to play each slice individually and record w/ the pattern recorders, basically gettin u there w/o having to use ableton. its in the drop down menu where it says "loop" i believe..? in the menu bar above every sample slot.


    anyone know the answer to this:

    is there a way to setup a button mapping to toggle a fresh set of buttons to map on the top row?

    similar to old mlr, where buttons 7,8 toggle to pattern recorders and live looping.

    thanks!

  • @ringo wingo,

    I'm thinking the problem may be the apc20 itself....I really have no idea though. I've just been fiddling around with mlrv and I've found that the only problem I have is no controller response. I can load samples in, I can record audio into a row.....just when I hit a button it's as if no signal is being sent.

    Maybe this might say something I can't

    -------------------------------
    xsample objects, version 0.3.2pre
    xrecord~, xplay~, xgroove~
    (C)2001-2008 Thomas Grill
    -------------------------------
    binding to port 7000
    MXJ System CLASSPATH:
    /Applications/Max5 Runtime/Cycling '74/java/lib/jitter.jar
    /Applications/Max5 Runtime/Cycling '74/java/lib/jode-1.1.2-pre-embedded.jar
    /Applications/Max5 Runtime/Cycling '74/java/lib/max.jar
    MXJClassloader CLASSPATH:
    /Applications/Max5 Runtime/Cycling '74/java/classes/
    Jitter 1.7.0 installed
    Jitter Java support installed
    binding to port 8000
    binding to port 7000
    udpsend: bad arguments for message "host"

    When I load mlrv this comes up in the max window.
    That last line is probably telling me what's wrong I just don't know what it could pertain to or how to fix it.

  • WOW. I just revisited this with the 2.2 update and it is actually playable on my PPC... even with rewire enabled, tho a little boggy, yet enough CPU for recording into ableton and semi-quickly rendering and importing to mlr for trying out ideas.

    Big ups!!

  • @DrFronz:
    i'd try to select / re-select the APC20 from the drop-down list. also try it with the APC40 setup. make sure that the APC20 comes up in the MIDI lists immediately below the device selection dropdown (you should select the first Port if you have multiples). we've only been able to test an APC40 as we don't know anyone with a 20, so theoretically the signals could be different but i wouldn't expect it.

    also, make sure you don't have ableton open, and you've rebooted the APC after having used ableton before you load Max as mlrv needs to send an initialise message to the APC (when you select it under the device menu).

  • @galapagoose,

    ....SUCCESS!

    I selected APC40 as the device in the "control" menu with APC20 selected for the device input and output and the APC20 autoselected as always in the MIDI section.

    Thank you so much for your help man and thanks to everyone else who gave me some help!

    Now, before I even try I'm going to ask, if I want to rewire mlrv to ableton using my APC should set up ableton then mlrv THEN plug in the APC? Or is rewiring mlrv to ableton while using a controller specifically for ableton to control mlrv just a silly idea riddled with frustrations and confused device signals?

    and again thank you.

  • hrmmm.. usually it doesn't matter which app you open first but just in case i'd say boot ableton before you attach the APC. also make sure you've turned off the APC20 in your "control surface" menu in ableton before you attach the APC. then just boot mlrv as normal and you should be fine.

  • anyone got live input workin while in rewire with ableton?
    it works fine in standalone,but n o way to select an input in rewire mode
    any suggestions please?

  • hey!! I'm asking already but have no answer from galapagoose, % or anyone.

    is there a way to succesfully map the top row with stop group 5 on mlrv 2.2??

    it works but the lights don't match, remain the same as the stock configuration.

    help?

  • Found a way around the recording issue by routing my audio through soundflower. Not 100% consistent just yet, but worked enough to finish two new tracks!

    New problem as of today, however; I'm not getting LED feedback. I'm on 10.5.8 with the newest version freshly reinstalled and a 128. I believe the problem is with monome serial at this point, going to try to reinstall that mess once again but thought I'd check with the community for any possible solutions in the mean time. I feel like I've read about a similar problem before but can't find said thread/comment. Help would be greatly appreciated, mlrV is not only a major part or my work flow, but the only software at this point!

  • Is the next release of mlrv likely to contain native serialosc support?

  • No offense but I hope not cause there's no dice for PPC users with serialosc. Its my own fault for using such an outdated machine.

    @darb
    are you using this method to solve timing issues with using the inputs? or are you doing this so live is the rewire master but you still wish to use mlr inputs?

  • @baubie: You can't use a Launchpad with serialosc either, which suggests that mlrv would have to support both serialosc and monomeserial.

    However, without some kind of serialosc support, how can you use an arc with mlrv?

  • oooh right..haven't thought of that one. I dunno about programming so i'm wondering if it problematic for the same patch to support both.

  • I don't see why it should be problematic. Monomeserial and serialosc both speak OSC protocol; they just use different ports and command strings. So it's just a matter of being sure that the application listens on the right port(s).

  • +1 for serialosc.
    Haven't used mlrv since I got an arc, but would certainly like to!
    More + more apps are coming with both versions.

  • @baubie

    I'm using soundflower simply so I can record the master out. Rewire hasn't worked for me for whatever reason. Max/MSP doesn't show up in ableton as it should. Any tips that I haven't considered would be greatly appreciated on that issue; however, a more pressing issue is now at hand for me:

    As I mentioned in my previous post I'm not receiving LED feedback on any of my monomes. I have two 40h's and a 128 all of which I've tested with multiple patches.
    I reinstalled max 5.1.8 runtime and monomeserial. I also tried an older version of both, max/MSP 5.1.3 and the monomeserial that had adc & encoder options at the bottom of the window (not sure the version.)
    Other than that software I can't think of what the problem may be. I have tried to install serialosc but had no luck with getting it to recognize my device. I also installed the full version of max/MSP around the time everything went haywire.

    As far as the serialosc implementation there is a patch for serialosc users to use monomeserial applications. No need to convert to the new protocol until other bugs are worked out, such as finding how to remain compatable with ppc & nonmonome devices such as launchpad or MPD's. And although I'm not sure about this it seems plausible that one could use the osc routing to incorporate an arc in mlrV.

  • @ darb
    you already mentioned you tried an older version of Max and monoserial, but what about an older version of mlr?

    Because by "newest problem as of today...with the newest version freshly installed.." leads me to believe you didn't have this particular problem until switching from 2.1 to 2.2

  • I should have been more specific in my post, but that's not the issue as far as I can tell. mlrV 2.2 has been the first useable version for me. Others have worked, but for various reasons not to the point I was able to record or compose a track in it's entirety. I had luck with v 2.2 soon after I first updated it, and the only (major) changes I've made to my computer were the installations of Native Instruments soft-synths, the full version on max/MSP, and the newer version of monomeserial & serialosc (which I installed after the problem had already began.)

    Furthermore, patches that worked in the past (such as polygom

  • this is mad random, but i saw in the video some MPDs mapped to mlrv. i dont have a monome or launchpad (yet) but i do have a midifighter [http://www.youtube.com/watch?v=uiG_zQtlL0U]. its basically an mpd - the knobs and faders, and instead of pads the buttons are arcade buttons. i was wondering if there is any way i could map it to use with mlrv? ive tried to midi map it but it doesnt work for playing samples and im am not aware if thats even possible...

  • @botaz
    i think MPD support will be added in future. they did have it in the version used in the video, but then took it out of the public release cause it was too unstable.

    please correct me if i am wrong

  • This software looks just astounding.. I hate to be another one looking for setup advice.. Have latest runtime installed, using windows and launchpad.
    I can get mlr running, and it seems to be talking to the launchpad.

    However I have the bug were you cant drop files into the program. Max says it can't parse the mp3 file.

    Any ideas?

  • Derp. Already fixed. Some of the suggestions in this forum are really good. Made sure DAC button was black, and created a folder called 'MLR' for program in root directory to keep things simple. I am still getting one small error in the max window, but so far MLR and Launchpad seem happy.

  • ***if any of the dev's or anyone who is well versed in the workings of mlrv 2 are reading this:

    i am working on creating an mlrv 2 soviet life sequencer (tetris) patch such that mlrv and tetris are interacting with eachother.

    i'm having a really difficult time locating certain sets of data in the patch. i'm looking for information regarding button presses and row movement. i want to have the fall rate/settle rate of tetromino's synced to mlrv / max's transport. to do this i need to figure out how to patch max so that tetromino's are not falling when there is audio playing in mlrv row's, and when there is movement, they fall at a fixed quantized rate synced to max's transport.

    also looking for button press information in the mlrv 2 patch so that presses can trigger event changes in tetris such as rotations, block changes, color changes, etc.

    need some direction here... this patch is rough to dissect.

  • Dear all, I've tried to run mlrV (2.219) but it just shows the benefactors screen and that's it.
    I'm using max runtime 5.1.8, serialosc, the /mlrv prefix is set on the monomeserial (serial osc bridge) and the required xsample files are all in place. The monome works fine (checked some apps from the monomebase 4.5)
    Can anyone point out what could be wrong here?

  • What does the max window say ?

  • it says mlrv
    but it gets stuck on the contributors screen, it never fades out to the actual mlrv interface

  • The max window : ctrl+m

  • anyone know how to extract row presses as midi data?

  • @chapelier fou
    ctrl+m gives me a screen full of missing objects

    for example:

    del: no such object
    *~: no such object
    !/: no such object
    !-: no such object

    etc...

  • @away message
    I second that question.

  • @fozzy :
    i'd reinstall max...

  • @chapelier fou
    did that... nothing changed :/

  • @fozzy, for comparison, I'd try shutting down serialosc and running mlrv22 with monomeserial as a test. purpose would be to narrow down suspect components.

    also try to post a jpg attachment image of the max window, see what the first error is...

    also wondering if you load the mlrv2 program via clicking on icon, have you tried starting max, then loading program?

  • Ok here is the the max5 window as soon as I load the monomeserial (serialosc bridge) the two missing objects are the two monome boxes (monomeserial give an option to connect 2 monomes at once)

    the second screenshot is when i load mlrv. note that the first missing object from mlrv is highlighted in gray (a LOT of missing objects I must say...)

    the third screenshot is the actual object missing from mlrv


    @rawore
    I just tried to load the patches through max instead of double clicking on them but i get the same :/

    EDIT: screenshots in reverse order :/

    847 x 666 - 79K
    481 x 732 - 126K
    475 x 358 - 59K
  • @fozzy: did you try downloading mlrv2 again and running from that copy?

  • yup... even tested mlrv version 2.1 but i get the same...
    i remember a time when setting up your monome was relatively easy through the monomeserial
    now with the serialosc i have to install a bunch of things (bonjour, zeroconf, monomeserial bridge etc...) and it's really bugging me that i have NO CLUE where the problem is :/

  • uninstalled and reinstalled EVERYTHING, and now for some mysterious reason it works! :)

    WOOO HOOOO!!!!

  • @fozzy: are you having luck with monomeserial or serialosc? I'm having similar problems and have tried uninstalling everything multiple times. It would be nice to know what works so I don't have to use trial and error when I'm reinstalling everything this time around.

  • @darb
    just serialosc, using the monomeserial bridge (since mlrv2.2 doesn't support serialosc)

  • @fozzy: great! you're looped ;)

  • hey parallelogram crew!
    i've been wondering...
    is there a way of making the file paths stored in the save file relative to that save file?

    example (see image), all the loops will be in the "Live" folder and the file paths saved in the mlr file will be /Live/...
    this would mean you could move the folder and file around on your hard drive (or to different hard drives) without having to create a new save file...
    any ideas? it muuuust be possible

  • @maersk
    indeed it must be possible. our 2.3 update has been slowly coming together and we'd love to have this kind of functionality. unfortunately we could not find a way to generate a new directory from within a maxpat in order to automatically create a self-contained preset bundle. the difficulty that occurs without this functionality is how to handle the drag'n'drop sample adding approach without having to manually copy the individual sample files.

    if anyone has suggestions as to how we can implement this effectively / a method to create directories within a maxpat and how to copy audio files into that location --- it would be much appreciated!!

  • Just a quick question, when running mlrV should I be using only monomeserial? Has running monomeserial with serialosc running simultaineously been known to cause issues? I've run into a snag usin mlrV with my new monome. I posted the problem here: http://post.monome.org/comments.php?DiscussionID=13121&page=1#Item_1

    The problem is explained towards the bottom of the post. The top is just explanation and side questions.

    Edit: problem resolved.

  • When I have one pattern group going in MLRV and I try to start another pattern group it doesn't work. If I stop the first pattern, then I can record and loop a second pattern. Am I doing something wrong?
    -rerouted the clock to sync from ableton and the pattern groups are working correctly. not sure why it didn't work the other way though.

    Or is there another app that is better suited for pattern recording/looping?

    Is it possible to sync the MLRV clock with ableton via rewire, but use an alternative audio output that is not from Max?
    -I think i figured this one out. Turn on the sync button Max1 in the Ableton preferences. select Max1 as the clock source in MLRV.

  • @parallelogram

    is it possible to record audio into mlrv 2 when rewired to ableton?

    mlrv 2 input seems to disappear upon rewire, so i cannot figure out how to pipe audio into a rewired mlrv 2 for sync'ed fun time.

  • I would love the option of mono external outs for groups.

  • Hey parallelogram, how is mlrv development going? is there still a 2.3 update in the works?