mk firmware / serialosc

  • hey tehn I'm still having problems with hard pushing the buttons.

    And the bigger problem is, if I switch back to the older firmware. (to debug), the monome stays reacting very sluggish.

    Is there anyway to fix this issue?


  • it sounds like the keypads are bad. e-mail for replacements.

  • change your makefile to m0000xxx and change your serial number with pirate rename. details:

    the monome has to be connected to the computer *before* you short the pins.

  • Hey Tehn,
    Yes I have followed all the details of the description.
    But still it stays like it.
    And I also mentioned that when I run MonomeCTrl Test patch, that the upper 2 rows dont light there leds.

    I think that it shoudnt be the pads but something with firmware.

  • run monome_test for testing.

    you're not running monomeserial right? (do not run monomeserial).

  • nope I'm not running monomeserial.
    and there is no change in hard pressing the buttons, with the monome_test patch.

  • i don't have much to suggest unfortunately. if you'd like to ship the kit to me i'll take a look. if so, e-mail

    you may want to try the install on another computer.

  • Hi tehn,
    I reflashed it again with debug.
    And it works fine now.

    really strange. :)
    But it's oke as long it works.
    Thanks for support .

  • I downoaded the firmware, looking for tilt support. When I navigate to \tehn-mk-af56f96\tehn-mk-af56f96\firmware\tilt, there are no .hex files present. Does this indicate that the tilt version is still as-yet incomplete? Thanks!

  • ack, i'll get those hexes included.

    also, serialosc support for tilt isn't there yet, and i need to write up the tilt aux hardware tutorials. should be ready in a week or two (major serialosc revision happening now.)

  • Great news, thanks for the update! I have been enjoying serialosc quite a bit.

  • hexes added to git for tilt.

    also fixed some bugs in the encoder firmwares.

    also posted an encoder test max5 patch, at the bottom of the assembly guide:

  • @tehn:
    I just installed the the enc firmware. But it gives me digital input of course. Is there any way to read analog sensors on the mk board yet? Would this just be the tilt firmware?

  • what are you trying to accomplish?

  • I want to use my FSRs, ribbon sensors and accelerometers. those are all finite, they provide a range of electrical resistance.

  • got it. the "analog" firmware is pretty much done, but we have a few serialosc fixes in the pipe before the analog support will come out. apologies for the delay, and we're on it.

  • Is there any update on 40h/alt compatibility with this firmware?

  • all the mk firmwares have a -old version for 40h boards

  • oh, excellent! I will give it a go and see how I get on. Ill give feed back on the update process.

  • Update did not go so well for me. First I found that the default-old folder doesn't have mk16x16.hex? Should I be using this?

    I tried with the mk.hex in the default-old folder to see if the the corner 8x8 would work at least. I seem to be having the same problem that other users are reporting. Button responsive has dropped and sometimes they do not register at all.

    I tried the encoders-old firmware with the mk16x16.hex and all the buttons are working but still have the same responsiveness issues.

    I also noticed some errors in the Max window.

    -> matrixctrl: cell coordinate(s) out of range

    this happens when ever I press a button that isn't the corner 8x8.

    I have now moved back to an older firmware that I had for backup, and strangely enough its working pretty good now and my miss-fires are gone.
    I still see the same error in the Max window.

    If there is anything you think I should try please let me know...

    I change my serial to m0000063 for the new firmware, and I changed back to mk000063 for the old firmare.
    MacOSX 10.6.8, Max 5.1.7, latest SerialOSC install.
    I am also not running MonomeSerial at any time.

  • ack. this is somewhat inexplicable as it's working fine over here. i'll take another look.

  • This is not a major issue for me at the moment, the old firmware works ok. The miss-firing is back unfortunatly but it is limited to only one buttons on my 256 so its easy to deal with.

    I don't think there is anything wrong with my hardware as button response is fine before the update.

    I tried the update process several times incase I was doing something wrong.
    If there is anything you want me to try with my set-up let me know.

  • hello,

    i have been trying to get my arduino uno to work with serialosc on a mac 10.6.8. i have already changed the 8u2 serial number to a40h-001. serialosc is perfectly installed since it recognizes my monome!

    i have read in the forum about other people trying to accomplish same thing on a mac. i have also read about a work around to compile serialosc to recognize the new atmega8u2 and get it to work, but i am not very familiar with terminal.

    my question is if the next version of serialosc will recognize the arduino uno?

    thank you !! :)

  • please start a new thread with this question, or follow up in a relevant thread.

  • ok so i read through this thread, but am really tired so i may have missed some thing. i've been really busy and thus very out of the monome loop during this whole serialosc transition. i'm currently running whatever was the best working mk firmware for monomeserial. i'm running Mac OS 10.7 Lion and have set up serialosc and ran the Lion fix in my terminal and restarted my machine. then i figured hey, i'll just test my current monome and firmware and see if it works. everything seems to be working fine except one silly thing...

    on the monome test patch... my button presses show up in the "led" grid... and my lights lighting up show up in the "key" grid.

    is there a newer firmware i am to be running?

    sorry if this is a redundant question. i'm getting reacquainted with my poor neglected monome and with the community and seem to be missing the information i need in the thread. my apologies.

  • the grids may be mis-labeled, let me check.

  • can't I get an answer on that? I bought the kit a good 1and a half years ago because it was said to have an analog sensor interface, soldering and all was done. But it still doesn't do analog in. Could you at least tell me if there is any chance you'll write the firmware at all this year and if not if it is possible to do it myself (where to go to learn ho to?)?


  • @ tehn

    Has there been any work on the serialosc firmware for the mk kits will old button pads? From reading my posts above you can see I was plagued by unresponsive buttons. I moved back to the older firmware as it was ok at the time and the misfires were manageable. Now as my set-up gets more complicated I am finding the misfires to be quite troublesome and sometimes find myself at a disadvantage not having serialosc compatibility.

    If you are not to busy maybe fresh eyes might find something, or maybe you have figured something out in the last few months....

    Also, has anyone that was having the same issue as me found a solution?

  • @tehn

    I'm quite a bit annoyed, I have been asking for over a year about firmware for analog ins, first it sounded as if it would come some day, now noone even bothers to answer. I bought the kit almost 2 years ago mostly because it would offer me analog in as well as the buttons - so i could minimize the shlepp. But so far to no avail. About two months ago I sked if there was any ressource for information on how to maybe attempt writing the firmware myself as you guys are busy with other things, but not even here I got answered...

  • @ tehn


  • @ tehn

  • apologies, not sure how this got by me.

    the problem is serialosc, as usual. will sent me a working version with tilt last week, but it's os x only.

    the mk tilt firmware has been up for 9 months now, by the way. on github.

  • and back to the misfire issues. is it uniform (all keys) or just a few keys? i'm trying to sort out if some bad keypads got into the mk batch.


  • @ Tehn,

    thanks for the reply but unfortunately it seems like the logic board has burnt out on my mac. Can't complain since i've got well over four years out of it! This means I can't do any real testing until I get a computer sorted, hopefully in the next few days.

    On to the misfires though. I don't think that the misfires I have can be put down to bad keypads as I had my button pads from earlier kits. The button pads I have for my 256 come from maybe 2010 or earlier. I only updated to the new logic board for bus power and the hope of serialOSC. I never had any issue with misfires before using the new logic board...

    Since I will most likely be getting a windows 7 machine as a replacement for the foreseeable future, I will try to do the update again and see what happens with regard button presses and serialOSC. Although I will need to test it again it seemed like the buttons needed more contact if you know what I mean..... I know this isn't possible since there hasn't been any hardware change but maybe the unresponsiveness is related to extra delay or debouncing when catching button data??

  • @tehn

    I know the firmware's there but as we talked about shortly After its release there's only support for digital encoders. What I'm interested in is getting analog sensors (they are essentially potentiometers) to work. And i have no clue how to modify the enc firmware to get there...

  • analog firmware is provided, but it's mapped to /tilt which is widely supported. straight /analog messaging hasn't ever been used or implemented.

    more importantly, i'm assuming you're writing your own patches. i'd suggest using the tilt firmware, which will get you analog input, but only two inputs (x and y axis).

    what's your final goal for hardware/software?

  • @tehn

    Quote from the monome website about Mk:


    auxiliary ports for additional digital or analog i/o, such as knobs, joysticks, accelerometers, rotary encoders, switches, LEDs

    I bought the kit for the 16 i/o pins that supposedly offer analog Input option. I had used eobody interfaces before along with several button devices. But the Midi resolution of the eowave never satisfyied me. So OSC seemed like a good alternative to Midi. And having completely customizable Buttons along with it did not seem bad. So I' m still waiting for something to make Mk read the pins for control voltage rather than binary

  • yes, the mk holds this potential, of course. the issue is that despite the serial protocol being designed to facilitate this functionality, there are numerous steps and processes that would need to be implemented which haven't been (libmonome serialosc support, and example patches or actual use cases.) my initial announcement of this functionality was not fully considered and i apologize. at this point i'm less interested in creating sensor lab.

    e-mail if you'd like to return the device

  • @zuchtfisch,
    if you have a mk monome kit you are not wanting, I might be interested as well.

  • @shimoda
    the trouble is that the MK is all soldered (including bright warm white LEDs) and I've machined an enclosure from a solid block of zebrano wood already. So you might see it pop up in a FS message here.

  • @tehn

    ok, I got a windows system sorted which I will be using for the next few months.
    I tried to update it to the serialOSC firmware and I am still having the unresponsive button problem. I took videos of before the update and after the update, not sure how much information this will give though.

    alt-encoder firmware (monomeserial)

    default-old firmware (serialOSC)

    I moved back to an older firmware (tehn-mk-07df1eb), now the misfires seem to be gone but two of the grids go blank after some button mashing. Not sure what my next step is

  • this is confounding. thank you for the video-- i'm going to look at the firmware tonight.

  • Arrggh! I must be experiencing this same issue. I first noticed recently when learning to program groovy scripts within Pages. At the time, I figured there must be something wrong with my code because (for example) I'd have the top left button programmed to just toggle a led on and off but upon testing when I would repeatedly trying to trigger on/off, on/off, on/off I encountered random non presses...or miss fires.

    Right now in fact, I'm using SevenUpLive and it's really apparent while using the Stepper. There are 3 states for the buttons with SevenUp's stepper: Note Off (no led), Note on (half velocity/half led) Note on (full velocity/full led). Some buttons seem to react fine, but others clearly missfire

    edit- Just did some further testing with _monome_test and its there as well

  • i was only mildly successful, continuing on this morning

  • new firmware posted to github-- "default" is changed. try it and let me know. works better for me, typo in the timing tuning

  • found here

    Is this something I can implement?..I've never worked with firmware. btw - My unit is a greyscale 64.

  • this is for the mk.

    gs64 problem requires keypad replacement, email