Starfire 128 Build - Please Help! (avrdude content)

  • i am hoping someone with similar experience can help me out. i'm working on building a arduinome128.

    i assembled/soldered one of my two starfire logic boards and i'm trying to get the firmware onto it but i'm not having any luck at all.

    i am using this ATmega328 with Arduino Optiboot (Uno) from sparkfun:

    i'm following starfire's extremely helpful videos, and when i try to upload the arduinome firmware in the arduino software i get this error message:

    avrdude: stk500_getsync(): not in sync: resp=0x30
    avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

    i've searched here and far and read about lots of people who've run into this. some of them had easy fixes like rebooting, turning off bluetooth keyboard, turning off serialOSC, and changing the COM port, slowing down the upload speed, etc.

    i've tried all of these (well, i'm not sure how to try a different COM port, there's only one listed, COM4, in the arduino software) and keep getting the same message.

    some more info:

    - i'm on windows xp
    - i opted for a um232 (
    - i am using sockets because i figured i might have to unplug some stuff!
    - i tried the other atmega328 (i ordered 2 since i'm building a 128) and got the same result
    - i tried the upload procedure with just the UM232 unplugged from the rest of the logic board and got the same error

    the last point makes me worry if i have the bootloader on my atmega328 or not...i read some earlier posts about how theirs had a red dot to indicate the bootloader was included, but i assumed this was for a previous model anyway (mine does not have a red dot).

    any help would be greatly appreciated!!! i am hoping it's something simple i'm missing.

  • Starfire's videos preceded the release of the Arduino Uno, and were more or less based on the Arduino Duemilanove.

    So, your solution is probably buried in this thread:

  • seems like most of the problems in that thread were related to programming the atmega8u2, not the atmega328...according to artfwo:


    arduino uno has 2 flashable chips: the usb2serial converter chip (actually an atmega8u2 microcontroller) and the primary atmega328p microcontroller. in order to program the latter you just press "upload" button in the arduino IDE and you program then is burned into atmega328 memory.

    programming the little atmega8u2 is a bit more tricky, as you can read on the page, which thealphanerd linked above:


    still seems like i should be able to just click upload for the atmega328...

    and i don't have an atmega8u2...but i do have an ftdi chip.

    maybe i have to give my ftdi chip the proper serial number first?

    (starfire's videos showed doing this after uploading the firmware, although like you said, that was for duemilanove not uno).

  • Don't know, man. That uno Optiboot jumped out at me as being sufficiently different to throw off all the instructions, but I don't have a lot of followup thoughts beyond that.