mlrV2.2 Serialosc edition with AlphaNerd Plugins

  • This afternoon I ported mlrV2.2 to serialosc... as far as I can tell everything is working perfect on a monome 64 and a 256. I wasn't able to test tilt, but that should be working as well. My edits may have broken comparability with apc's and other non monome devices, sorry brahs. I also appear to have broken the credits in the opening... whoopsie.

    I have also taken the liberty to include my pattr marker hack... which opens up the entire pattr database of mlrv2.2 to max on a global scale. I have included a plugin example that has volume control and bpm control broken out into a separate patch... I will be using this to develop some arc patch's to interface with mlrV over the next two days.

    To set up your serialosc monome click on the settings button, and you should see a familliar but slightly different version of the serialosc connection patch, I have added my serialosnoopy mod, so it becomes quite easy to break out button press data for visualizers or network performance.

    Checkout mlrV2.2 serialosc edition on github :

    You can download it here:

    Please use github as a means of filling out any problems with the patch, I will do my best to keep it updated, and fix what I've broken...

    Checkout the mlrv2.2 plugins on github:

    You can download it here:

    The mlrV2.2 plugins will work with monomseial mlrv2.2 if you use the _mlrv_nerdmod.maxpat included in the zip file. Just drop that file in to your mlrV2.2 directory and you are good to go.

    Any questions feel free to ask in here, on the #monome irc channel, via github, or by messenger pigeon

  • This is great. Thank you.

  • awesome! downloading now

  • oh raja you and your pigeons, they never get there on time, especially in the festive season.

  • AN (peace)

    the six days to the gig and there's a new app Flash!

    you've been busy


  • have you thought of it automatically setting the device?

  • @maersk think my connected device came up connected again after I saved a preset, stopped the app, then restarted & loaded preset.

  • well, checked again... the preset reload doesn't make the device connected. sorry about my misunderstanding.

  • yep sorry completely forgot the device type was saved in the preset, thought it was mlrv detecting it

  • @maersk

    That is actually pretty easy to work in... Not sure if it is a good idea though.... if it auto connects it will always do so with the first device in the list. Also the bang to autoset would need to wait long enough for devices to be recognized via bonjour... which is not necessarily reliable timing wise (although that could be fixed with a delay).

    I started writing that I am unconvinced about adding it in... but a thought just occured to me about making an option in the setup menu to turn auto connect on and off... so perhaps I'll try and work that in soon.

  • @thealphanerd
    i just meant that when you hit connect, it detects what device is connected.

    either way this is great :) one less thing to set up when playing live! also one less thing to reopen if everything crashes haha

  • @maersk

    OHHHHHHH that makes a hell of a lot more sense... probably a way to do that with a single reg expression... If only I knew reg expression :p

  • I assume that if you have the xsample plugins from the original installed, they will do for this as well?

    Also, should this be run in max 5 or 6 (runtime)? Or does it matter?

  • @willcarter
    yep the xsample files are inside max and will work with any max patch that references them.
    you probably won't have any problems running it in max 6 but i'd stick with 5 just to be on the safe side especially if you're performing live :)

  • this is great, thank you!

  • used it live the other night, thanks :)

  • getting no sound
    granted i wasnt getting sound or lights using mlrv sans serialosc

    i'm connected
    samples load and waveforms appear
    i press buttons and then
    they dont cycle thru the loop

    only the first button in each groups row illuminates

    probably a simple solution but i'm stumped

  • Is your transport running? Have you installed xsample?

  • xsample yes

    n00b question...where is the transport?

  • Probably found it but it's in the "extras" menu as "global transport".

    If you're using runtime you won't be able to find it without this workaround:

  • yo thanks alpha + dolza
    got it working

    first time actually using MLRV
    nothing like it

    great UI and its so flexible
    really like mlr on steroids

  • Does this serialosc Alphanerd patch work with the 128? I'm not getting any loops to run the length of my monome, they lights always start back at the left after 8 rows. Any help, please

  • @cmb: yes, like the original mrlv2.2, it does. check the website for setup details.

  • @cmb

    You are going to want to go into options and set the type to be monome 128.

  • Hey,
    not tried yet, but i got a message pointing out that i am missing "OSC-route".

  • you need the CNMAT everything collection

  • Are the plug ins compatible with the original mlrv2.2? I'd love to use with my apc40 if so. Cheers, Spaze

  • The serialosc version should still work with the socks

    Otherwise you can you can find a nerdmod of the main mlrV 2.2 in the github

  • Just got this! Brill, megathanks for the port!

  • How does one test tilt?

  • trying it out with max 5.1.0 in Windows7 (64bit) but i can't drag&drop audio files (tried both with wav and aiff)
    (did copy the xsample files etc...)

    what could i be doing wrong?

  • did you give it plenty of time? I thought mine was hanging but I just tried really big files without thinking bout it.

  • yup, guess i did...

    in the Max window i'm getting:
    #N: extra arguments for message "fromsymbol"