OLD SevenUp 2.0.5rc3 Thread - Use SevenUp 2.0.5 Thread Instead

  • Ah cool.

    Well the hardest part is that the manta is 8x6, so can't display 8x8x at a time. That and also that it's not actually a grid.

    The lit button is a toggle to shift the 8x8 grid up or down to show the top 6 or the bottom 6 rows.

    It's disorienting even for me but thems the breaks I think.

    Melodizer is the mode to be in since the manta velocity is quite nice.

    Stepper and looper you need to get oriented to the vertical back and forth on the hex pads instead of a straight row.

    The multicolor is nice (Yours is a V2 right?)

  • I've been fooling around quite a lot with 2.0.5 lately on my 256 2011 monome, and I really love the app, but I'm experiencing quite a lot of issues all the time. it's like the app gets overflooded and re-starts all the time. most of the leds suddenly light up, and everything halts, and then it gets back to normal for a while. I tried what you said bar-none: using less steppers and so on, to minimize the led data traffic, but this is not solving the problem.

    is anyone else experincing this on a monome 256 with led intensity activated?

    it seems to me that there is something that needs to get optimized.

    wish I had the knowledge to dig into the app and fix it myself
    probably will someday :D

    cheers

  • btw should it do any harm to have both the 2.0.4 and 2.0.5 objects in live's library? cause lately I've been switching between 2.0.4 and 2.0.5 to see which would run smoothest. everytime I did this, I put the correct items in the max cycling75 java lib folder of course. including the original max items.

  • sorry for spamming, but now that I changed back to 2.0.4, it's doing the same thing there as well... I don't get it...

    is 7up just not supposed to run with a 256 or am I doing something completely wrong?


    edit:
    I now see that using just one instance of 7up on my 256 fixes this issue.. so apparently it's got be some kind of overload in the data traffic. or ?

  • There is still a manta forum on Google Groups, it's where the new posts on the topic can be found.
    As another manta v.2 user I want to encourage bar|none to keep it up! I think it's amazing that one app can work on such different devices.

  • @himstregims
    >"I now see that using just one instance of 7up on my 256 fixes this issue"

    You can't use more than one SevenUpCore instance period. It's meant to be a singleton in Live. If you drag in 2 then they are competing with each other for critical communications. Glad you got it sorted.

    @Someone_Else
    Thx

  • @bar-none

    sorry I wasn't explaining myself correctly.
    what I meant was that it only works flawless when I choose "monome 64" or "128" in 7up core... i meant "7up instance" as in a "window" of 64 buttons.
    if i use 4 of these "windows" (all of my 256), it cracks up from time to time..

  • Ah I see. Yes, the 256 can have data rate issues with 7up. Basically, the serial buss gets overloaded and then the comm backs up. If you switch to a page with less blinkiness, then it can recover. Not much we can do about it unfortunately.

  • is there any way to measure this? I mean if I make a patch myself that gets overflooded - how would I know what's actually happening.. guess this is a bit off topic

  • You can't really detect it. I can see it in 7up cause the lights become sticky and the device starts to become non-responsive.

  • Hello again,

    I had sevenup working but decided to change to the serial osc version. Did the install and now...

    Should I only be seeing monome 128 and 256 in the connection options? I have a 64, is it not supported?

    Here is a picture of the max window in case you need it.

    1280 x 1024 - 203K
  • nevermind! I restarted and it is now listing 64 as an option.

    Nice.

  • Yeah that 128 and 256 are mine, once it pings your network for devices it should refresh to yours.

    Glad it worked. I find the zeroconf thing to be freakin awesome, cause it just works with no configuration.

  • does this work with any version of max higher than 5.1.8 or does it have to be 5.1.8 only?

    it only has 5.1.9 on the older versions of max on cycling 74 website. also does it work ith rt version of max?

  • Is there any max length of the looping function in the melodizers?

    It's behaving weird sometimes when I'm trying to create longer loops.

  • @fraserh
    Yes, it does work with 5.1.9. It does work with RT version of MAX however you MUST have a MAX for Live license to run it since the components are M4L devices.

    @peterlausten
    Shouldn't be but realize that your loops do need to be cut correctly to loop at their native tempo since 7up doesn't do time stretching.

    Is there something else specific happening?

  • hi bar none,

    I have tried it with 5.1.9 runtime (i avemaxfor live license) but when I select the folder for where ableton see max (in preferences) its says "can't find usable version of max", am I doing something wrong? :D

  • @bar!none

    I'll have to investigate further, I'll get back to you...

  • @fraserh
    You may have to take that one up with Ableton. I see my licenses in Ableton preferences and you just need to install MAX RT as well to use M4L from what I know.

  • @bar none

    I asked on ableton forum and the replies I got said you need full version of max to run maxforlive.

  • Ok, download the full version then. You need it installed but you don't need a MAX license, you just need the M4L license. This means that you can't edit MAX patches but you will be able to install and use M4L devices.

    It's confusing I know.

    http://www.ableton.com/pages/faq/max_for_live

    http://www.ableton.com/pages/faq/max_for_live#faq_6_link

  • hi bar none,

    I got managed to get 2.0.4 working again so I am going to stick with that, apart from bug fixes etc, what are the differences between 2.0.5 and 2.0.4 is there new "instruments" in 2.0.5?

  • Glad you got it working. There is a complete detailed description top of this thread.

  • it has been FAR too long since i have played in the realm of 7up... cannot wait to experience all of your hard work!

  • one question. is it still possible to use a midi keyboard in combination with
    sevenup 2.0 and the melodyzers? if yes - how? ^^

  • @LEVELS
    Hey thx, welcome back

    @eugenb
    On page 1 of this thread, search for "then sends to midi output ch 9."

  • thank you!

  • i need help getting controler to work on sevenup 2.0.4, in the instructions it says ...

    1.Open Ableton Live's MIDI preferences for a single virtual midi device, enable its "Track" output and its "Remote" input ONLY. An example is shown below: ?

    and on the image in the instructions of the midi inputs its lists 8 or but when i open the preferences in my ableton it only has 3 midi ports, 2 for the launchpad im using and 1 for wave gs synth or something. how can i create extra midi ports in ableton?

  • If on mac you create virtual IAC ports. Pc can use midi yoke. Google either and should unblock you hopefully.

  • I'm using a gs64 and i have Live 8.2.6 and Max 5.1.9 using SerialOSC 1.0 and the SevenUpCore recognizes my monome but when I connect the seven never appears on my monome. When I click test every LED lights up, but that's all I can do with SevenUp right now. Any help?

    EDIT: Kind of obvious but I'm also using SevenUp 2.0.5

  • Right click on SevenUpCore title bar and choose "Open MAX WIndow"

    Clear the window and try connecting. It's possible your jar files are not installed correctly. The M4L part of 7up can connect and the test will work but the java part will not run, which means no 7's

  • I got it to work

    I accidentally put the "supporting" folder in the wrong "lib" folder

  • Sorry but I have a new problem now.

    I got the Seven to appear and when it goes away it goes into stepper but I am stuck in stepper mode. The top right button is solid, and the one right below it flashes, but I cannot change modes. I try tapping the solid button, but nothing happens.

  • If you press other buttons in the grid in stepper mode outside of the navigation column do they light up? If they do then your communication is working.

    Changing modes you need to tap the solid and then tap a non-flashing button in the navigation column.

    If the monome doesn't respond at all then it means connection from monome back to 7up not working. You might want to screenshot and attach the "Open MAX window" contents.

  • i am able to control the grid in stepper


    Here's the screenshot of the Max window

    EDIT: in the max window I saw that it said something about the zeroconf so I put them in the max-externals folder but i still can't navigate :/

  • this also came up when i opened the max window after i put zeroconf in the max-externals

    EDIT I just rotated it so the buttons shifted and it works fine i think something is wrong with my button sorry for the trouble
    EDIT actually something is wrong with my entire rightmost row, none of the buttons are responding! need to look into this more

  • You can use the rotate dial to move the nav column around and see if it is indeed a device issue. If some buttons are working, that usually means everything should work in 7up.

  • @bar none

    I have set up midi yoke and have now 8 virutal midi channels, I set it up to use with controller but something strange is happening.

    when I use midi mode to map the slider etc it works until I turn midi assign off (the little midi button top right) then the light stays on the launch pad for which ever slider I use and when I change to another 7up function, for example the stepper it wont allow me to use the button I had assisnged in controller. so what ever coloumns I use for controller are then unusable in other sevenup functions if that makes sense.

  • Well you can only use those sliders when in controller mode, so yeah they don't work on other pages. You get fast at changing pages real quick.

    Also masterizer page has buttons in the nav column you can midi map. Those are also only avail when in masterizer.

    Don't know if that helps or not.

  • Thanks Bar None,I know that mate, what I mean is one I have assigned a fader in Controller I cant use that coloumn on my launchpad in another function of Seven up. for example if I select the first column to control a beat repeater in Controller, I can't use the first column in Stepper (the lights dont work in stepper and I get no play back when pressing leds in that coloumn). It is like once I have selected that coloumn in controller I can't use that coloumn in stepper/looper/melodizer etc.

  • Can't imagine 7up would do that. Is it possible that some sort of midi mapping in the launchpad itself is at work here? Like the launchpad is also midi mapping and then taking over that column?

    Launchpad does send midi and maybe Live is mapping that, then repeating it back to launchpad and screwing up the comm.

    Look at the mapping page in Live.

    In midi settings, turn off ports set to "remote" that are not associated with 7up.

  • i use 2 self built monome 40hs. i fired them with arduinomeserial both with the prefix /7up. on one i changed the starting row to 8 to use both monomes in one 7up session.

    now to my problem: after installing serialosc, i use pages to manage both monomes. in both i have a page with /7up as a prefix, but the newest 7up version doesn't even detect those... what should i do?

  • hmm, pages doesn't re-advertise the combined surface as a new virtual device?

    I tried this with griddle and it does re-advertise whatever combined devices you create. I was able to connect to a composite device that way.

    You might try griddle as a test and maybe ask if Pages should be re-advertising or not.

    The whole point of the zeroconf stuff was not to have to have that massive pick list of sizes and manual configuration nightmare we had before.

  • thank you, i'm checking it out!

  • do you guys want someone to list this on the app page? under serialosc/max4live? i was looking for this there... and it wasn't. i'm down to put together a page for you.

  • so... i've messed with 7up a number of times... but can never seem to build a set up to my liking with it, however i feel it has the potential to do all i want it to... some inspiring sets have used it...

    do you know exactly how to put together such an adaptive set as this?

    http://vimeo.com/13963438

  • Well you do know of course that 7up is Adam's (makingthenoise) creation right?

    All I can say is there is a serious art to creating a performance set like he and other artists do.

    One trick I have seen Adam do is using midi messages to jump to certain positions in the timeline as safe points to jump to. Using automation to your advantage.

    Stepper can be used for a lot more than just beats.

    Melodizer can be used for a lot more than just notes, it can trigger pretty much anything via midi.

    At gridfest 2011, there was a whole track (Under the Hood) on this subject and the videos are linked here.

    http://vimeo.com/channels/gridfest2011

  • one more question on 7up/live. is it possible to record the samples, which you can manipulate mlr-wise in menu 4/5, live? let's say i have my guitar set up as an input in live, how can i link audiofiles into the stepper, where the samples are located. is this even possible? ^^

    another approach is using melodyzer 1 as a clip-launcher with follow actions, but you would have to split the clip into subclips and couldn't record your actions...

    i know that i could just use mlr, but i want to be able to see the content of my clips...

  • I think I'm having a hard time with the questions today. Not really understanding exactly what you are trying to do.

    Generally, simpler and sampler need to be fed samples via drag and drop. so there is no way to automatically feed the samples from a recorded clip.

    Believe me, this has always been a pain and the fact that you can't time stretch them either is a bummer.

    Now if someone were to make a component in M4L that worked better. Would be all over that.