please help - arduinome button presses aren't registering

  • I don't seem to be receiving the MIDI messages from my arduinome. The LEDs light up when I am using the MAX patch but when I press the buttons, Max is not receiving the signal. I know the messages are being sent because I can see the green light on the arduino flash when I use the buttons. I am therefore guessing that the problem lies in the rooting of the MIDI messages. I just can't seem to figure out where I am going wrong.

    I am using Mac OS 10.6
    Arduino Duemilanove
    SerialOSC seems to be working fine
    I am running ArduinomeSerialST8
    And the Max test patch from Monome Base 4.5

    I feel like I am missing something simple but I have been trying to figure this out for hours! Any help would be really appreciated.

  • If the LEDs on your arduinome light up when you're using the max patch, then max is receiving the signal. Max is generating those lights. It's also generating the MIDI signal that you're looking for, if you're using a patch that sends MIDI from the monome. Your arduinome does not generate MIDI, period.

  • Know that, then watch this:

  • Actually, hang on.

    You're able to send OSC messages to your arduinome to turn the lights on, but don't seem to be receiving OSC messages when buttons are pressed?

    Note I did not say MIDI, because that's completely misleading and it doesn't actually describe your problem, at all.

    You should seriously change the title of this tread from "No MIDI???" (answer: "None. Why?") to something like "please help - arduinome button presses aren't registering". This helps people who know how to help you to understand that they're needed.

    Anyway... it doesn't sound like you're missing anything simple at that point. It sounds like an electrical problem. i.e., all of your diodes are in backwards.

  • don't run arduinomeserial and serialosc at the same time..

  • Ah. Yes. What stevieraysean said. I missed that you were running both.

    The udp port numbers that OSC uses are exclusive. If any one thing is listening for button presses at a given address, nothing else can.

  • the big problem with running the two at once is that they are both trying to parse the same serial messages into osc mesages... so serialosc and arduinome (monome) serial fight to get the messages... try and get monome test working first before anything else

  • Thanks for the help. I have now changed the title of this discussion.

    However, running just serialosc has not solved the problem. I followed this step-by-step and I am using the patch shown in number 5:

    When I press the buttons, the Max patch does not respond. But when I press the key grid with the mouse, the corresponding LED lights up.

    Any other suggestions?

  • try killing serialosc and using this max patch... it reads the raw incoming serial data

    This is a good step to make sure the button press data is coming in correctly at all

  • After more extensive testing, I've have realised that the buttons are working and there is a mix up somewhere on the software side of things. If I open the Arduino software application and open the serial monitor, and then press a button, I can see the program responding. So there is a breakdown between the arduino and the MAX patches I'm tring to use. I am yet to figure out why. Does anyone know what port serialOSC uses?

  • It's randomly assigned, though newer versions of serialOSC.maxpat (like the one in step 5 of that page) do have an "M" button which allows you to manually type in a port number of your choosing.


    Also, strange question, but what serial number did you put in the firmware?

    The drop-down menu (between "setup" and the "m" button, near the "connect" button) will tell you. Check that and report back. And also, let us know whether it's the only device showing up in that list. In fact, if you could open the dropdown and take a screenshot, go ahead and post that. =)

    This may or may not be a factor, but serialOSC does identify your hardware (and thus what protocols it should use to communicate with your hardware) by its serial number.

  • a40h-001

    If you are wondering why it is a40h-xxx format rather than a40h-xxxx, it is because I am using a duemilanove. See:

    I've attached that screenshot. It all looks like it should be working to me :-/

  • I'm experiencing very similar problems (see ) - except that mine doesn't show up as connected in Monome Test.

    Using the serial-test recommended by thealphanerd above the device shows up okay. Pressing the buttons //sometimes// changes the numbers in the box I've highlighted on the attached screenshot. They're made up of combinations of 128, 152 and 30 //only//, unlike the numbers produced in Arduino's serial monitor, which correspond to button state and address.

    Toggling some dots on in the "led" grid thing //occasionally// makes some of the lights come on, but not in any logical way that I can see.

    (Incidentally, this behaviour in serial-test appears identical regardless of whether or not serialosc is running.)

    @thealphanerd, is there any documentation or hints as to what any of the stuff in the serial-test GUI actually means? Or a tutorial somewhere you can point me at to do some learning?


    958 x 751 - 56K
  • @dgrizzle - have you managed any progress with this issue? I'm now at a very similar point, and pretty sure it's a software communication problem.

  • Problem solved. There was a problem with the arduinome firmware 3.3.

    See here: