Arduinome Connected in monome_test, buttons not working

  • After a few weeks of tinkering I have finally gotten my Arduinome with Unsped shield + Bibo board to be recognized in serialosc, and connected in the monome_test patch. Updated the .dll in serialosc fixed this problem for me.


    My issue now is that no button presses or LED commands are working from monome_test. The board goes through its lighting sequence at boot, and all LEDs remain on.

    I have tried all orientations of cables (restarting and reconnecting monome_test each time). I see no input in monome_test when i press buttons, and clicking the led or button squares does nothing to my board.


    I have verified all of the ICs are aligned correctly on my unsped shield. Visually checked all diode/LED connections (have not yet testing using a multimeter...)


    After starting monome_test, should my LEDs start off, or on?

    Any thoughts on this? I feel like I am so close.... yet so far!

  • Is the lighting sequence one column lit at a time? Are you sure you don't have the cables connecting to the wrong thing? For example the buttons from the unsped shield connected to the LEDs on the bibo board? Can you post some pics which show clearly how it's wired up?

  • Thanks for the quick response.

    My start up sequence lights up one row at a time, and ends with all LEDs lit (except for one LED, which is dead, I still need to resolder a new one).


    I have tried all combination of wiring, however here are pictures showing alignment of ICs on my Unsped shield, as well as alignment of connectors to the Bibo board:

    http://s1236.photobucket.com/albums/ff452/alxhastngs/Monome%20Setup/

  • I'm looking at your first pic and notice the cable alignment on the unsped board. Note that the pin 1 of the input header is top right, while pin 1 of the output header is bottom left.

    The red wire of the cables indicates pin 1.

    You have both cables pin 1 of both cables connecting in the same orientation.

    Then on the bibo board both cables are plugged in the same way, meaning that the you're plugging pin 16 (from the arduino shield) of the input into where pin 1 is supposed to be on the bibo board.

    Perhaps I'm not explaining this well, I don't have one to hand at the moment. I may be able to illustrate this with a photo later on.

  • I have tried further experimenting with the orientation of cables, swapping cables on the headers of the unsped board yielded some sporadic button connectivity, as well as very sporadic LED functionality.

    I am not 100% which headers are in/out on the unsped and bibo board. Here is an image for reference:

    http://s1236.photobucket.com/albums/ff452/alxhastngs/Monome%20Setup/?action=view&current=monomewiring.png


    My thoughts:
    WXYZ is the input header of the Unsped board, 5678 is the output of the bibo board.

    ABCD is the output header of the Unsped board, 1234 is the input for the bibo board.


    Logic may seem flawed because WXYZ is connected to the resistor network, which I would think is used to pull current for the LEDs?

    Anyway, this image should help! Thanks for the assistance in trouble shooting

  • On the bibo boards header pin 1 has a square solder point/pad, marked here with an x:

    x 0 0 0 0 0 0 0
    0 0 0 0 0 0 0 0

    The unsped shield input header pin 1 is as below (again x marks pin 1)

    0 0 0 0 0 0 0 x
    0 0 0 0 0 0 0 0

    The unsped shield output header pin 1 is:

    0 0 0 0 0 0 0 0
    x 0 0 0 0 0 0 0

    You need to make sure that your cables are crimped properly (pin 1 on one end is connected to pin 1 on the other end of the header), that pin one of the cable is connecting to pin 1 of the bibo board (for each header).

    Currently you have this wrong, I made this mistake as have several others, it results in much crazyness.

    I think, I'm not sure please check this, that pin one of the bibo board headers is top right.

    Which means you have:

    "2" -> "B" is pin 1 on the bibo board going to pin 8 of the unsped shield.

    And so on.

    I'll look for a clear wiring diagram when I get home. If you search some of the build logs in the documents->Arduinome section you're sure to find this documented.

  • If it happens to be the case your cables are right, are you on the UNO or are you using an old version of serialosc? serialosc was not supported on windows with arduinomes for quite a while. I'd do your testing with the old arduinomeserial as that is much simpler to troubleshoot. I still use arduinomeserial over serialosc most of the time just because it's easier.

  • Did you manage to solve this problem? I'm stuggling with the same issue at the moment. However, I am not using the unsped shield. I am using stripboard. I have checked all the connections and they all appear to be correct. Any ideas anyone? The arduino's green light flashed when I press a button but I can't pick up the signal in the monome test max patch.

  • @axlhastings - did you get anywhere with solving this? I'm having a similar issue, though I'm fairly sure mine is a software problem:
    http://post.monome.org/comments.php?DiscussionID=13863&page=1#Item_22