New Arduinome firmware v3.3

  • Hi everyone,

    Wow... nearly 3 years since the last firmware update! Not a big update here but one to keep things going...

    Owen and I got an email that the Arduinome firmware was not compatible with Arduino 1.0. I am not able to test as I do not have an Arduinome handy right now but I think I have fixed it. Can someone download ArduinomeFirmware 3.3 form the source forge and verify it uploads with Arduino 1.0+ and that were all good? Thanks!

    https://sourceforge.net/projects/arduinome

  • Thanks for the update - it was something I was going to ask about as v3.2 wouldn't verify before. In the middle of building my Arduinome just now, but will give it a go as soon as I get to that stage.

    (Sorry, I realise that's not a terribly helpful reply!)

  • Thanks Joseph.

    @Arduinomers - Even if you have 3.2 on your nome, if you could test 3.3 we would greatly appreciate it. Just need to install Arduino 1.0 and try to upload the sketch. It should work, but if not you can always reflash 3.2. Thanks!

  • Hi Jordan,

    I think there maybe a problem with 3.3.

    The buttons were not registering when I was using 3.3. I was receiving the serial data into arduino, but I could not get Max to receive the button pressed. I could however, send messages from Max to turn the LEDs on.

    After trying various things for weeks, today I tried 3.2 and the buttons are now behaving as I would expect!

    Please see this thread for more details:

    http://post.monome.org/comments.php?DiscussionID=13863&page=1#Comment_168698

  • Hi Jordan (& Owen),

    dgrizzle seems to have found the solution to both his and my problems. In the 3.3 update the "Serial.print"s need to be changed to Serial.write"s (as well as taking out the "BYTE"s) then it's all good.

    This also confirms that it can be done using a Mega (at least up to the monome_test stage) - looking forward to trying out some proper apps.

    All the best,
    Jo

  • wow! nice catch guys. We'll fix that right away.

  • crap, I totally knew that but forgot! Sorry :) oops.

  • Cool guys 3.3a is up, hopefully that does it. Let me know! and sorry again!

    Best,
    J

  • hey jordan,

    3.3a works with arduino 1.0!

    thanks for the fix.