Pages midi routing to Live?

  • I'm trying to set up pages to send MIDI note messages to Live and haven't had any success yet. Clip Launcher works fine, and I got MLRV working via pages. But, I'm not sure how to properly route the midi.

    In Live preferences I have the MaxMSP MIDI ports enable for track on port 1 and sync for port 2. I've enabled the MIDI inputs and outputs on the global level and page level in pages, but no MIDI info seems to be getting to ableton.

    Can anyone help?

  • you also need to select midi in/out in each page. per page.
    *edit, whoops you've already done that

  • hi jesse,

    do the maxmsp midi ports work like IAC devices or any other virtual midi port? i'm honestly not sure, but IAC devices should work. try those out and see if it makes a difference. you can google 'iac driver' to watch a video on how to enable them. if you're on PC then i've found LoopBe to be good, and midi yoke works as well but sometimes i have to disable/reenable the devices in ableton for them to start working.

    sounds like you're doing the right stuff though. are you getting sync from ableton?

  • Everything seems fairly self-explanatory, that is why I'm confused that I'm not getting any MIDI into Live yet.

  • Thanks phortran. IAC port seems to be working.

  • One more quick question. What would be the best page or application for sending chromatic midi notes? I would like to try using the pattern recorders in pages with drum racks in live and those are easier to use with sequential midi note numbers instead of scales. In the MIDI Keyboard page I can set the scales to 1,1,1,1 etc, but I'm not sure how to have it cover all 128 notes in order.

  • i'm having trouble getting a second MIDI output page working. i have the MIDI faders set up fine, but when i try to set up midi keyboard through another IAC MIDI Bus i get nothing. the little light in the top right lights up when keys are pressed, but the midi monitoring in the i/o dialogues show nothing... any ideas. (all the cofigs are right for the i/o in live and as far as i know in pages)

  • I was having the same issue when using a MaxMSP midi port, but it worked fine with the IAC port. Could you use IAC port 1 and just put it on a different MIDI channel?

  • or you can just make a separate iac port altogether, thats what i do...

  • Hello,
    First off, happy holidays everyone. It seems that St. Nick has brought me some frustration for the holidays. I was wondering if anyone could offer some advice regarding the MIDI sequencers and MIDI keyboards in Pages. It seems that I'm having the exact same issues as charlestonpatrick was a couple months ago with pages and sending MIDI to Live. I've got the MIDI faders set up and working and everything else seems to be working properly through IAC buses, but I'm getting nothing in the midi monitoring. Any insight into this would be most appreciated. Thanks!

  • hi down&down, there are some strange issues with pages and IAC devices and ableton in particular, sometimes you can see the notes coming in to the midi monitor but it just won't trigger anything. i'm actually working with a friend at this very moment to track this down but we've been trying to figure it out for awhile now, so not really hopeful that we'll get it solved right now. basically it's very similar to this:

    http://forum.ableton.com/viewtopic.php?f=2&t=137143

    rebooting seems to fix it temporarily. very weird and annoying issue for sure.

    edit: we just verified that the midi timestamps i'm trying to send aren't translating for some reason, midi monitor keeps coming up with zero, so maybe we're on to something here.. will update if i find out more

  • @phortran
    Thanks so much for your response and for this fantastic application! I'll give the reboot a try and see if that fixes it.

  • sure thing, i think i have this fixed now if you want to give it a try:

    http://monome-pages.googlecode.com/files/pages-0.2.2a28.zip

    i haven't verified yet w/ my friend but i'm pretty confident this will do it. let me know.

    edit: verified it is working when you also have libmmj installed:

    http://www.humatic.de/htools/mmj.htm

  • i'll have to try this out soon :-) thanks @phortran

  • great! also, new version available:

    http://monome-pages.googlecode.com/files/pages-0.2.2a35.zip

  • ay...
    glad i found this discussion...
    im running into some MIDI weirdness with pages...
    basically, i got 1 page... (midi triggers)
    im using this as a serialosc to MIDI translator basically...
    (there is not really a decent 256 to MIDI thing at all.....)
    that, and i really dig the pattern recorders...
    each one of my songs is a separate ableton file...
    when i switch songs... i almost always lose MIDI LED feedback from ableton...
    so, atm i need to load a new ableton file and quit and reopen pages and configuration for every song...
    hella weird...
    not sure if this can be fixed....
    im having thoughts of putting my entire set in 1 ableton file...
    but this would most surely be a massive disaster, with levels and panning and midi mapping on (i did the math.. haha) over 2800 clips...
    not sure that would even help much...
    anyway....
    any ideas homies???
    hollerize!
    thanks a lot!

  • hey edison, did you try installing that libmmj library? that might clear up the issue, that or possibly a java update are worth trying out. pages also might be crashing, can you try running it in a terminal and let me know what kind of output you get? run it like:

    java -jar pages-0.2.2a35.jar

    you'll have to be in the folder that the jar file is in. let me know if you get any messages when you close / reopen a new set.

  • yooooo dude...
    thanks for the instant response!
    so i got :

    log4j : WARN No appenders could be found for logger (socket Logger).
    log4j : WARN Please initialize the log4j system properly.
    log4j : WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.

    once the pages configuration is loaded, and OSC is listening on port 12345...
    i get no messages when changing sets though...

    holler atta honky!

  • that all looks pretty normal, sounds like the midi device goes away or somehow changes when live opens/closes. i was hoping pages would choke on something so i would have an indication of this happening and could try refreshing it or something... doesn't seem like it's going to do that. one thing that might help is i finally fixed loading a config file from the command line / program arguments. so you could go:

    java -jar /path/to/pages...jar /path/to/configfile

    put that in a pages.sh file, make it executable and you should be able to just double click it to load your config. replace file paths with the right ones for your system. it should at least make it quicker to close/reopen. i'm guessing the java updates and libmmj aren't helping either?

  • yo man...
    so java updates... and libmmj didnt change anything unfortunately..
    as for the executable...
    now were way over my head...
    terribly sorry but im not sure what that means!
    haha
    think the best option here, is to revert back to monome serial...
    just rock plain old MIDI style...
    hadnt thought of that before...
    now to figure all that out..
    sting nasty!
    thanks phortran..
    you rule schools

  • sorry i was a bit light on details there, i was thinking to avoid having to hit file -> open configuration every time you could just pass the configuration filename in when you launch pages. you can wrap that all up in whats called a 'shell script' so it's just one icon on your dock/desktop that you have to click and your config automatically opens.

    it's just like how we did:

    java -jar pages-0.2.2a35.jar

    except you put it in a file named pages.sh and you add the configuration file to the end. so for example pages.sh might be:

    java -jar /home/edison/Desktop/pages-0.2.2a35/pages-0.2.2a35.jar /home/edison/Desktop/pagesConfigFile

    you have to use the full file paths for this to work. you also need a line at the top to start the shell program, so the whole thing is:

    pages.sh:
    ---
    #!/bin/sh
    java -jar /home/edison/Desktop/pages-0.2.2a35/pages-0.2.2a35.jar /home/edison/Desktop/pagesConfigFile
    ---

    just those 2 lines in the file. after you have that file ready, just drop to terminal and do (lets say its on the desktop):

    cd ~/Desktop
    chmod +x pages.sh

    that makes it executable so you can run it. at that point you should be able to double click it to launch pages with your config file loaded

  • so,
    updaters...
    i downgraded to monomeserial..
    tried to run in just MIDI mode...
    full no note off disaster...
    so i am now running pages in conjunction with monome serial and all is bliss...
    not sure why...
    but all things are working great now..
    seriously phortran ... thanks you so much for the help
    stay up good dudes!
    holler

  • so weird, glad to hear it works though!

  • yea man...
    dont ask me.... i just work here...
    ha!
    thanks!