tml - tehn micro looper

  • @ tenmen

    I would be great, if you share your 4ml-port for tml.

  • hey guys, sorry i've been quiet, have been travelling alot.

    i sorted out the momentary/lapsing record button this morning. Bit of tweaking in the morning, and hopefully can release tomorrow.

    M4L I haven't looked at for a couple of weeks, but if there's demand I'm happy to.

  • @tenmen: any ideas/progress on a sync to transport feature?

  • new version of tml is up...


    added momentary/latching record functionality

    head over to for the download.


  • @ tenmen
    the download link for v34 give me an error: not found

  • @sepp fixed, thanks!

  • also, as i'm a man of my word, i just upload the max for live port.

    please note however...

    channel routing is so poor in m4l I actually find this inferior to using the max version in combination with rewire/soundflower


  • Thanks! looking forward to trying it out soon.

  • this is really weird, but all of a sudden the record button is not working for me (i have max 5). i can see my input on the meter and hear it in my monitors, but the button doesn't work like it did a couple of weeks ago when i last used tml031beta. any ideas here? i've tried rebooting/restarting/recording that input in live (works)/loading samples (works)/trying different channels.

  • I'm having the same problem with the M4L patch. Using Max5. input is fine, voice focus works, but none of the other buttons work and Arc2 isn't doing anything.

  • @goiks/rj

    sounds like we might have a max5 compatibility issue here. has anyone got this successfully working on max5 or max6?

    i've got both at home, but i only tested on 6, i'll take a look at this evening and see if i can replicate. sorry guys!

    also, @goiks, was just co-incidentally looking at your cases last night - great work man!

  • i was playing with this successfully on max 6.

  • thanks tenmen, glad you like the cases!

    also, if it is a compatibility issue it may be the excuse i need to upgrade.

  • @all i'm sad to say that it appears this isn't max5 compatible. my grid and arc look normal, but audio isn't behaving as expected.

    unless anyone has a very strong opinion, i'm going to leave as is and request that everyone upgrades to the max6 runtime, it's free!

  • thanks for checking tenmen. like goiks said - an excuse to upgrade!

  • i can't believe this whole thing slipped by me somehow. amazing work tenmen. your video is going up on the front soon.

    i'm working on the keyless arc hack-- i'll mod the most recently posted version here.

  • Do u have to own an arc to use this app? Would love to do some guitar stuff with this app but only have a grid don't own an arc.

    Is there a way to adjust loop length,start/end points on the grid itself?
    Will the app run without an arc connected?

  • Funky issues here w/ TML and TML refactor.

    1) Only the first two dials of the arc seem to be working?
    2) There is only one position where dial #1 plays back any sort of signal (3 o' clock with the cable pointing up)
    3) even if I record just a finger snap, it appears that the recorded part is much longer (e.g. 6 seconds?)

    TML 35 refactored:
    arc#4 goes nuts when turned all the way "up" - i.e. when all leds are lit. For lack of appropriate words it "stutters" when moved, but all leds are off and light up only when moved. It returns to normal only when all but the last led are on. I have the same playback issue as above... it's like searching for a needle in a haystack, unless I fill up the whole buffer.
    To sum it up there is no way I could manage to do anything on the fly like tenmen is doing (besides his obvious musical talent)

    Thanks for any tips and pointers


  • I can't get TML to work for me either. It says my arc and grid are connected, but nothing works. Other apps are working fine.

  • @Uncle_GroOve and @blungo2

    I can't speak for TML25 as i wasn't involved with the development, but I'm happy to try and get to the bottom of any issues you're having with the refactor?

    First of all, what version of Max/Runtime are you running?

    I remember the 4th (volume) dial would start to look nuts if you turned the level beyond the maximum even though it wouldn't actually affect the volume at that point. However I think you're saying the 1st dial basically is always representative of the full potential buffer, regardless of how long the audio if you've recorded is. Have I got that right?

    I'll have a rummage tonight and make sure I'm on the latest version of everything and see if I have any issues.


  • Currently i'm using the latest version of Max. I haven't tested TML with it, i'll give it a shot.


  • Same as before, the dialog boxes say the monome and arc are connected, but nothing lights up/works.

    I'm on Max 6.1.3

    Here's a screen shot of my max window

  • same problem monome & arc are connected, but nothing lights up/works...

  • I can't seem to get this to work, and I was wondering if anyone could help me out. I believe I'm following the instructions, as well as what I think I'm seeing in the video:

    Selected my grid (128)
    Selected my arc (4)
    Enabled DSP
    Selected my input source (I've tried both the built-in speaker on my MacBook Air as well as my Apogee Duet 2) and seen input meter activity
    Put voice one in focus by pressing the button in row 8 column 1
    Pressed and held the record button in row 7 column 1
    Enabled voice one by pressing the button in row 6 column 1

    I don't see any meter activity in rows 1-5. The arc is responsive, though I hear no sound. I have the output volume turned up. Am I doing something obviously wrong?

  • same problem @rratleph