SevenUp 2.0.5d (UPDATE posted 08/02/2012)

  • !!!!!!!!!!!!!!!!!!!! IMPORTANT NOTE !!!!!!!!!!!!!!!!!

    .alp file from 2.0.5 did NOT have the latest bug fixes in the .amxds

    You can also just drag and drop the .amxd files from the ./components folder in the distro over the top of the ones installed from the .alp file.

    Seems that the .alp was NOT updated properly in 2.0.5 which has led to a lot of confusion.

    Fixed distro is here.

    Also added a fix for broken multiintensity led support that was broken with new serialosc version.

    Go get it!

    Adam helped test and bless this final version and also updated the site and documentation. Documentation is much more serialosc focused.



    7up supports MAX5 and MAX6 now.

    - Two versions of SevenUpCore. SevenUpCore from 2.0.4 is now SevenUpCoreClassic
    and has old style connection dialog. This version support use with Monomeserial,
    and all routers that were designed to work with v1 protocol. New SevenUpCore is
    designed to work with serialosc and v2 protocol. You need to install zeroconf MAX
    externals for your platform first. This connection is very slick as monomes are
    autodetected on the network and configured automatically including detection of
    monome size. Rotation, intensity can be altered on the fly while running.

    - Added velocity support to Melodizers
    On melodizer 1, midi input to ch9 on track that SevenUpCore is in will record
    notes to pattern recorders. Velocity will now be recorded as well.

    There are three custom OSC protocol messages specific to 7up and not included
    in the monome osc protocol.

    For v1 classic protocol these are

    /refresh - Force 7up to redraw the entire surface, rather than the
    standard draw mode that only redraws what has changed. This was needed for
    manta support, because we move the draw window and need a way to force a full

    Multi-level led support for v2 monomes. Monomes that support multi-intensity leds
    can use this mode which is very friendly on the bandwidth since it trades fast
    blinks for led levels. Current pattern still fast blinks. Record enable still
    slow binks.

    - Added Manta Support. Must have a v2 Manta with dual color leds. Choose mantav2
    from SevenUpCoreClassic pick list. Must drop Manta7up.amxd into your Live set
    somewhere. Choose "connect" to connect to the Manta first before starting 7up.

    Tilt support added for serialosc

    /xpress x y v - Same as /press but with extra param for velocity.
    if you send osc button press messages to SevenUp and add an extra integer OSC
    param at the end, SevenUp will interpret this as velocity input.
    This is how the manta patch works, an app could also use an ARC or encoder
    to modify the velocity range and send this with button presses.

    The messages are slightly different when using v2 serialosc protocol since the
    path look slightly different in v2 messages.

    /grid/xkey x y v


    Fixed tilt support for gs128. For some reason the protocol type tags were
    different for the gs128. Anyway, it works now.

    Fixed loop recorder bug where choke group interactions were not being properly

    Fixed SevenUpCoreClass host/listen port configuration did not allow for ports
    above 9999. Now can go up to 40000.

    Fixed clip launcher being a resource hog by not polling anymore but using
    observers instead.

    Users wanted blink modes switched on clip launcher since fast blink was used for
    all inactive clips and that meant lots of blinking and almost unusable. So now
    the fast blink is for playing and solid for not playing.

  • Also updated the wiki to point to this version and list the app as supporting serialosc.

  • you (and adam) make me so happy, bar|none.

    thank you for your contribution! can't wait to try it out
    when i get back from work.

  • Thank you so much. Means a lot to hear it.

  • nice, will check it out next week when i'll have some time.

  • thank you for making this work for 5 and 6 because monomeemu does not seem to work in 6 yet.

    Thanks again for all the hard work fellas.


  • hey bar|none, outstanding !!!! velocity support for meloodizer: yay :))))

    thx so much for this

  • My monome is connecting according to SevenUpCore but I'm getting no lights or button control...

    For different reasons I freshly reinstalled Lion and have everything else set up right I believe (ftdi, zeroconf, max6, serialosc, ableton 8.2.7). Monometest works perfectly. I followed the sevenup install protocol to the t (fresh install, copied files into /lib/ folder, installed live pack, opened live set and manage projects / export).

    I open a new set in ableton, drop in the SevenUpCore (not classic) into a midi track, and it already sees my 256. I press connect and it connects and start/stop button in Core automatically is toggled on (orange). But... no lights (such as the startup 7s when I was using previous versions) and no control.

    pressing test in SevenUpCore does turn on all the lights and clear turns them all off...

    Any ideas?

  • Are you sure it's your 256 and not mine, left over in the dialog? Mine is m0000146.

    You should do the standard right click the title bar and open MAX window. Also double check that the zeroconf is actually there, when you upgrade MAX the externals don't move automatically.

    One thing to try is to hot connect and disconnect the monome and see if the list changes in SevenUpCore, if not then probably zeroconf missing or serialosc not running. This list doesn't update unless zeroconf is running.

  • it registers as m256-202 (mine). sees my arc4 too... hot connect and disconnect changes the list in SevenUpCore...

    here's a paste from the max window.

    won't let me copy/paste from max window but when I drag SevenUpCore into a midi track max window has a red line "could not load class "mtn.sevenuplive.max.msj.Sevenup4Live"

    When I press connect I get 4 "binding to port"s then object = zeroconference and message = Service published: /7up 30834.

  • Well this is the problem

    "could not load class mtn.sevenuplive.max.msj.Sevenup4Live"

    Can't load the java jar files. They must not be in the correct location or not all there?

    /Applications/Max6/Cycling '74/java/lib

    SevenUpLive-v2.0.5.jar core.jar jdom.jar oscP5.jar proxml.jar jitter.jar jode-1.1.2-pre-embedded.jar max.jar

    You sure that your copy of Live is pointed to the correct version of MAX? That is set in the Live preferences? Not some older install or something?

  • you're right, live was set to old max... pointed to new and works like a charm.

    sorry to waste your time but thanks for the help!

  • Ah, made the same mistake myself. Glad it's working.

  • Can someone please help? I can't figure this one out.

    I can't seem to connect my arduinome to sevenUp. Please have a look at these screen shots. For some reason, the seven doesn't appear in the sevenUp core box as shown in the setup instructions. Has anyone seen this before? I was having this problem with 2.0.4 as well but occasionally it would work. I don't know what I am doing differently... Any ideas?

    Macbook pro OSX 10.6.8
    Ableton live 8.2.7
    Arduinome 8x8 (64)

  • I connect my 256 to 7up core, and everything seems to work just absolutely perfect, right until I click in any other track and it all disconnects. no communication between my 256 and 7up-core, and all the LEDs turn off.

    Running the newest live, max 6, osx lion
    installed zeroconf objects and serialosc 1.0


  • @dgrizzle this is 2.0.4. or classic mode 2.0.5
    Use the default ports 8000 8080 not the 1024 I see. Forget the autoconfig button.

    This was a problem with 2.0.4 and MAX 6 fixed in 2.0.5. Make sure no 2.0.4 jars left in install.

  • Got 7up live working on 10.6.8. Amazing program, every single page works flawlessly. However if I save a live set, re open it then click on start/stop. It doesn't comunicate with live instruments. The strangest part is that all the lights still work.

    Im using: SevenUpCoreClassic, Livid Block, monomeBridge, Live 8.2.7, Mac 10.6.8.

    Here are some screenshots of my setup and an image of a melodizer setup so you can see ive got it ordered properly.

    882 x 245 - 66K
    662 x 430 - 89K
  • Why are you using monomeBridge?

    7up 2.0.5 communicates directly with serialosc and does not need bridge as a translator.

    You have to use SevenUpCore and not SevenUpCoreClassic.

    It's a ton easier that way and much better performance too.

    Make sure to follow all the install steps from makingthenoise site.

  • I have a livid block. the only two options that show up in SevenUpCore are 128 and 256. Theres no 64 option. I cant connect to either of those. I assumed i couldn't use SevenUpCore, i thought i could only use SevenUpCore Classic. Ive installed all the drivers, zeroconf externals, serial osc.

    Is there a way to make sure serial osc is in fact running? thats the only thing i can think of.

  • Ah missed that fact.



    ps -ef | grep serialosc

    ps -ef | grep serialosc
    501 220 143 0 Sun07PM ?? 0:00.31 /usr/local/bin/serialosc
    501 7466 7444 0 8:24PM ttys000 0:00.01 serialosc
    501 7491 7468 0 8:24PM ttys001 0:00.00 grep serialosc

    Do the presses work too?

    One thing can happen in Live is audio interface disabled (orange bar at bottom). If that happens then no communication will happen between the instruments.

    Check audio settings in Live? Only thing I can think of.

  • sorry which fact did you miss?

    In SevenUpCore Classic, all the presses work until i save and try to reopen. Then the buttons light up but presses dont work.

    In SevenUpCore, I dont even see the livid in the drop down list.

  • I missed the fact that you are using a Livid Block.

    So it can emulate the old protocol hence the need for the monomeBridge and SevenUpCoreClassic, so you did the right thing.

    I don't really know how to diagnose it except that if presses aren't working then it's the inbound port that has an issue.

    You can right click on SevenUpCoreClassic and choose "Open MAX window" to see log message, there might be a clue there.

    Sorry this is the first tech question for a Livid Block so I really don't know what can go wrong on their side.

    I know the launchpad can't handle then led fresh rate from 7up and I think Livid block had similar issue. Is there any info on the Livid forum?

  • @barnone

    there's no 2.0.4-jars left in my max 6 lib folder now, but the problem hasn't changed. hm. weird

  • Which version of MAX is Live Preferences pointing to?

    Also it's not just the jars, the amxd's from 2.0.4 as well, all the M4L components.

  • it's Max 6.0.4 that I use for m4l together with Live 8.2.6

    I've deleted everything on my computer that's not the jar- or m4l components that belongs to 7up 2.0.5, but it still does this.

    I just tried opening 7up-core and when I have it running like this, with max open, the problem is gone. this is pretty weird, huh

  • Oh man you just found a major problem with the packaging of the release.

    The components were not updated inside the Template project. Therefore if you installed using the Template Project which is what we recommend, you'd have this issue.

    Thank you for finding it. We will put up a new version ASAP.

    This is also probably why a few people have reported bugs with clip launcher that I knew were fixed. Yikes.

    Easiest way to get the correct versions are to drag them from the ./components folder in the distribution into your set.

    I've also posted a temporary fixed version of the distro here until I can get Adam to update the site.

    Mind reporting back on whether that fixed it?

    The components affected are


  • ahh, yes!

    working like a charm.

    best app ever by the way.

  • Cool. Adam is at SXSW but will update main site in the am hopefully.

  • Ok, updated

  • Thanks again for this update I've been looking forward to using this program for a long while. Problem: I did the update and when I load the seven up core on my imac (10.5.8) I do not have the option of choosing the monome 64. I only have two choices a 128 and 256. I did the same installation on my mbp with lion and had numerous options available (chained monomes etc). Any thoughts.. I tried a reinstall and nothing.

  • If you are using SevenUpCore in 2.0.5 then monomes are detected through zeroconf. Therefore zeroconf needs to be installed via the 2.0.5 installation instructions. Serialosc needs to be running to detect your monome.

    The old way of choosing from a big list of possible monomes is accessed via SevenUpCoreClassic and only works with Monomeserial. I would definitely try to use the new way as it's a lot better in the long run.

  • Thanks Bar/None (btw this is syzygwell on muffs) I have everything set up with my monome on serial osc and it works with all the other programs such as polygome etc. But to be clear you are saying there is an extra step with zeroconf that I need to do with the 2.0.5 installation?

    I already have the serialosc running and my momome 64 works with all other serialosc compatible programs at this time.

  • Hey there syzygwell.

    I guess that step is easy to miss since under requirements section.

    "SerialOSC installed and running. Be sure to follow the instructions and install all necessary prerequisites. The zeroconf MAX external must be installed for your monome to be discovered."

    There is a link there under SerialOSC and that links to zeroconf page. That's a bit obscure isn't it?

    Here's the zeroconf page. You want to install the max external for your platform.

  • I think I have a different problem. all mxo files are in place with the zeroconf installation. I bought the walnut 64 edition a year ago when serialosc was brandnew and have just been waiting to use this program without the bridge.

    So my monome is found by other serialosc programs. Its just when I open the seven up core midi file it only allows a selection of 128 or 256 (neither of which I have) a monome 64 isn't even a choice in the selection field.

    I've further checked the user/Library/Preferences/org.monome.serialosc/(and here is my monome id)

  • The 128 and 256 are likely mine. If they are still there and your is not and serialosc is running then it points to zeroconf issue.

    Are there multiple installs of MAX on your machine? Is it possible Live is not pointing to the version of MAX with zeroconf installed? You can check in Live Preferences which version of MAX is pointed to.

  • interesting I had two versions of runtime, one in a seperate folder just beneath the max folder in applications. (I think I installed that yesterday when I did the update but recall I was having the issue before the update) When I checked the midi preferences on ableton I had two max runtime options on in/outs.

    The original max/max runtime folder has the proper zeroconf files. I deleted the extraneous runtime folder and now no runtime options show up in the preferences midi plane in ableton.

    and the same problem persists. I can't see that I have two versions of Max installed however. I have M4L within ableton (v2.2) and the max folder in apps when running serial osc apps outside of ableton such as polygome or whatever.

    is that possibly where the problem is?

    I'm going to try moving all the files from my mbp to the imac and see if that somehow makes a difference because somehow this computer shows the Monome 64 with my ID number. Though I did the same installation on both machines.. just weirdness.

    eta: well that didn't work so it isn't whatever is in the other folders from the max install under apps.

  • Yeah I really cannot figure this out. I did the exact same installation on both computers and its runs fine on the mbp but my main music computer the imac not so much.

    I have one instance of Max/maxruntime that I can find on my computer. In the Ableton/Pref/filefolder it points to Max in my application folder. I actually went back and uninstalled/reinstalled serialosc because I noticed a weird issue with the lo port setting in the terminal. although I have no problem connecting and when I check the monome ID in the user/lib/prefs its only my monome listed.

    However when I go back to seven up its the same thing:
    Monome 128 (m128-400)
    Monome 256 (m0000146)

    So here is my question. If monome/serialosc programs external to M4L connect and run correctly and my M4L programs that utilize the monome connect and run correctly. What is different with Seven Up that it won't?

  • Hmm. Yeah those are my monomes you are listing, so they would normally be refreshed with yours.

    The big difference between in M4L and in MAX is that you need a valid M4L license and also it depends on the version of MAX that Live points to in it's preferences.

    Also, if your audio interface is disabled in Live, then M4L's communication including OSC is disabled until the audio is reenabled.

    A few things to try.

    1. Right-click title bar of SevenUpCore and choose "Open MAX Window". Paste the contents or screenshot of that into a post.

    2. I created a bare bones M4L device that uses the standard serialosc connection method.

    Download it and drop it into your set and see if you can see your monome.

    3. Click the M4L edit button on SerialoscTester.amxd. Make sure the version of MAX that you think should come up and that has zeroconf installed does.

    Open one of the external monome apps you say works from here and see if it does.

    That's all I can think of for now.

  • ok odd. This fixed the problem. Just so you know I opened up the max window and could see two zeroconf issues highlighted in pink. Something like unable to load executables in browser and something else I can't recall. Anyway I loaded your serialosc tester and had the same issue. Then I opened up the max editing window and hit connect from there and suddenly it read my monome which seemed to clear the issue for both programs.

    bizarre but thank you for helping out. I still don't know what was wrong but if that fixed it hey I'll leave it in the mystery bin.

  • yes!! mystery bin is fine with me. that was bizarre.

  • Thanks so much for this man..

    I love 7up its brilliant..can't wait to get out of work and try it at home!

  • gaaaah. More problems. Hopefully this one will make more sense. My monome is still not showing up when I try to connect Seven Up however I have a new error. It looks like this now (see attachment) . Instead of a Zeroconf issue Im having a port issue.

    437 x 428 - 58K
  • Well the binding to port is still zeroconf with serialosc. Looks like something is already bound to the port.

    Is another monome app trying to connect via serialosc? Say a MAX app or something?

    You can try restarting serialosc. Also a reboot does wonders for stuff holding a port that shouldn't be.

  • I didn't have any other apps open. I do have max/max runtime installed as well as m4L. not sure that should create this type of issue but in any case those are the only two instances of max and again I just had ableton open trying to use 7up.

    So I'll give that serial osc a toggle. should I just run the stop and start configurations in the terminal?

  • I had the same issue with selecting a track and losing connection with my monome, so I loaded from the component folder. In doing so, I keep my connection and I can see the stepper cycling with the 2 LED's active on the right, but i get no response from pushing any buttons. It appears active but doesn't respond to touch. I've replaced any trace of a previous sevenup install including all of the .jar files. Any suggestions? I'm using:

    Max 6.0.3
    7up 2.0.5
    Ableton 8.2.5
    Greyscale 64

  • I've got a really strange problem.

    Some days SevenUp finds my monome and works beautifully, where as others, it just doesn't seem to find it so I can't connect to it. I've re-installed 2.0.5 completely and I made sure everything was deleted before I re-installed. I've tried running other programs that use Serialosc when sevenUp is being a bit dodgy and they run fine. I've tried restarting my computer and the problem still occurs. Strangely enough, I seem to have to wait about a day or so until things start running normally again. Any ideas how to fix this issue?

    Mac 10.6.8
    Arduinome 64
    Max 6.0.3
    7up 2.0.5
    Ableton 8.2.7

  • It would be worthwhile for everyone to check the osc_prefix in your monome's configuration file. Details towards the bottom. That would stop inbound communication, for example key presses.

    @deshazo19 @dgrizzle
    Can you paste your MAX log like @machina did? You have to Right click on the SevenUpCore title bar and choose "Open MAX Window".

    When you say doesn't find it, doesn't appear in dropdown or doesn't get 7's?

    I created a bare bones M4L device that uses the standard serialosc connection method.

    Download it and drop it into your set and see if you can see your monome.

    No button presses means the monome is not getting inbound communication from 7up. Have you tried stopping 7up, unplugging, replugging in usb for monome, then trying to reconnect?

    One thing that can be tried if there is a port issue is to unplug your devices, then delete the serialosc conf files for your device.

    [Chaos-3:~] chrislloyd% cd ~/Library/Preferences/org.monome.serialosc/

    [Chaos-3:~/Library/Preferences/org.monome.serialosc] chrislloyd% ls
    m0000271.conf m128-400.conf

    [Chaos-3:~/Library/Preferences/org.monome.serialosc] chrislloyd% rm m*

    This forces serialosc to choose a different set of ports when the monome is replugged in. You can also wait till it creates these files, then choose a fixed port yourself.

    for example

    server {
    port = 19086
    application {
    osc_prefix = "/7up"
    host = ""
    port = 33007
    device {
    rotation = 0

    Make sure prefix it /7up. For example, other applications may try to set it to a different value.

    The application port is 33007, I could edit this and choose 8002 or something else if I wanted. When I plug the monome back in, it will respect the port I choose.

  • bar|none,

    I unplugged and replugged the monome and success. Seems to be working great. Thank You!

  • Awesome, that's my technique as well.

  • Actually... I've hit another snag. I'm sure this has been discussed elsewhere, because I got the idea from a thread I read a long time ago, but can't seem to find it again.

    I'm trying to create a chain for a live set that would include multiple instances of looper. The problem is that I can't get the chain to distinguish between the separate loopers. I trigger column 1 and every instrument starts playing the sample assigned to column 1 at the same time using the last device in the chains length parameters. I suppose I could solo the instrument in the chain I want to use for that song, but each sample is a different length and I need instrument to recognize those settings.

    Is this even possible or did I dream of reading a forum with this idea?