mash (2)

  • and now?

  • please respect that i don't want to release something unfinished and undocumented and be plagued with questions and bug reports.

    thanks for you patience. it shall soon be rewarded.

  • Sorry for spaming stevie... I was meant to be sarcastic.. It's quite cheeky and unnecessary to urge a developper to release, spending hours and hours with patching and debugging and give it away for free...


    Take all the time it needs of course!!!!!!!

  • @l00p no worries.

    it's nearly there. just putting the shine on a few things/thinking over a few things that don't work very well..

  • in the cyclical fashion represented in every aspect of life the perceived release date of mash may also coincide with its own previous release date creating yet another decemberine birth-miracle let us all celebrate



    ...
    riverun

  • cracked probably the biggest bug that was holding this back.
    took some fairly severe actions to find it.

    putting it back together again.

    carefully....

  • so close - last year's best xmas present looks like being this year's too...

  • inside my creamed jeans is a creamed jeans demon whose own dreams were creamed by the creamed jeans demons' creamed dreams creamery

    am excite

  • mind if i ask what bug was squalshed so as to get the taste of soup out of my mouth?

  • the patch now runs with both vector settings set to '64' and with overdrive and audio interrupt 'on'. this is on my 4 year old macbook. possibly get better on newer machines.

    this i found was the main hurdle to getting the pattern recorders to function correctly and not loose timing and accuracy.

    without this any higher vector settings would result in unstable pattern recording with interrupt 'off' and audio transients with it 'on'. or they would function fine until the transport was initiated.

    basically replaced some audio objects that were i think wasting a bit of processing. also decided to drop the VU style meters on the volume faders on the monome interface for now at least until i can figure a more efficient way of doing it. pretty sure it was flooding the scheduler.

    the main test i was doing for this was to record some audio then engage a pattern recorder. press a single button in that row and then press the pattern recorder button quickly again to loop it. the result being a metronomic pulse. then hitting the tempo/beats button once to start the transport and have the very short pattern loop be the tempo. this is now working well

    recording, patterns, quantizing seems to be running tight as james brown now.

  • ^^ taking things very seriously ^^

  • Sounds absolutely awesome! Can't wait to play!

  • Mash... I've been drooling... Mash 2.0 is compatible with Serialosc right?

    Can't wait...!

  • Ahhh with University over and done with... mash will hopefully take up most of my time in the new year... can't wait!

  • all i want for my birthday today is a pile of mash'ed pickled loops

  • So for valentines, MASH will make our hearts swoon.... we can all dream of true love!

  • Just wondering what the ETA is on mash 2... I'm itching to start getting into it!

  • Hi, i really love MASH.

    Will there be a monome-serial version of Mash2, too?
    I would really appreciate this!

  • Mash makes my liquor
    Makes my liquor
    Make my liquor

  • i don't get it.
    Let me tell a simple example.

    i start mash. empty.
    set input, etc.
    i press button 1 while playing keyboard with the right hand. the press again, it loops. Working fine for now, got my loop playing in the first row.
    Then i tap tempo (some audio glitching doing this, but, anyway).
    i drop a drum loop on the second row.
    i can play the both rows in sync. Perfect.
    Then hit button 1 again, my keyboard loop stops. Normal.
    Now i wanna record a new keyboard loop on the first row.
    i do the process again.
    Strange result, it doesn't replace it by the new loop, but keeps the first one in a strange way.
    Help ?

  • not gonna drop any dates for mash2 till I know I can hit it.

    still working away. bugs.. glitches... dealing with an aging computer....

    initially mash will be for serialosc and max5.
    though with some of the tidier things happening in max6 I expect it will move there pretty quickly.

    don't know if I'll bother with a monomeserial version.
    aren't we all moving on?

    @chapelier fou that doesn't sound right. maybe try resetting a couple of time before starting.. audio glitching might require tweaking of larger vector sizes..

  • ok i'll try.... a reset per row should be cool.

  • @stevie
    You know I love you.

  • regarding monomeserial:

    If you look at Raja's MonoMahna2
    http://www.rajatheresidentalien.net/_MonoMahna_WIN.zip

    He integrated monomeserial & OSC in the same app.
    Maybe that's the way to go?

    I can't use serial OSC, so I would be stuck with mash 1 :-(

  • I thought all devices can use serial osc now?

  • not if you can't afford one & you're stuck with a launchpad + emulator :-(

  • @stevie :
    Clicking "reset" a few times before starting actually solves the problem ! is there any particular reason for this ? i mean, will it be reliable ? (planning to do a live performance with a harpist in two weeks).

    i still need to midify the mixer session (according to me, it's unusable as it is for now)

    YEAY ! Thank you !

    louis

  • @trppng: I see your dilemma. will think on it.. I think a better way forward would be for someone to bring the emulator into serialosc though..

    @chapelier fou: I haven't worked with mash in a while. though i used it live many times occasionally it would lock up and no more button presses would get through. I usually kept a loop pedal for backup while restarting max/msp.

    yeah the mixer isn't the best on the monome.


    its such a mess in there that i've been rewriting as mash2 for about the last year....

    and no it's not ready.

  • while not in time for valentines i've got 2 weeks free for development around the end of the month. expect to get this into yer hands.

  • This is gonna drive me crazy.
    Mash 2 + Octatrack + Cirklon the same month....and then back on tour and will have to leave this little family at home !

  • whoa wicked!!! Looking forward to it!

  • bump for a sickkkkkk patch.

    mash is my new favorite looper!

    many thanks and exciteee about mash 2.0

  • also, stupid question.

    is there a way to permanently save the custom color scheme that i make?

    when i quit and reloaded mash, all the colors reverted back to original.

  • I'm bumping this too... excited for this patch.

  • I've only just come across mash and it does exactly what i want it to do! However i'm stuck on a few things that are really frustrating me.

    Firstly, does the tap tempo work? I press it and the sound doesn't seems to change, but the bpm in the patch just gets higher and higher with every push. Am i doing something wrong?

    And when I record a sample, how do I set the loop length? Sometimes I will record something and it till only play on the first button of the row and then nothing for the rest of the buttons until it comes round again. I can't figure it out and it is quite annoying. Can anyone help?

    Thanks

  • (if I remember right) The tap tempo is for telling mash the tempo of the first loop, which then controls the length of each subsequent loop. So you record your first loop, tap the tempo, and from then on, all the rest of the loops record for a length of time adjusted to fit the first loop. Which is why you have your second problem. All the loop lengths are relative to how you've set up the first loop and the tempo. It sounds like mash recorded for a lot longer than you thought, meaning everything you played only mapped to the first button.

    Hope that helps, I'm not good at explaining things in the morning.

  • ^i think the tempo button denotes how many "beats" your loop is and then figures out the tempo that way. its not a tap tempo in the traditional sense.

    so like if u have a 2 bar loop, u can hit the tempo button 8 times to set the tempo.

  • It's not a tap tempo. Use that button to assign a number of beats to the first loop. So if your first loop is exactly four seconds long and then you tap the top right button two times, the tempo will be 120bpm. And if you press it two more times at any point, the tempo will change to 60bpm.

    If you record a first loop and hear it in your head as two measures, press that button 8 times (doesn't matter how quickly you press it), and mash will know how to distribute the rest of the loops you record.

  • Whoa! this is great information. I had no idea the number of taps was important. I've probably screwed my self up by tapping the tempo too many times before recording a loop.

    Is there a button on the monome for reseting the tap button to start fresh or is it the Reset button you have to click on the app?

  • Ok, that's interesting. I've tried having another go with the tempo/beat button and I'm getting strange results. So I first play in an 8 beat guitar loop, hit the tempo/beat button 8 times. All seems fine. However, when I record a second part of say 16 beats, I'm finding that I can't hear the second loop and the light moves across really slowly, one light across every 32 beats. At the moment I'm finding that if I do not touch the tempo/beat button, I am getting better results, but I have a feeling that I am going come across further problems if I use the program in this way. Any other input?

  • @egon just global reset iirc

  • @dgrizzle It's finicky; I never got the most consistent results.

    Aside from waiting for mash2, you're going to have to spend a lot of time just trying different things to discover all the quirks you might run into. And read back from the beginning of this thread to find some which have already been established. For example, it helps to click the global reset button several times when you first open mash.

  • Would it work for the lowly APC 40? lol
    Love to try it.

  • I have just started using this with nonome on my launchpad, wonderful fun, thank you for developing this. Hopefully by the time my walnut 64 comes I'll be a bit more proficient with the interface (which is, admitedly pretty easy to get grips with, even for a newb like me!)

  • Hello.

    I love this app..it seems to be set up perfectly for what I want to do.

    However, I'm having major difficulty in that it crashes consistently after 5 or 10 minutes of play. So frustrating, because I love it so much and want it to be stable for me soo badly.

    Here's my setup.

    Monome 256 Walnut edition.
    Macbook Pro
    OS 10.7.2
    Serialosc unloaded
    monomeserial running
    /mash

    set up DSP Coreaudio routed to my Mackie Onyx 820i

    I don't see any posts regarding crashing, so I'm sure its something with my set up, but I don't have a clue what might be wrong and probably need some good samaratin to hold my hand through troubleshooting.

    Might it be something with Max6 or monomeserial etc.. Anyone have any ideas or suggestions?

    Any help would be greatly appreciated.

  • maybe try max5? not sure if max6 might be causing some issues?

    mine does some quirky things every now and again, but it doesn't crash (i'm assuming that u mean it quits unexpectedly?)

    and my setup is pretty similar to yours. except i am not on 10.7 and i have a walnut 64 and use max5 runtime, but i have the same mackie mixer and use it on macbook pro or mac mini.

  • that worked ringo wong, thanks.

  • awesome! glad i was able to helpp!@

    now getchoo loop onnn