Arduino firmware question

  • This might be a strange question, but in having difficulty getting the computer (serialosc or arduinomeserial) to see my arduinome whatsoever (on windows 7 64 bit pc) I was wondering about whether I was putting the arduinome firmware on properly.

    I've used flip to flash the 8u2s firmware. The arduino's device instance path in windows shows the vid/pid/a40h-001, so I believe that should be correct.

    For uploading the arduinome firmware 3.3a (most current from flipmu sourceforge hub) I open the arduino software (version 1.0), open the .ino file, verify then click upload. It uploads. Is that what I am supposed to do? I know that's how you load 'sketches' but is that just arduinome speak for firmware? Or, anm I doing that wrong and thus that is why I can't get my arduinome seen?

  • "verify then click upload. It uploads. Is that what I am supposed to do?"

    Yes, that's how you flash the arduino with the arduinome firmware.

  • i had lots of difficulty with this

    make sure you have the latest ftdi driver

    and make sure you do this:

    i might be wrong, but i don't think you need to use arsuinomeserial for anything anymore

    i.e. you should stick with serialosc and make sure both aren't running at the same time

  • @jamphandan

    The board in question is the Arduino Uno (not stated here, but in other threads), no FTDI chp involved.

  • Yeah, I've already put that in the serialosc folder. Just plain no luck.

    marto, it sounds as if you have a working arduinome connected to a windows pc. Is that so? If so, d'ya think you could pull up it's properties in the device manager and under details tell me what is giver for the device instance path?

    Mine is:

    Thanks for trying to help by the way, it means a lot.

  • At the moment I'm at work and don't have access to a working arduinome (it's in bits pending replacing the LEDs). Perhaps if you head over to the #monome irc channel ( someone there may have an arduinome up and running with serialosc, basically someone in a better position to help :)

  • Been on there a bit lately, will try again, thanks.

  • @marto/shimoda

    sorry, this is all still a little confusing for me.


    i think lots of people have had difficulty get their arduinome to work with an uno, myself included. i don't have an arduino at all (starfire clone) but i tried using an atmega chip that was supposedly flashed with uno obtiboot. after much frustration i gave up and bought a Duemilanove chip instead.

  • @jamphandan

    I presume the arduino duemilanove worked bettter? I'm considering buying one to see if it works and if it does, just buying two more for the 128 I'm planning to build.

  • yes, my 128 (well, two 64 clones) magically started functioning when i switched the uno chips for the deuemilanove ones

    i found flashed chips on ebay for pretty cheap but i guess you'll need a whole arduino (or three)

  • That's a bit weird since it seems as though the issue isn't the 328 but the usb part of the uno. Are you saying that you used duemilanove arduinos or just the chips from a duemilanove? The ftdi usb-serial chip is what seems to make the difference in having serialosc recognize the nome.

  • @shimoda

    i used a starfire logic board that has arduino components on it:

    so i'm only speaking of swapping out the atmega328 chip

    honestly, i had issues with the ftdi driver too so i'm not sure exactly what solved my issues, but i do know i had a heckuva time flashing the arduinome firmware using the "uno" 328 chip (i wasn't even getting as far as trying to get serialosc to recognize the nome)

  • Interesting. Flashing the arduinome firmware (sketch) wasn't a problem at all. I only know that it actually works as my wife's mac picks it up in arduinomeserial fine. What I don't understand is that serialosc on her machine still won't pick it up. That makes no sense to me since I haven't really heard complaints that arduinomes (with unos) won't work on macs.

  • you made sure arduinomeserial and serialosc weren't running at the same time (on your wife's mac)?

    i haven't used arduinomeserial at all, but i've read many times about people having issues when running monomeserial and serialosc at the same time (i'm sure you've read this as well).

  • Yes, I've actually uninstalled one or the other at times to insure they weren't running. That was aside from stopping services and whatnot. I tried serialosc on the mac before ever installing arduinomeserial. I really just don't get it but them's the breaks I guess. I'm still trying to figure this out on pc primarily because that's where I work and what I have. I have my main desktop and my older q6600 (still a nice quad core plenty powerful enough for music anything) for my shop studio. It's why I'd rather be able to have this running as the mac does me no good other than to make sure the arduinome is working.

  • well, i'm sure a lot of people would say it's worth getting a mac, haha.

    i'm still on windows as well. don't stop trying. there were plenty of times i thought about throwing in the towel.

    might be worth switching from the uno, though. i recall searching the forums long and hard for an example of someone on windows who had a functional arduinome with an uno. didn't find much help there...

  • I have a duemilanove on order. Unfortunately it is taking forever to ship... :^(