monome not being connected by serialosc

  • hey guys,

    Alright so i left monome community last year because of money problems and graduating college...im finally back!! i got a greyscale 64 and ive been trying to get it set up with serialosc and this is new to me..im kinda use to monomeserial. So my problem is that serialosc recognizes my monome (0691) but when its in a program i go to click connect and it does not do anything. i tried looking thru the forums and i spent most of my day yesterday and today trying to figure it out...i did the setup that is listed in documents step by step twice.

    im running windows 7 64 bit
    hp latop g62
    serialosc 1.0
    max 5.1 runtime


    let me know if u guys need any other information...i know basics of computers but not in depth stuff so bear with me :)

    thanks!!

  • thanks man! its good to be back :)

    and thanks for doing that hopefully someone can help me out....i did install the FTDI driver...i clicked the setup executable version 2.08.14 one...i got the link from the windows set up page.

  • any love? ive already pulled out the little hair i have on my head lol

  • does your device show up in the dropdown?

    any errors in the max window? download the full version, not just runtime.

  • my device does show up in the drop down box...which is why it is confusing! i have to go to the dentist right now...ill try that when i get back!

    i only get errors when i run polygome..

  • alright so i installed the full version and it still doesnt connect...it reads it in the dripdown box! here is a screen shot

    1163 x 475 - 80K
  • did you try all of the windows voodoo? ie. disconnect your network? firewall is off?

  • i did not try all of that stuff! i will give it a run thru and get back to you! thanks for the tip

  • @tehn...well you are a genious! i tried all of the windows voodoo and it worked!! many thanks :)

  • which one solved it?

  • im guessing it was the firewall one...i was confused with the instructions..i didnt turn the firewall off completly i only allowed max6 to have access...make sure u turn it all the way off

  • oh and i just figured out i need to have my wireless adapter off

  • I have tried disabling my lan and wireless, and my monome still does the same thing. It looks the same as the image that aPre has posted up above. I have also disabled my firewall and no luck.

    Any thoughts?


    win7 64
    max 6 Runtime
    samsung series 7
    Downloaded all the newest stuff from the setup guide for windows.

  • here's an image that might help...

    1680 x 1050 - 443K
  • thanks for posting the great screenshot.

    just to confirm, the issue is it recognizes but clicking "connect" does nothing?

  • Heh, thought I'd try to pack all the details in one shot. Only thing that I couldn't fit is showing that bonjour is also running.

    Yea it seems to recognize it, although it also has i2c monome in the drop down so I'm not sure if it is really correctly recognizing it. For the record it is a monome 64. And yes it doesn't do anything when I press connect.

    Let me know if there's anything you need. Thanks in advance!

  • actually I'm not sure it's recognizing it, because I started up maxrt/monome_test without the monome plugged in and the options were the same.

  • Those two pop-up monome options seem to be available in that version of the seriolosc.maxpat, I've tried it as well. Those will show up whenever it is run. It is likely that it isn't seeing the monome at all.

  • i only see one instance of serialosc, which may suggest the device is not being detected?

    can you run FTProg, "read" the eeprom to find our your serial number:

    http://www.ftdichip.com/Support/Utilities.htm#FT_Prog



    also, i fixed monome_test to remove the confusing default items.

    http://docs.monome.org/lib/exe/fetch.php?media=app:monome_test_1.11.zip

  • can someone confirm that arduinome support is even present in windows serialosc? i'm uncertain about the most recent version.

  • @tehn,
    as my arduinome is an uno, ftprog won't work. Under the properties page for my arduinome, on the details page, vid_03eb&pid_204b\a40h-001

    I flashed it using the hex file compiled and given by artfwo:

    http://post.monome.org/comments.php?DiscussionID=10201

    And added the libmonome.dll from visinin:

    http://post.monome.org/comments.php?DiscussionID=13221&page=1#Item_18

    I feel like I've heard about some people getting serialosc working. Maybe I'm mistaken.

    I have heard that a new version of serialosc is in the works that better adds arduinome support in windows. Unfortunately I can't get arduinomeserial to read the device on pcs, though I hope that a duemilanove will help since it has the ftdi 232 chip.

  • edit - shimoda is fast

  • @jamphandan -

    you edited jamp, so you have serialosc running? what arduino por favor?

  • again we're mixing up our issues so it's getting complicated.

    - arduinome support on windows serialosc in general.

    - arduinomes using an uno-- this may be a new frontier.

    - most importantly, what is going on with windows systems and zeroconf support with regard to serialosc.

    the FTProg suggestion was for secretL with his non-arduinome 64.

  • @tehn,

    apologies as I don't mean to be confusing. A few members have offered many suggestions and I've tried everything.

    *perhaps the windows/zeroconf thing is most important as it seems to affect all serialosc comm. issues on windows.

    My particular issue is regarding uno arduinomes but I may be the main sufferer of this. I've just posted on another thread to find out whether those who have had success with arduinomes and serialosc (bongo and bennito appear to be a couple) are using duemilanoves. If only you could find one last monome kit logic board under kelli's desk (;^)).

  • i feel like i should preface every post with my platform/nome version/etc., haha. sorry, i've been adding to the confusion as well...

    (i'm on windows xp and my arduinome uses starfire logic boards, no arduino)

    it's my understanding that visinin's version of libmonome.dll addressed arduinome support for windows generally (and it worked for me)

    it's my understanding that no one has (or not many have) successfully built an arduinome with an uno on windows (i couldn't make that work, although i didn't use an uno initially, but rather an atmega328 chip with uno optiboot on my starfire board)

    further, for the record, the zerconf explorer program did nothing for me either (this was mentioned in another thread recently)

  • i suspect the uno will pose many problems. the arduinome project came before this board and updating it has been tricky because it doesn't use an ftdi chip, which is the main detection method for serialosc/etc.

    @jamph: is your setup working? zeroconf explorer didn't show devices?

  • @tehn:

    I'm at work so I'll try your suggestions tonight when I'm home. Hopefully doesn't get completely buried under other problems! I'm hoping to start prototyping some things for a live set I have to do in 2 months.....

  • I do seem to remember that many people here were using the starfire logic which used an ftdi so isn't like the uno. How hard would it be to expand serialosc's detection methods to include the atmega8u2 and 16u2 chips? The Chronome serialosc has been reengineered supposedly to use the mega, but it has to be built and is for mac IIRC.

    I will try the duemilanove which I have heard works but it would be nice for future arduino builders (and myself) to be able to use unos if only serialosc would detect them.

    By the way, I do know that serialosc works on my computer as I am able to use amounra's (aumhaa.com) monomodular plugin to connect other devices via serialosc (polygome, mlr, mash, are just a few I have successfully connected to an APC20 and iPad using lemur).

  • @tehn: although i haven't gotten to test it very much, my setup is working well with a few apps using M5RT (polygome, boinng, etc.)

    but no, zeroconf explorer doesn't do anything when i double click on it, much like iamgolman's experience in this thread:

    http://post.monome.org/comments.php?DiscussionID=12861&Focus=157180#Comment_157180

    and i just realized that discussion was from last september and didn't appear to have a resolution.

    i must say i haven't spent much time with the zeroconf explorer once i got my arduinome functioning.

  • @shimoda:

    unos are not working on windows right now. the reason has to do with how serialosc monitors and queries for monome devices -- because of platform-specific reasons, serialosc on windows can only see FTDI devices, whereas on other platforms it can do a more general query for serial converters.

    unfortunately it's not going to be straightforward to expand the detection methods. unless there's something blindingly obvious that i'm missing, of course. the relevant file is in the serialosc source, in src/detector/windows.c, line 289ish in setup_device_notification(). it's a shitty compromise and i'm not happy with it but i tried several different detection methods and this was the only one that worked reliably.

  • @visinin,

    I assume you mean that the compromise was for getting arduinomes to work with serialosc at all? Unfortunately I don't have a pro version of visual basic so can't compile anything thank links to the mfc library (I think that was required on windows boxes).

    Is this line:
    GUID vcp_guid = {0x86e0d1e0L, 0x8089, 0x11d0,
    {0x9c, 0xe4, 0x08, 0x00, 0x3e, 0x30, 0x1f, 0x73}};
    querying for compatible devices based on chip manufacturer then? I see the 0x3e which I assume to be the target for 03EB, but I could be mistaken as that is what the serial hex flash does to the manufacturer chip, this is readable on macs, not pcs. Is that essentially looking for ids of devices to work with? My understanding is that the arduinome firmware will interface with serialosc once a connection is made. It would seem too simple, but is there possibly another guid somewhere that could be added to the list that serialosc could essentially attempt to connect with? In the details for my uno com port properties page, two of the info options include Bus Type GUID and Device Class GUID, but they are longer codes


    btw, line 249 cracks me up: "port = ftdishit_to_port(devname);"

  • it was a compromise for getting *any* monomes to work. arduinome support as long as they use FTDI chips was pretty straightforward. this uno stuff seems to be easy enough on OSX and Linux (props to owen vallis for figuring that stuff out), but windows is very inflexible and uno support will not be an easy project. sorry :(

    if you want to get in on the development, though, i'm doing all of the official builds with mingw/msys and i'm not sure how MSVC++ will like my code. also, we're not using MFC, just the raw win32 libs.

  • I know almost no C, but am reading up, and looking at all this code... oh that c/Unix course from what was that 1997? Okay, I must be thinking of something else then (MFC). So I assume I could try things and hatch them with mingw (not familiar with msys at all and mingw I've only used to compile MAME).

  • man i'll be honest...i don't remember what that GUID is for, you'll need to look it up in the registry. it's related to the FTDI driver, though. best case scenario is that you'll need to add another GUID and call RegisterDeviceNotification with it, and then in control_handler in the switch for SERVICE_CONTROL_DEVICEEVENT you'll need to check the GUID that the event came from...looks like you just get a devicename in that function, so i think you might have to do some sort of registry lookup...ugh.

    best of luck if you undertake this though.

  • Wow, okay, let me get my greek translator out (lol). Will look into it though. What I don't understand unfortunately is all the binary/hex translation. Thanks for your time.

  • @Tehn

    Ok read the eeprom

    serial # : m64-1017

    I'll be around for the next few hours, hopefully some progress can be made.. if you're around!

    thanks again

    P.S. should I make a new thread? this is getting confusing.

  • I've just tried bonjour browser and there are no services listed in the window...

    That seems bad.. haha. So even though serialosc is running it seems there is a problem here between these services. Hope this helps to diagnose.. I'll keep looking for stuff to try.

  • wish i could help you out man...i got lucky with mine!

    seems like u tried everything with installing all new stuff...do u have monoserial installed?

    and are you usiing the full version of max?

  • but I'm getting the feeling from looking around on here that this is an unresolved problem that is plaguing a few people...

    I really have to do a lot of work on a new set for an important show. Perhaps including the monome is unrealistic.

    Thoughts?

  • did you try the libmonome.dll visinin made available for windows, it's a bit different I think than what shipped. It is linked earlier in this thread. Rename the original so you still have it. I follow the .bak renaming because it's easy to find the original.

    Like aPre said, have you tried monomeserial? You have to disable serialosc to run it and run monomeserial versions of things, but it also works and seems to be more predictable on pc.

  • the full version of max.. hmm I downloaded max from the max site, so I think so. I mean I didn't buy it, so I have to use the runtime.

    I'll try these options shimoda, get back to you in a few.

  • replacing the libmonome doesn't work.

  • So on the positive tip, monomeserial appears to correctly recognize my monome. Not sure I have it properly setup as of right now.. will tinker.

  • well I have it working with monomeserial and the monomeserial test patch I found on here. Its responding as I would expect. So I assume that I can only use monomeserial patches, hope I can find what I need. I also hope this is stable.

    Atleast it works! Too bad about serialosc, I hope you guys get it fixed up.

  • Great! Most of the 'big' apps have older monomeserial versions, of which I believe most features are available. Just glad to hear you've gotten something working. Windows just seems to have these issues. Really hoping that they can be fixed as I can't afford a macbook anytime soon.

  • I hope to find a list somewhere.

    Tried sevenup classic last night... it doesn't really work at all. Seems to start fine, but it breaks down quite quickly. Anyways I'll keep looking for apps, if you have any suggestions I'm all ears (mpc style, looping, clip launching, sampling).

    I wonder if the devs have a time frame for fixing this serialosc thing, because if I can't get things to work correctly with monomeserial.. this box is a 600 dollar paperweight.

  • hey secretL, you can try pages. with pages you can use your monome in monomeserial mode and then use serialosc applications via the 'External Application Page'. the protocols will be translated internally and it should allow you to use any app until the issues are figured out.

    one thing i've noticed is that the device tends to bind to some sort of "computername-Local." hostname. i think it was determined that some ISPs are intercepting your dns resolution of this hostname and that's why turning off internet access fixes it. i wonder if you can just add a line to your hosts file to force the "computername-Local." hostname to resolve to 127.0.0.1 ?

  • Thanks a bunch phortran!! I will try pages asap. Sounds like just what I'm looking for.

    Hmm, disconnecting my network (wifi, lan) didn't fix serialosc for me so I I'm not sure that would make a difference.

  • this device is very intermittent, to the point that I could never use it live. I'm not sure what the deal is but I can barely ever get it to connect to the test app in max anymore and it worked once in pages but with no led functionality....ahhhhhh.