SerialOsc Woes

  • Hey guys. i need some help.

    Finally got around to finishing my arduinome last week(2 years late D=)
    and got it working perfectly in arduinome serial. so i recently updated to the newest firmware and gave serial osc a shot. while the arduinome was detected normally by apps it seemed like none of the button presses were registering and the led feedback was messed up.

    I shut down the serial osc process and fired up arduinome serial and lo and behold all the old apps worked perfectly. using monomebase 4.4's test app all the button presses and led feedback were perfectly normal. i even tested nerdscroll and it worked fine. so i restarted serial osc and fired up monomebase 4.5 to test it out. Lets just say its messed up to hell :(
    pictures here:-
    I could really use some help here. I'm currently on a windows 7 64bit laptop.

    P.s:- i linked to photos of both the arduinome and the monomebase 4.5 screen to show the discrepancy between led feedback in max and on the actual unit.... also.... none of the buttons work at all.

  • ah yep, you're hitting the arduinome baud rate bug.

    go into your serialosc install directory (c:\program files\monome\serialosc if memory serves me right) and replace your libmonome.dll file with [[|this one]].

  • i think i love you :D it totally fixed my led woes.
    and while for some odd reason monomebase 4.5 still wasn't
    accepting button input other serial osc apps are working fine :)