[¿fixed?] Serialosc Mountain Lion Compatibility?

  • fix by visinin (thanks!):

    Was this already covered? I searched and couldn't find anything.

    Anyone else upgrade and having trouble connecting through serialosc?

    I was supposed to show my monome to my new boss tomorrow, but it looks like i'll have to let him down.

  • Did you check permissions as per - http://docs.monome.org/doku.php?id=setup:mac#fix

  • unfortunately that didn't solve it.

  • same problem here. serialosc doesnt work with mountain lion. it doesnt even show up in the activity monitor. hope this can be sorted soon. i'm willing to help if anyone has ideas.

  • Do you have a new ivy bridge prosseser?

  • Damn, this sounds frustrating.
    @ Moldy Wood - can you not just roll back to Lion for the demonstration for your boss?
    Re new processors - I am still using Lion, with the new ivy bridge processor in my new MacBook Pro and had some problems with PartyVan (now sorted see - http://post.monome.org/comments.php?DiscussionID=14846&page=1#Item_9)
    But apart from that issue (which involved issues with a Gen object and the processors) the new ivy bridge processors don't appear to interfere with any other aspects of the patches I use (ie serialosc works) I repeat, I have **not** upgraded to Mountain Lion (& looks like I won't by the sounds of it, until I can be sure I can use my monome!)

  • It seems Apple are fast becoming the Microsoft of the 21st century. I mean that in the worst possible way, of course.

    I'm gonna roll back all my machines to Snow Leopard and XP. Screw progress, I'm a neo neo-Luddite.

    Now where did I put the candles?

  • late 2011 macbook pro, i don't think those have Ivy bridge processors. i've already tried the "lion fix", (never had to do that on lion though), still no luck.

  • Console says-

    launchctl: launchctl:no plist returned for: /Library/LaunchAgents/org.monome.serialosc.plist

    but org.monome.serialosc.plist is indeed there. i dunno what this means, but may be a clue

  • Yah, I have a macbook before the ivy bridge, I just decided to install the GM version of Mountain Lion, to check out the new OS.

    Does anyone know about downgrading back to Lion? Is it a hassle?

  • shouldn't be. i did it from leopard to tiger way back when. wasn't any problem to do at that point in time. don't know about now...?

  • Just use time-machine? If you haven't backed up via time-machine before installation, can you just go to the App store and re-download & install it? If you already purchased it using your mac account it shouldn't be a hassle.

  • I was really hoping that switching from lion to mountain lion wasn't going to be as much of a headache as it was switching from snow leopard to lion. I think the best bet is to just hold off until everything gets straightened out. And though I haven't tried downloading mountain lion yet, I'd like to add that I am running serialosc just fine on lion with one of the new retina MacBook pros with the ivy bridge processor.

  • have you tried launching serialosc from the console?

  • No, I haven't tried that. Do u mean from Terminal?

  • ok, changed.

    i'm really anxious about this fix. I have a my first gig doing VJ control on my monome a week from friday for this big dj in Chengdu, and don't want to lose face by not having a working set-up. Perhaps I should be considering touch-osc...

  • cripes.

    i'll be looking at this, but-- does anyone have information about general adoption of mountain lion? i mean, does max/msp work? ableton?

    i'm not looking forward to having to break all of my working software.

  • The only software I have that isnt compatible with mountain lion is serialosc. Everything else works great, max and ableton included. (as long as you're up to date)

  • odd, somewhat worrying.

    could anyone who's having this problem try just launching serialosc raw from the console?

    > $ serialosc

    and then leaving it open. you should get some debug information as you connect and disconnect monomes.

  • i typed "$ serialosc" in Terminal and i get "-bash: $: command not found". how do you enter commands in Console?

    also when i try to run the serialosc-start.command file, i get

    launchctl start error: No such process

  • path issue?

  • don't type the $.

  • same results
    -bash: serialosc: command not found

    ...when i type "which serialosc" i get nothing. sudo chmod 775 /usr/local/bin didn't help. checked my $PATH variable "echo $PATH" and got-

  • when i run the serialosc installer, Console spits out a bunch of errors

    screenshot attached

  • can somebody upload the serialosc file located in usr/local/bin (MAC)? i think thats all i need

  • https://dl.dropbox.com/u/248085/serialosc.zip

  • thank you!

  • @visinin

    ok now i have the serialosc files in usr/local/bin (i tried uninstalling/reinstalling serialosc yesterday, that must be why they were missing)

    now when i type "serialosc" in terminal and unplug the monome a couple times i get

    serialosc [m0000149]: connected, server running on port 15667
    serialosc [m0000149]: disconnected, exiting
    serialosc [m0000149]: connected, server running on port 15667
    serialosc [m0000149]: disconnected, exiting

    i attached a screenshot of what console says...

    serialosc works now if i launch it from terminal using the "serialosc" command, but it stops working as soon as i quit terminal. it doesn't automatically load when i boot up like its supposed to.

    still seeing the "launchctl: launchctl:no plist returned for: /Library/LaunchAgents/org.monome.serialosc.plist" error in Console.
    (the .plist file is indeed there)

  • > ok now i have the serialosc files in usr/local/bin (i tried uninstalling/reinstalling serialosc yesterday, that must be why they were missing)
    some piece of serialosc is installed, because if the installation didn't work, the serialosc executable that red provided wouldn't work at all. in particular, serialosc needs /usr/local/lib/liblo.dylib, /usr/local/lib/libmonome.dylib, and everything in /usr/local/lib/monome.

    if you didn't have these files, you'd get an error like this when you try to run serialosc:

    > pyreth:src will$ ./serialosc
    > dyld: Library not loaded: /usr/local/lib/libmonome.dylib
    > Referenced from: /Users/will/dev/serialosc/build/src/./serialosc
    > Reason: image not found
    > Trace/BPT trap

    there seems to be the possibility of an installation being in an inconsistent state, where you have //some// of the dependencies, but not others. this seems to be the boat your installation is in. for this reason, **if you are having problems with serialosc, //please// do not start uninstalling and reinstalling it**. it seems to have the potential to create problems of its own. i have a mountain lion seed i'll install on my test box and see what i can find. this may be a mountain lion installer issue.

    > serialosc works now if i launch it from terminal using the "serialosc" command, but it stops working as soon as i quit terminal. it doesn't automatically load when i boot up like its supposed to.
    can you use apps with it?

    it seems apple changed something with launchctl in mountain lion. i'm looking into this. for now, you will need to run serialosc manually from the terminal.

    is mountain lion now available for everybody, or are you guys using the GM seed from the developer program?

  • @MoldyWood:
    okay, looks like you're using the GM. curious to hear about elquinto's setup.
    do you have /usr/local/bin/serialosc? how about /usr/local/lib/libmonome.dylib? we may be seeing some installer weirdness here.

    how comfortable are you with building software from source? it seems like serialosc is running just fine (according to elquinto), but that something in the installer (and potentially launchctl) is messed up.

  • i think what was going on is the installer was having problems installing that one file. everything else (as far as i know) was in the correct spot. before i uninstalled i had everything as it was on Lion/ Snow Leopard. even then, it still wasn't working, although i hadn't tried the "serialosc" command in Terminal.

    yes i can now use apps if i launch serialosc through terminal. and yes i am on the GM seed (developer program).

    thanks for your help visinin, i'm very happy i can use the monome with mountain lion now.

  • Hi
    serialosc works now if i launch it from terminal using the "serialosc" command, but it stops working as soon as i quit terminal. it doesn't automatically load when i boot up like its supposed to.

    Maybe try launching it into the background ie ' serialosc & ' . . .

  • yah, the serialosc command works for me.

    thank you, this will cover my ass for the gig.

  • if my reading is correct, it looks like i have to redo the OSX installer package from scratch because the old way we're doing it is now deprecated. i'm starting on that now.

    thanks, apple. really appreciate it.

  • mountain lion was officially released today. any updates?

  • I was thinking of updating, but glad I didn't yet. Not touching anything on my performance machine I know max is rock solid there, but my desktop has a bit of wiggle room since I don't perform on it.

  • i'm using a separate partition for mountain lion, but i want to fully install it once serialosc is updated. mountain lion seems to fix/improve many of the problems i had with lion.

  • downloading mountain lion right now.
    will have more info once it's all installed (4gb download, ugggh).

  • Good luck visinin & thank you! I'm holding off downloading and installing mountain lion until I can be sure it will play nicely with serialosc & my monomes...

  • from the accounts i'm hearing so far, serialoscd runs just fine once it's installed, but something has changed in how OS X wants installers to be built, so that's where we're hitting a problem. it may have something to do with the introduction of gatekeeper (i.e. we may need to sign the installer now? sigh).

    grumble grumble apple grumble stop breaking my software grumble.

  • So if I have serialosc 1.1 installed already it should be ok? (sorry for my ignorance, but what is the difference between serialoscd & serialosc?)

  • the difference is technical and you shouldn't sweat it. it relates to the name of the actual background serialosc process, which is "serialosc" in 1.0 and "serialoscd" (d for "daemon", a term that means "background process") in 1.1.

    seriously none of you guys should have to worry about it.

  • Thanks visinin. All your hard work on these matters is much appreciated!

  • @visinin

    It couldn't be gatekeeper or signed pkgs because the first thing I did when I installed mountain lion was turn that feature off.

    Anyways, wish u best of luck. I hope it's not too tricky.

  • having problems over here as well. serialosc command in terminal gives me this:

    serialosc [m64-0310]: connected, server running on port 12332

    but nothing works.

    i know very little about terminal, but it seems as though that result is a good one. don't know what i'm missing. a dummy proof walkthrough appreciated in advance.

  • activity monitor says it is running when i launch from terminal but no apps work.

  • So if you have it installed and upgrade the OS it should work fine? Thinking of updating to ML this weekend.

  • okay here's the word.
    serialosc does not currently support mountain lion so if you upgrade you should not be under any assumptions that it will work.

  • That's a bummer.