[¿fixed?] Serialosc Mountain Lion Compatibility?

  • you should still be able to compile serialosc from source even if the installer is bonked (currently working for me)... I even have homebrew formula's and can walk people through the setup on irc... results not guaranteed

  • That's it! I'm digging out my LCII from the darkest recesses of my attic, and resurrecting the old BBCB from the basement... I'm gonna play Elite and fiddle with Re-Birth and have no other truck with computers for the rest of my days. Technology sucks. It's all a scam to keep you buying the next platform with it's promised "fixes". Ya ever see Steve Jobs and Bill Gates in the same room? No! They're the same, man, I'm tellin ya. Ya hear me, sheeple? S.C.A.M. SCAAAAAAAM.... Man, the number of times I've upgraded or switched platforms and they're all the same. They just trying to grind ya down and make you feel worthless so you'll eventually substitute avarice for self-esteem, judging your own worth by the possessions you own (or really, man, your possessions own you... Don't they? You know what I'm talking about...) and other people's perception based on crass commercialism and capitalism!!! RISE UP! SHUN THE TECH! BE ONE WITH YOUR SPEAK 'N" SPELL AND DENY THAT WHICH WAS DEVELOPED WITH TOUCH TECHNOLOGY AND OTHER SUCH GIMMIKKKS... IF IT AIN'T 20+ YEARS OLD, DON'T TRUST IT!!!!!!

    On a more serious note, is Mountain Lion, other than fucking up serialosc, running smooth for everyone? I'm starting to have serious CPU issues with Lion and am considering upgrading at least one of my Macs to circumvent that.

  • @ thealphanerd, that's very good of you to offer help with that.
    Is it the installer or something else though?

    @dm483 - yes! I hear you (starts looking for the commodore Amiga that he is sure is still somewhere in storage)

  • Dont worry-Apple will bring out Hello Kitty Lion next week to adress these issues...

  • art punk it would involve installing developer tools and compiling from source

    step one is to download and install Xcode... that will take a little bit

  • Hi
    Which branch is supposed to build serialoscd?
    Have built the master and ipc branch but both build 'serialosc' for me?
    Was able to build an OSX installer from the main branch and modded serialosc-installer and install with 'Control' click to temporary bypass Gatekeeper.
    But no hardware to test against . . .
    Will see how LeMonArc goes . . .

  • ipc branch will build serialoscd.

  • Are we still on a 'don't upgrade to mountain lion' status? When might that change? Or is it 'upgrade and compile serialosc for yourself?'

  • bump back up past the spam

  • From the scattered messages on other posts, it looks like it's getting rewritten at the moment (auto backwards compatibility, dropping /mode, and hopefully adding ML support)

  • Thanks to visinin for all of his help with trying to get serialosc and mountain lion working correctly so far. Unfortunately, it looks like the fix might be longer then a lot of us expected. I might have to downgrade back to lion today, as I'm starting to go through monome withdrawal.

  • so i'm running mountain lion on my main dev system right now, and serialosc definitely works. however, i'm seeing installer issues, and that's a frustrating show-stopper.

    installing from source will //always// be a supported way to install serialosc. there's nothing special we put in the installers, everything's up on the github. that being said, if you're not familiar with compiling from source, it will probably be frustrating, and i can't help everybody out beyond some basic instructions and prerequisites (dependencies).

    i believe thealphanerd has done some work on making homebrew formulas for serialosc and libmonome though, yes?

  • The version you have running on mountain lion you compiled/installed from source? (ie, it didn't work when you went from lion to mountain lion)

  • So, //**can**// I actually upgrade to Mountain Lion and be confident that my **//previously installed serialosc//** will work, or should I be cautious? (sorry if this is a dumb question, I think it's sort of the same question Rodrigo asked, but different...errr...)

  • +1 to artpunk's question

  • @artpunk @declutter I would not assume this at all. I upgraded to Mountain Lion and serialosc (which I had installed and been using under Lion) immediately stopped running. I can work around it by triggering it via terminal, but this is hardly the ideal situation and no-where near performance stable.

    Upside is everything seems to be running way faster.

  • Thanks for the answer paul! I will download the update but make a bootable usb of it rather than install it just yet. Looking forward to a serialosc update/solution!

  • Hi fellows. I'm a relatively new monome user, I have a 64 and never imagined that I have to worry about problems with monome drivers before upgrading to mountain lion. So when I pluged my monome and nothing happens I was shocked. So I start to search for help and found this topic, and for what I read already, if I understood well, we have to wait for a new version of serialosc with new installer to monome work again in mountain lion, that's it?
    I read the files that need to be installed and made a picture of my 3 main foldes where the files need to be, can anyone help me and confirm if my files is all ok in the folders? My problem is, no device detected in monome test app. And by the way, I made my homework, check the lion privileges thing on terminal, installed the last FTD drivers and serialosc version, etc, looks like everthinng is fine, I guess so at least. Thanks a lot for all you gyus info and support. Best. JB.

    863 x 776 - 221K
  • previously installed serialosc won't work.
    apple has moved some things around. it runs but doesn't autostart.

    if you're in that situation, just run "serialosc" (or "serialoscd" for 1.1) from the terminal until i get the autostart sorted.

    that being said, serialosc on mountain lion is still unsupported officially.

  • Thanks visinin - Is there any relatively simple way to run a terminal script on startup that does this (runs serialosc(d)?)

  • @Raja, thanks! I'll give that a try, much appreciated!

  • I have upgraded to ML; serialosc isn't running by default, and the serialosc-commands don't work to get it running in the background; but I _can_ run it from the command line in terminal and then leave it running and get on with monome-ing as usual. Haven't tried anything more complex than that.

  • Hi declutter, I haven't downloaded the update yet, but have been looking at different options, which serialosc commands did you use & how did you pop them into startup? I was looking at using something like lingon

  • upgraded to ML a few days ago, with an existing install of serialosc 1.1.

    as noted serialosc doesn't run on start-up, but when running it from terminal it's been fine.

    getting my head around the map level messages on monome and arc at the moment, with a lot of long messages sent very quickly. haven't had any problems or odd behaviour.

  • Serialosc has been running fine in Mountain Lion (manually enabled via Terminal). I've been bouncing data between Max, Live and Osculator without any problems or lag.

    I even left everything running overnight and it was still trucking along in the morning. Normally I inevitably wake up to something broken. But, if memory serves, that was predominantly prior to switching to an Apple system ;)

    A fix for this problem would be nice, but I'll be fine for the interim as the fix via Terminal seems pretty solid on my end.

  • @artpunk - all I'm doing is opening the 'Terminal' app, and typing 'serialosc'.

  • Thanks declutter, ok so I have worked out I can just type serialosc into the terminal window to start the process, this surprises me, I thought I would have to navigate to usr/local/bin first to run serialosc (shows how little I really understand about this stuff). So...
    I save a file with simply serialosc in it as a .command file to run in launchagents and it should do the trick on startup? Has anyone actually tried this? (I will now and get back to you)

    Shit, run into my first hurdle, how should I save a terminal command to run in a .plist in LaunchAgents? God I feel dumb.

    OK - I have used lingon 3 to try and run serialoc on startup/login but somehow it doesn't seem to work, probably something I am doing wrong.
    Sure, I can run monome apps doing the terminal solution, but I would relly love to just be able to start an app at anytime without having to run terminal. Oh well...
    I'm looking forward to a solution? (hopefully)?

  • LOL! Raja, you are a genius. The **Login Items** solution did the trick.
    For some reason your serialosc-start commands were not recognised by my Molehill Pussy Terminal, I got this in the window:

    Last login: Mon Aug 6 21:21:03 on ttys000
    You have mail.
    /Users/camstephen/Downloads/stuff/serialosc-commands-osx/serialosc-start.command ; exit;
    imac:~ camstephen$ /Users/camstephen/Downloads/stuff/serialosc-commands-osx/serialosc-start.command ; exit;
    launchctl start error: No such process

    [Process completed]

    but a different .command with this:

    //cd /usr/bin/local

    worked on log in. I probably could have just left the thing as //serialosc// but thats what I tried first (well, second, after yours spat the pussy, err I mean dummy) as a new login item under accounts in System preferences and...it worked! I don't care about the terminal window being open, as long as serialosc is running from the get-go, it's a beautiful thang!

  • I was actually curious about the terminal commands, but now that I know it's just typing in 'serialosc' I think I can live with that.

    I'm wondering what version of serialosc I have running, and if it needs to be 1.1

    Either way I think I'll upgrade my desktop to ML based on this info, and wait until it's completely sorted out before putting it on my laptop(performance machine).

  • I think I have 1 running on my iMac and 1.1 on my PowerBook Rodrigo. Party Van seems to run just fine on both... (haven't installed ML onthe laptop yet)

  • So when you load serialosc via terminal, do you need to leave terminal open the whole time? (serialosc seemed to go away once I quit terminal)

  • Step4 seemed to just change what I typed in to "serialoscd" (instead of serialosc). If I just hit enter after step3 and quit terminal it seems to hold put.


  • Or just launch it into the background using ' serialosc & ' . . .
    It should pop up a job and process number - note the process

    now type 'jobs' - see serialosc is running in the background

    Just grab a decent *nix cheatsheet . . .&, fg, bg, jobs, ps, Ctrl/z away . . .

  • So, as I understand the process so far...
    If I type
    //serialosc &//
    into my command script to use in my log in items, then serialosc will start running in the background.
    Does the terminal window stay open until shut manually (but in this case serialosc keeps running in the background) ?
    Is there a terminal command (to insert after the above 'serialosc &') to close the terminal window as part of that whole process without having to close it manually? Is it //nohup//?
    Sorry, I am asking after searching on the web, but can't test it at the moment as I am on my iPad away from my computer...

  • wow, that screen tip is working perfectly! no need to keep the terminal window open anymore. thanks raja :).

  • yeah it works relatively well...for the moment....

  • OK back home from work so can test out my command script.
    First I uninstalled serialosc 1 and installed serial osc 1.1 because...well, just because. So for the record, on my imac core 2 duo 2.9ish Mhz 4GB of RAM running ML:

    serialoscd &

    in a command script set as a run at login item briefly opens a terminal shell, starts serialosc, keeps it running in the background and quits the terminal shell window. Terminal is still open, just no window. Haven't worked out a way of quitting terminal from my command script yet, or even know if it is a good thing to do or possible...
    One word of caution however, for those like me who may not know: I logged out & in a few times to test my changes and make sure serialosc was running. When I went to connect partyvan, I noticed several choices of the same monome to connect to with (1), (2) etc after my walnut 64's serial number. Hmmm, never had that before I think! When I connected (one of them) to the Party it was acting screwy. I thought it must be because of the multiple instances of monome-ness. So I restarted the computer, serialoscd started, terminal window went away and connecting in monome test or the Party Van gave me only one monome to connect to and all worked smoothly again...so I'm guessing logging out leaves serialosc(d) running in the background and running that script on each login just started another new instance of it? (& this can cause problems with patches)?
    I am living and learning (& unfortunately usually //forgetting// soon after the learning bit!)

  • i love all of you equally.

  • yeah if you run serialosc several times then everything will break when you try to use it.

  • hey guys, just an update here --
    figured out the problem. the installer actually seems to be fine...not sure what the deal with it was. it may have been the repeated uninstalling and reinstalling, so, in the future, don't do that.

    the problem seems to just be in the auto-starting. there were some syntax errors in the configuration file we ship and earlier versions of OS X were just more lenient with us.

    i'll get an updated installer out tomorrow. thanks for your patience, and apologies for the delay.

  • thanks for the update visinin. so with this updated installer, will that make serialosc fully compatible with mountain lion at that point, or is there still some additional work that will still need to be done after that? thanks for your continued effort towards finding a solution.

  • Nice! Looking forward to setting up ML on my laptop finally.

  • any news on the update visinin?