insanity_3 (updated 19/12/2012)

  • for me the preset doesn't 'appear' to load. a tap on the bottom row buttons, and instantly all is right with the world.
    i'm on a mac though.

  • not working for me :/
    in fact i noticed something weird... while the app loads buttons in all the columns, as soon as i press a page button, all the button columns change to faders...
    weird huh?!

    btw dadek, which version of max are tou running?
    i'm thinking of istalling 6, might fix it :/

  • tested on maxRT 6.05 and the problem's still there :x
    dunno what else to try, open to suggestions

    EDIT: Apparently i need to tap some buttons (other than the page select buttons) as soon as i load the preset, and right after that, if i press a page select button everything seems to be working fine :)

    weird issue though :x
    I just was lucky enough to discover a workaround by accident
    hehehe, off to mapping! :)

  • glad you got it sorted. a really versatile app i'm thankful for.

  • I'm encountering another problem while using pages on Insanity. Some LEDs won't light up after I've changed page :/
    Checked for conflicting midi CC/channel values, but everything is uniquely set...

    Any ideas what might be wrong?
    I'm using insanity 2.05 and trying to map it in Traktor Pro 2.5

  • Bumping for insanity 3.0 :)

  • hi there.

    same here!
    i´m having problems here to load my preset files. loading my saved preset files has no affect and won´t change the deafult settings in the insanity.

    tried to save and load in both formats xml and json.
    argghh.. have to re-map all over again.

    btw. i´m on osx 10.6.8 / max runtime 6.0.2 / serialosc / insanity 2.05

    whats the workaround you were talking about ?! hehe :-)

  • @monoaural
    I've encountered some problems while saving my own presets.
    Just open insanity, make a few changes (nothing too elaborate, just for testing purposes add some sliders/buttons) save your patch, close everything and then reopen.
    From what i remember (it's been quite some time since i was doing this) the insanity app has an issue when it comes to saving over the same patch. Let's say for example you add some sliders and buttons, save and then you decide to make some adjustments to that and save over it's not gonna work. So if you need to save OVER try picking a different filename for your patch (I was using numbers).

    Also when loading the patch, as soon as i connect to the monome I have to push a random button on it, and then a page button (bottom row) so that everything lights up and behaves correctly.

    Try those and tell me if it's working out for you! :)

  • @fozzy
    yep. you are the man ! this workaround seems to work for me. just the midioutput and the midi led input won´t be safed which isn´t a big deal...

    all righty. have to back to the button work. have to do a nice job today. its going to be lots of fun ... hehe :-)
    cheers buddy!

  • i have another strange thing going on over here.

    i just finished to map page #1.

    column 1-15 - buttons
    column 16 - fader

    then, started to map page #2.

    as i switched back to page #1 all LED went off but kept the value settings. no visual LED feedback for the buttons. but yes for the fader?!
    the fader (page #1, column16) kept nicely the LED visual fedback.

    i don´t get this.

    btw. i´m trying to re-map an apc40 mapping for a session in ableton for the gs128 using insanity128..

    mmhh weird..

    little update:
    just mapped page#2 with only faders.

    this faders page seems to work like a charm...

    so. only the buttons cloumn within a pages don´t seem to update the values afters switching pages...

    actually, another thin that i noticed is kind of a double press. sometimes i have to hit a button twice until it will be triggered.
    btw. all buttons are mapped in toogle mode.

  • @fozzy
    any workaround for this aswell :-)

  • There's no work around on that I'm afraid :/
    There are various issues with the LED i/o while changing pages, and although I've checked numerous times for midi channel/cc overlaps the problem persists.

    Unfortunately stevieraysean didn't have time to rewrite the patch, and the actual "glitch" is kinda hard to locate since the insanity patch consists of various other subpatches from different authors etc.

    Hopefully there will be a version 3.0 of insanity! So let's bump for that!

    *As for the double press issue, you just have to deselect "toggle" (in case you are controlling button function via the software/DAW you're using)

  • @fozzy
    ah o.k- thanks dude. lets hope for 3.0.

  • Hi guys, will see if i can fix these bugs sometime in the near future. If not start on a new cleaner readable version.

    I have many different patches out and to be released. Im behind on all of them really. Study has been far more time consuming than thought it would be.

    Glad to see so much interest in this patch. Will try make things right for yall.

  • you are my hero!

  • **new** version in the oven.

    all .mxj (java) interior. fast. accurate. a bazillion dimension arrays.

    //expandable// set of midi objects. thinking multi column sliders for extra resolution like dj monome app.. x-y pads. pattern recorders..

    will start with the standard button/sliders though.

    top **or** bottom page changing row buttons!!!

    maybe even **tilt/ physics** sorta stuff..

    //whale-skin hubcaps, buy one get one free, send no money now, no easy payments, tax-deductable, biodegradable, whacky waving inflatable arm flailing full-frontal lobotomy _insanity to the future!..//

  • Wow, it sounds like the perfect buddy for the dj-mlr ! Really excited about the multi columns sliders....

  • so waiting for this!

  • so..... I think this is ready..

  • was thinking to bump this today. happy holidays! gonna try this out right now. thanks stevieray!

    can't wait to try it out!!!
    Thanks stevieraysean!


  • is this working for anyone?
    i can't connect a monome, none show up in the list.
    inSanity2 still works fine.
    tried max 5 and 6, on OSX.

  • need the latest serialosc. the one that works without zeroconfig.

    sorry, should have mentioned that.

    I can do a version with the older one if this is an issue for people.

  • i thought i had latest serialosc. will grab it and report back. thanks.

  • newer serialosc did the trick. now to porting up my setups.

  • cool, be sure to give the saving a good test. i'm pretty sure its solid though...

    sorry about no backwards compatibility on the loading front.

    anyway, be sure to try out sliders with varying width and height.. means you can get extra resolution or put buttons underneath them..

  • on win7 64bit here
    installed the new serialosc v1.2a
    Installed the latest JRE (Version 7 update 10, 64bit)

    When I open the patch I get
    mxj could not find Java 2 Runtime Environment
    Error Loading

    any ideas?

  • was it working before updating java?

    i take it you've restarted already?

  • *didn't have JRE installed in my machine before, just did it for insanity3

    I did restart and i also installed the 32bit Java version
    just in case... but still didn't work (different error this time though)
    Has anybody got it working under win7 64bit and with what JRE?

    Tested with monome test 1.4 and apparently the new serialosc 1.2a works fine
    so it's just a JRE issue

  • I have not jumped over to serialosc. any chance of monomeserial version?

    could you maybe make a video showing the new features? Love insanity!

  • Really can't get my head around this issue
    java -v on the command prompt shows that i do have the latest version install, however i still get the error :

    mxj: could not find Java 2 Runtime Environment.

    Error loading:
    (mxj) mxj_platform_init failed. Could not initialize the Java Runtime Environment.
    Please check your Java installation.
    Unable to create JVM
    newobj: zl.join: No such object

    Apparently the Java Virtual Machine (JVM mentioned in the above error msg) can't start... any ideas?

  • yup... tried max6, same error
    tried various updates for JRE1.6 since everybody is telling me that JRE 1.7 versions are kinda messy, but still I'm unable to run the virtual machine.

    Apparently i need to set the heap size lower,
    hopefull will get my head around that

    Would be nice to hear if anybody else had a similar Java issue
    (sould use a heads up!)

  • @Kris prolly not gonna make a monomeserial version at this stage. will make a video soon.


    says to try installing 32-bit java.

  • just installed 32bit Java and it "works"
    but both under Max5 and Max6 i get this new error

    zl.join: zl.join: No such object
    binding to port 17812
    jpatchline_completeconnection: index out of range.
    binding to port 17925

    also my monome doesn't show up in the patch connect :/

  • the zl.join thing is from the serialosc.maxpat

    basically it's new max6 formatting so i'd recommend using that.

    the monome not showing up is a bother. something with serialosc 1.2

  • monome shows up and connects fine in the monome_test 1.4
    any ideas/workarounds?

  • try this.. updated serialosc.maxpat

    theres a refresh devices in the + menu.

  • oh man, this version is sweeeeeet!
    at first i was having a hard time getting my head around it
    but the multicolumn faders are AWESOME

    I love the fact that you could give "value" in each cc button, so you can essentialy make a button of your own dimensions simply by giving the respective buttons the same value!

  • This is very much off topic, but what changed with [zl] between max 5 and 6 is easy to correct for.

    Essentially, what you see now as [zl.join] and [zl.slice] and [] etc didn't exist before. You had [zl join] and [zl slize] and [zl group] instead.

    Those still exist. The dot notation helps w/ autocomplete and the inline help stuff, but is otherwise optional -- if you revert to using a space instead of the dot, that code will work in Max 5 and Max 6.

    I try to be considerate with that in my own stuff, but I won't for too much longer. When Live 9 comes out, Max For Live upgrades to 6, removing the one compelling reason to continue supporting 5. Anywhere else, you can just install separate runtimes.

    (if you're a Max for Live user not upgrading to 9, you are on your own in a desolate wasteland)

  • On osx 10.5.8, monome connected, but I can't seem to effectively operate the patch. Insanity 2.05 is working perfectly.

    Getting these messages:
    Could not load class 'insanity_grid'
    at com.cycling74.max.MXJClassLoader.loadClazz(
    at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(
    at java.lang.ClassLoader.defineClass(
    at java.lang.ClassLoader.defineClass1(Native Method)
    java.lang.UnsupportedClassVersionError: Bad version number in .class file

  • what version of max are you using?
    if you're using 5 i'd suggest 6.

    is java up to date on your system?

    sometimes the java just doesn't load in max and i have to relaunch max. dunno why.

  • Max 6, yes.

    Java is SE6 1.6.0_26-b03-384
    I'm pretty sure it's the most recent update for Leopard.

  • might have to recompile it targeting that java version. gimme a day or two

  • Damn, you the man.

  • wuuuaaaoooohhhh. well done stevie.

    +1 you´re the man

    quick note. can´t use it together with _pages. extapp_ does not apear in insanity dropdown menu. ?!

    max 6.0 here haven´t tried on 6.1 yet.

  • @Chris Aiello having trouble getting this done.. not sure exactly what commands i need to use. if you wanna try it yourself the source files are included in the insanity folder.

    download bluej.

    add /max 6/cycling '74/java/lib/max.jar (wherever it is on your system) to bluej's preferences/libraries

    open insanity_3/java/package.bluej

    tools - compile.

    and it should compile for your java version..

    @monoaural yeah the latest serialosc.maxpat doesn't use bonjour so pages or griddle don't work anymore.

    kind annoying. might change back to the older one till something else has been worked out to do inter-app connecting..

  • Stevie, I very much appreciate your time and help.

    I tried what you said, but still getting the same error messages.

    It's possible that I just don't understand how to operate insanity 3. When I click on or press buttons in edit mode and change their properties, those changes remain on the gui regardless of clicking on or pressing any other button. And clicked/pressed buttons remain yellow on the gui until they are unclicked. And no changes stick to any buttons.

    Is this a Java issue? Or am I just not understanding how to use this? I understood Insanity 2, so I'm not completely inept.